HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   DNS Problem with mailserver (http://www.howtoforge.com/forums/showthread.php?t=5531)

pesja 14th July 2006 12:55

DNS Problem with mailserver
 
Hello,

After I was setting up an new domain, I corrected the DNS settings to a "normal" value as:

a record mail.mydomain.com -> xxx.xxx.xxx.xxx

and a NS record (priority 10) pointing at mail.mydomain.com

I restarted the server (to be sure) and waited about 1 day. Then I tried to send mail to info@mydomain.com and admin@mydomain.com but none of the boxes received mail.

So I went to DNS Report which gave me the following error (domain was edited):

ERROR: I couldn't find any MX records for mydomain.nl. If you want to receive E-mail on this domain, you should have MX record(s). Without any MX records, mailservers should attempt to deliver mail to the A record for mydomain.nl. I can't continue in a case like this, so I'm assuming you don't receive mail on this domain.

and:

ERROR: I could not find any mailservers for anyhost.nl.


Except the "open DNS" servers DNS Report reports that all the other tests as pass. So except de mailserver settings everything is working.

Wat is going wrong. I used the perfect setup of Debian Sarge and everything else is working splendid.

pesja 14th July 2006 13:13

Sending out mails is working fine.

I thought I did solve the problem, with check the co-domain boxes. But still nog receiption on the mailadresses

Ben 14th July 2006 13:18

What tell the tools from www.dnsstuff.com?

What gives a

dig yourzone.tld. +trace
or
dig -t mx yourzone.tld. +trace

EDIT ok, saw your edit...

pesja 14th July 2006 14:21

did a ping to mail.mydomain.com -> OK so it's existing.

I really do not know what's wrong. the bind-file of my.domain.com is looking fine and it's all pointing the right directions.

From DNS report I only got som minor fails (open DNS etc) but still it's not finding any mailserver and mx-records.

=======

I'm using the VMWare Image which was made by Till. As he wrote in another topic it is an perfect install of Debian 3.1 + ISPConfig.
Maybe that's the problem. I don't know.

After I made mydomain.com I also made ns1.mydomain.com and ns2.mydomain.com (pointing to another IP) So mydomain.com does has it's own nameserver (ns1) pointing to it's Ip-adress.

I made also another domain which pointed to external dnsservers and that domain is working perfectly (mail 100%).

When I look at the dns-reports of the domain with the external dnsservers and to the report with the internal dnsservers it's the same, except the part of the mailserver (mx)

Please help me to make it work!!

IntnsRed 14th July 2006 14:31

This sounds like the exact same problem I had in this thread. Could the solution be there?
________
East Liberty Auto Plant

pesja 14th July 2006 14:42

Thank's man. That solved the problem. Only removed that little word in front of the MX record and restarted bind.


All times are GMT +2. The time now is 12:46.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.