HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Tips/Tricks/Mods (http://www.howtoforge.com/forums/forumdisplay.php?f=29)
-   -   phpmyadmin not working correctly? Check your suhosin settings... (http://www.howtoforge.com/forums/showthread.php?t=55232)

talkingnews 4th December 2011 23:12

phpmyadmin not working correctly? Check your suhosin settings...
 
This one bugged me all afternoon - I'd click on, for example, search results, and it just did nothing. Or I'd change the amount per page to over 100 ...and nothing.

Finally, I looked at that bit of phpadmin no-one looks at, the very bottom of the front page!

And it said

Quote:

Server running with Suhosin. Please refer to documentation for possible issues.
You can read all that if you want, but to cut to the good stuff...

edit /etc/php5/fpm/conf.d/suhosin.ini

add
Code:

suhosin.request.max_vars=2048
suhosin.post.max_vars=2048
suhosin.request.max_array_index_length=256
suhosin.post.max_array_index_length=256
suhosin.request.max_totalname_length=8192
suhosin.post.max_totalname_length=8192
suhosin.get.max_value_length=1024

save,
service nginx restart
service php5-fpm restart

and there you go! phpmyadmin all working properly again! Hope this manages to save you the couple of hours I spent looking, and teaches ME to look more closely at the foot of pages... :)

EDIT: Sorry, mods - I thought I was posting in the hints and tips section. Would you mind moving this post if you feel it belongs there?


All times are GMT +2. The time now is 18:04.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.