HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Mail password not accepted / ISPConfig (http://www.howtoforge.com/forums/showthread.php?t=55200)

midcarolina 2nd December 2011 02:21

Mail password not accepted / ISPConfig
 
Hi,

This is the strangest thing with my mail system. Let me give my set-up first:

Fedora 14 x86 64 w/ ISPConfig 3.0.4.1 Postfix, Dovecot (Falko's Perfect Server)

The php mailer is working fine - example mail delivered through wordpress or email marketing. When a client sets up the mail server mail.example.com (as smtp, imap, pop), MS Exchange, Thunderbird, and several other mail systems recognize the servers right away, but the set-up can never be completed because the password is always refused. We have tried on several domains and changed passwords numerous times, each time with the same result. I would tell you the maillog, but it is completely empty. Only the root mail has any info, all of which pertain to fail2ban, etc.

Any ideas? Thanks

Ghostdare 2nd December 2011 08:47

Do you have an web-mail where you can try to login? Maybe you don't heva courier or dovecot working.

midcarolina 2nd December 2011 16:54

Hi Ghostdare,

Webmail has never worked on any of my servers so that is not a good indicator for me. Frankly, my thoughts and opinions of webmail are very little to put it mildly. I don't even offer it as a service.

I do know that dovecot is (or should be) working just fine. Stopping and starting the service works just fine. I have always had issues w/ ISPConfig not accepting passwords.

Thanks.

falko 3rd December 2011 16:02

Quote:

Originally Posted by midcarolina (Post 268666)
I would tell you the maillog, but it is completely empty.

This is strange. There must be something fundamentally wrong with your setup. Do the MX records of your domains point to the correct server?

midcarolina 3rd December 2011 17:36

Hey Falko,

Ok, I have since made a discovery that has to have something to do with this. I have 2 boxes. Both using the EXACT same everything. They were built using The Perfect server ISPConfig 3 and Fed. 14 x86_64 and Dovecot. Box one mail works fine. So, for me the first thing I like to do is follow file paths and see what's inside the one that works vs. the one that's not. Especially since they are identical. Here is what I found:

/etc/postfix/main.cf and master.cf - same

Box 1 (working mail) /etc/dovecot.conf versus box two

Box 2 (not working) also contains /etc/dovecot.conf BUT it also contains a Dovecot folder as well off of /etc like

/etc/dovecot/ with folder conf.d and file dovecot.conf. Inside of /etc/dovecot/conf.d/ are 13 CONF files (auth, imap, pop, pop3, etc.) and 9 auth EXT files.

Strange. The first box does not have the folder 'Dovecot' off of /etc/ This has to be the conflict of some sort, but I don't want to willy nilly delete it.

Thanks Falko!


All times are GMT +2. The time now is 02:30.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.