HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Suggest HOWTO (http://www.howtoforge.com/forums/forumdisplay.php?f=9)
-   -   The Perfect Server - CentOS 6.0 x86_64 [ISPConfig 3] (http://www.howtoforge.com/forums/showthread.php?t=55195)

rewards 1st December 2011 18:44

The Perfect Server - CentOS 6.0 x86_64 [ISPConfig 3]
 
Hello,

http://www.howtoforge.com/perfect-se...64-ispconfig-3

I have have tried to install ISPConfig 3 on a Centos The Perfect Server - CentOS 6.0 x86_64 [ISPConfig 3] at this page http://www.howtoforge.com/perfect-se...64-ispconfig-3, on a freshly installed Centos 6.0 64bit and I found some problem and they are;

1- At page 3, http://www.howtoforge.com/perfect-se...ispconfig-3-p3 7 Enable Additional Repositories And Install Some Software, the import command does not work and here the error message;

[root@server1 ~]# rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY*
error: /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6: key 1 import failed.
error: /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-Debug-6: key 1 import failed.
error: /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-Security-6: key 1 import failed.
error: /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-Testing-6: key 1 import failed.
error: /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6: key 1 import failed.
error: /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag: key 1 import failed.

also this command does not work eaither.
rpm --import http://dag.wieers.com/rpm/packages/RPM-GPG-KEY.dag.txt

[root@server1 ~]# rpm --import http://dag.wieers.com/rpm/packages/RPM-GPG-KEY.dag.txt
error: http://dag.wieers.com/rpm/packages/RPM-GPG-KEY.dag.txt: key 1 import failed.
[root@server1 ~]#

The webmail gets installed and can be accessed at this page, http://www.howtoforge.com/perfect-se...ispconfig-3-p6. I found two problems here and they are;
1- I cannot access the site using http://server1.example.com/webmail
2- I can access the site using IP address 192.168.0.174/webmail but when I try to login with user name falko and password falko I get error message saying "ERROR
Unknown user or password incorrect."

On this page you have a typo problem, http://www.howtoforge.com/perfect-se...ispconfig-3-p5, for 15 Installing Apache2 With mod_php, mod_fcgi/PHP5, And suPHP and the command;

yum install php php-devel php-gd php-imap php-ldap php-mysql php-odbc php-pear php-xml php-xmlrpc php-eaccelerator php-mbstring php-mcrypt php-mssql php-snmp php-soap php-tidy curl curl-devel perl-libwww-perl ImageMagick libxml2 libxml2-devel mod_fcgid php-cli httpd-devel

the mssql-php perhaps should be mysql-php. The yum gives problem when it reaches to that line.

falko 2nd December 2011 17:32

Quote:

Originally Posted by rewards (Post 268647)
[root@server1 ~]# rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY*
error: /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6: key 1 import failed.
error: /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-Debug-6: key 1 import failed.
error: /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-Security-6: key 1 import failed.
error: /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-Testing-6: key 1 import failed.
error: /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6: key 1 import failed.
error: /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag: key 1 import failed.

also this command does not work eaither.
rpm --import http://dag.wieers.com/rpm/packages/RPM-GPG-KEY.dag.txt

[root@server1 ~]# rpm --import http://dag.wieers.com/rpm/packages/RPM-GPG-KEY.dag.txt
error: http://dag.wieers.com/rpm/packages/RPM-GPG-KEY.dag.txt: key 1 import failed.
[root@server1 ~]#

Seems as if the keys were imported before, so you can ignore this.

Quote:

Originally Posted by rewards (Post 268647)
1- I cannot access the site using http://server1.example.com/webmail

Does server1.example.com point to 192.168.0.174?

Quote:

Originally Posted by rewards (Post 268647)
2- I can access the site using IP address 192.168.0.174/webmail but when I try to login with user name falko and password falko I get error message saying "ERROR
Unknown user or password incorrect."

You must create an email account in ISPConfig first and then log in with the email address and the password.

Quote:

Originally Posted by rewards (Post 268647)
On this page you have a typo problem, http://www.howtoforge.com/perfect-se...ispconfig-3-p5, for 15 Installing Apache2 With mod_php, mod_fcgi/PHP5, And suPHP and the command;

yum install php php-devel php-gd php-imap php-ldap php-mysql php-odbc php-pear php-xml php-xmlrpc php-eaccelerator php-mbstring php-mcrypt php-mssql php-snmp php-soap php-tidy curl curl-devel perl-libwww-perl ImageMagick libxml2 libxml2-devel mod_fcgid php-cli httpd-devel

the mssql-php perhaps should be mysql-php. The yum gives problem when it reaches to that line.

No, no typo. I install php-mysql and php-mssql. If the command doesn't work for you, there's something wrong with your setup.

rewards 3rd December 2011 09:03

Hello,

The server1.example.com point to 192.168.0.174. I did as instruction by putting 192.168.0.174 server1.example.com server1 in /etc/hosts file. I don't know what else needs to be done? I still can access only by IP address only. In ISPConfig, I clicked Email, added domain called server1.example.com, Domain example.com, spamfilter not enabled. Then, I added a mailbox for falko, real name Falko, email falko@example.com, password falko, Quata 10MB, sent copy to is blank, spamfilter not enabled, Enable Receiving box is checked, Disable IMAP and Disable POP3 boxes are unchecked and saved it. I still get Unknown user or password incorrect error message when I tried to login. Thank you for reply in advanced.

falko 4th December 2011 22:25

You must log in with the full email address, not just the local part, so the username would be falko@example.com.

Quote:

The server1.example.com point to 192.168.0.174. I did as instruction by putting 192.168.0.174 server1.example.com server1 in /etc/hosts file. I don't know what else needs to be done? I still can access only by IP address only.
Modify your client PC's host file and add a record for server1.example.com or set up a local DNS server that resolves server1.example.com.

rewards 5th December 2011 07:57

Hi Falko,

You deserve a gold medal. Thank you for your responses. Now Falko can login to http://192.168.0.174/webmail. I still had problem installing php-mssql and I hope it would not be a big deal to have that. The message was;

[root@server1 ~]# yum install php-mssql
Loaded plugins: fastestmirror, presto, priorities, refresh-packagekit
Loading mirror speeds from cached hostfile
* base: mirror.5ninesolutions.com
* epel: mirror.hmc.edu
* extras: mirrors.login.com
* rpmforge: fr2.rpmfind.net
* updates: mirror.san.fastserv.com
1070 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-mssql.x86_64 0:5.3.3-1.el6 set to be updated
--> Processing Dependency: php-pdo >= 5.3.3 for package: php-mssql-5.3.3-1.el6.x86_64
--> Processing Dependency: libsybdb.so.5()(64bit) for package: php-mssql-5.3.3-1.el6.x86_64
--> Running transaction check
---> Package freetds.x86_64 0:0.91-1.el6 set to be updated
---> Package php-mssql.x86_64 0:5.3.3-1.el6 set to be updated
--> Processing Dependency: php-pdo >= 5.3.3 for package: php-mssql-5.3.3-1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: php-mssql-5.3.3-1.el6.x86_64 (epel)
Requires: php-pdo >= 5.3.3
Installed: php-pdo-5.3.2-6.el6_0.1.x86_64 (@updates)
php-pdo = 5.3.2-6.el6_0.1
Available: php-pdo-5.3.2-6.el6.x86_64 (base)
php-pdo = 5.3.2-6.el6
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[root@server1 ~]#

The server I am assuming is running well. The ISPConfig, the phpMyAdmin and webmail are working and I can access them. I had few questions. I tried to send an email to my yahoo mail address from webmail and I did not receive any mail from falko user. Does it mean I have to add domain information in postfix? I am ready to install the web-script I have and I am still unclear which folder is the web folder to upload the script? Do you know which folder is web folder by default under ISPConfig? In order for this server to fully be functional as a home server which can be appreciable on the Internet, do I have to do anything else? I have the domain already from godaddy. I have to mention that I bought ISPConfig manual and the focus of this manual is how to install the ISPConfig on a single server or multiple mirror servers focusing more on the Debian and Ubuntu servers etc and does not say that much beyond the installation. I mean after the successful installation of ISPConfig and uploading the web script and successful installation of the web-script, do I have to do further more configurations? Thank you again.

falko 6th December 2011 21:53

Quote:

Originally Posted by rewards (Post 268818)
Hi Falko,

You deserve a gold medal. Thank you for your responses. Now Falko can login to http://192.168.0.174/webmail. I still had problem installing php-mssql and I hope it would not be a big deal to have that. The message was;

[root@server1 ~]# yum install php-mssql
Loaded plugins: fastestmirror, presto, priorities, refresh-packagekit
Loading mirror speeds from cached hostfile
* base: mirror.5ninesolutions.com
* epel: mirror.hmc.edu
* extras: mirrors.login.com
* rpmforge: fr2.rpmfind.net
* updates: mirror.san.fastserv.com
1070 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-mssql.x86_64 0:5.3.3-1.el6 set to be updated
--> Processing Dependency: php-pdo >= 5.3.3 for package: php-mssql-5.3.3-1.el6.x86_64
--> Processing Dependency: libsybdb.so.5()(64bit) for package: php-mssql-5.3.3-1.el6.x86_64
--> Running transaction check
---> Package freetds.x86_64 0:0.91-1.el6 set to be updated
---> Package php-mssql.x86_64 0:5.3.3-1.el6 set to be updated
--> Processing Dependency: php-pdo >= 5.3.3 for package: php-mssql-5.3.3-1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: php-mssql-5.3.3-1.el6.x86_64 (epel)
Requires: php-pdo >= 5.3.3
Installed: php-pdo-5.3.2-6.el6_0.1.x86_64 (@updates)
php-pdo = 5.3.2-6.el6_0.1
Available: php-pdo-5.3.2-6.el6.x86_64 (base)
php-pdo = 5.3.2-6.el6
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[root@server1 ~]#

Did you enable and configure all repositories exactly as shown in the tutorial?

Quote:

Originally Posted by rewards (Post 268818)
I tried to send an email to my yahoo mail address from webmail and I did not receive any mail from falko user.

Any errors in your mail log? Also please check if your server is blaclisted: http://www.mxtoolbox.com/blacklists.aspx

Quote:

Originally Posted by rewards (Post 268818)
I am ready to install the web-script I have and I am still unclear which folder is the web folder to upload the script? Do you know which folder is web folder by default under ISPConfig?

You must create an FTP user for the website and then log in with an FTP client such as FileZilla. You should then see a web folder. This is where you must upload your stuff.

rewards 8th December 2011 01:37

Hi Falko

Yes I did exactly as the tutorial not once but several times and every time I did a fresh install and started from scratch. I have lots of log files in /var/log folders as shown below. Which one is the accurate log file to check.

[root@server1 log]# ls
anaconda.log audit dmesg lastlog ppp tallylog yum.log
anaconda.program.log boot.log dmesg.old maillog prelink wpa_supplicant.log
anaconda.storage.log btmp gdm messages pureftpd.log wtmp
anaconda.syslog clamav httpd mysqld.log rkhunter Xorg.0.log
anaconda.xlog ConsoleKit ispconfig ntpstats secure Xorg.0.log.old
anaconda.yum.log cron ispconfig_install.log pm-powersave.log spooler Xorg.9.log

Yes the IP address of my ISP was in the black listed website you sent me http://www.mxtoolbox.com/blacklists.aspx. I created a FTP user called falko with password falko in the ISPConfig. When I tried to FTP using Filezilla with falko user I get the following error message;

Status: Connecting to 192.168.0.174:21...
Status: Connection established, waiting for welcome message...
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 1 of 50 allowed.
Response: 220-Local time is now 16:16. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER falko
Response: 331 User falko OK. Password required
Command: PASS *****
Response: 530 Login authentication failed
Error: Critical error
Error: Could not connect to server

falko 8th December 2011 19:51

Quote:

Originally Posted by rewards (Post 269142)
Hi Falko

Yes I did exactly as the tutorial not once but several times and every time I did a fresh install and started from scratch. I have lots of log files in /var/log folders as shown below. Which one is the accurate log file to check.

[root@server1 log]# ls
anaconda.log audit dmesg lastlog ppp tallylog yum.log
anaconda.program.log boot.log dmesg.old maillog prelink wpa_supplicant.log
anaconda.storage.log btmp gdm messages pureftpd.log wtmp
anaconda.syslog clamav httpd mysqld.log rkhunter Xorg.0.log
anaconda.xlog ConsoleKit ispconfig ntpstats secure Xorg.0.log.old
anaconda.yum.log cron ispconfig_install.log pm-powersave.log spooler Xorg.9.log

It's /var/log/maillog.

Quote:

Originally Posted by rewards (Post 269142)
Yes the IP address of my ISP was in the black listed website you sent me http://www.mxtoolbox.com/blacklists.aspx.

Do you use a dynamic IP? In that case you should set up relaying: http://www.howtoforge.com/postfix_re...her_mailserver


Quote:

Originally Posted by rewards (Post 269142)
I created a FTP user called falko with password falko in the ISPConfig. When I tried to FTP using Filezilla with falko user I get the following error message;

Status: Connecting to 192.168.0.174:21...
Status: Connection established, waiting for welcome message...
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 1 of 50 allowed.
Response: 220-Local time is now 16:16. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER falko
Response: 331 User falko OK. Password required
Command: PASS *****
Response: 530 Login authentication failed
Error: Critical error
Error: Could not connect to server

Are you sure that falko is the correct username? You can find the correct username in the FTP user listview in ISPConfig.


All times are GMT +2. The time now is 18:24.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.