HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   monitor bandwidth via mrtg logs Error on Nagios (http://www.howtoforge.com/forums/showthread.php?t=55187)

dilanmic 1st December 2011 11:53

monitor bandwidth via mrtg logs Error on Nagios
 
HI,

I have installed Nagios 3.2.3 with Nagios Plugins 1.4.15, Net-snmp 5.7.1 to Ubuntu 11.10. I am getting following errors message when I try to monitor bandwidth via MRTG logs,

"check_mrtgtraf: Unable to open MRTG log file"

Here is the script of my switch.cfg:

# Monitor bandwidth via MRTG logs
define service
{
use generic-service
host_name linksys-srw224p
service_description Port 1 Bandwidth Usage
check_command check_local_mrtgtraf!/var/lib/mrtg
/10.10.10.1_1.log!AVG!1000000,1000000!5000000,50000 00!10
}

* There is NO mrtg in /var/lib/ directory
* But there is check_mrtg and check_mrtgtraf plugins in /usr/loacl/nagios/libexec directory

Do anyone can help me about this problem?
Thanks in advance...

dilanmic 1st December 2011 14:47

Solved
 
Solution:

Install MRTG Plugins

Then follow this link:

http://linuxbasement.com/content/mrtg-ubuntu-server

Correction

indexmaker --output /var/www/mrtg/index.html /etc/mrtg/mrtg.cfg

Hope this help

mpi 20th December 2012 14:46

Nagios with MRTG
 
Hi all,

Im using nagios and mrtg ... mrtg is installed and i can see the graphs on http://localhost/mrtg ... and on nagios in the switch.cfg file i have the following

Quote:

define service{
use generic-service ; Inherit values from a template
host_name RouterCiscoT
service_description Port 1 Bandwidth Usage
check_command check_local_mrtgtraf!/var/www/mrtg/172.25.0.56_fa0_1.log!AVG!1000000,1000000!5000000, 5000000!10
}
but check_local_mrtgtraf is for local machine (if im not ling my self) and if i used check_mrtgtraf im getting an error while restarting nagios /etc/init.d/nagios restart ... is there any solution for this ??/ what im doing wrong ???


All times are GMT +2. The time now is 09:30.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.