HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   postfix smtp sasl auth problem (http://www.howtoforge.com/forums/showthread.php?t=5506)

hammer 13th July 2006 14:22

postfix smtp sasl auth problem
 
Hello, i am using postfix+saslauth to auth my smtp outgoing mails.
I cant login to my smtp server. POP3 i have no problem but i can only check mails with it, smtp is needed to send ones (hmpf you already know that i guess :) )

So here is what i have as my configs, and logs:
Quote:

- telnet log
opasnivremena saslauthd # telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 opasnivremena.com ESMTP Postfix
ehlo opasnivremena.com
250-opasnivremena.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
Quote:

- mail log
Jul 13 15:25:25 opasnivremena saslauthd[29373]: do_auth : auth failure: [user=hammer@opasnivremena.com] [service=smtp] [realm=opasnivremena.com] [mech=shadow] [reason=Unknown]
Jul 13 15:25:25 opasnivremena postfix/smtpd[29142]: warning: SASL authentication failure: Password verification failed
Jul 13 15:25:25 opasnivremena postfix/smtpd[29142]: warning: localhost[127.0.0.1]: SASL PLAIN authentication failed

Quote:

- saslauthd conf
SASLAUTHD_OPTS="${SASLAUTH_MECH} -a shadow -r"


Quote:

- main.cf
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_sasl_local_domain = $myhostname
smtp_sasl_auth_enable = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,
permit_mynetworks,
check_relay_domains

smtp_sasl_password_maps = hash:/etc/postfix/passwd
smtp_sasl_security_options =


HELP .. i've tried all i have comed up with. ...

in addition i can auth via testsaslauthd using the same username and password as when i auth in my smtp ... but in testsaslauthd it works ... in the smtp it doesnt. ..

and another strange thing ... when i auth vie testsaslauthd it logs it as user hammer, but when i auth via outlook express it logs it as hammer at opasnivremena.com ... hammer at opasnivremena.com is not a valid user ... how can i fix this?

hm ... f**k i've removed the -r option (after reading 100 times the manual .. .to understand that it adds the domain name after the login name) and everything is OKAY now!

kanour 13th July 2006 18:19

Thank you.
This was very handy to me because I had the same issue. One more time for everyone ( I have Debian distro).

In /etc/default/saslauthd
line with: PARAMS="-m /var/spool/postfix/var/run/saslauthd -r"
has to be changed to: PARAMS="-m /var/spool/postfix/var/run/saslauthd"


All times are GMT +2. The time now is 11:38.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.