HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   MailMan with 3.0.4 (http://www.howtoforge.com/forums/showthread.php?t=55007)

pier56 19th November 2011 18:08

MailMan with 3.0.4
 
The upgrade to 3.0.4 seems ok.

I have installed mailman with the new manuel.

But I created a list before this install, on a domain.

And lists on this domain are created, but there are 404 errors for interfaces
http://<domain>/cgi-bin/mailman/admin/<list>
http://<domain>/cgi-bin/mailman/listinfo/<domain>

ispconfig "mail warnings" shows :
Nov 18 13:38:02 ks356348 postfix/postmap[5085]: warning: /var/lib/mailman/data/virtual-mailman.db: duplicate entry: "<list>@<domain>"
(and other aliases)

/var/lib/mailman/data/aliases seems ok.
But /var/lib/mailman/data/virtual-mailman has a problem :
there are several lists of <domain> which are not deleted.

Do you know how I can correct that ?

Thanks !

pier56 19th November 2011 18:27

It is for ispconfig.
Sorry for error.

falko 20th November 2011 16:46

Did you create a second list with that name?

pier56 20th November 2011 17:02

After reinstalling
 
No, I tried to delete and recreate the list, same problem. And same problem with all lists on that domain.

After reinstalling mailman, I have almost the same problem.

Now, there are no errors with virtual-mailman.db. But if I delete a list of this domain, it stays in virtual-mailman. For others domains, no problem.

I have found that web admin/users interfaces are https URLs for the domain mail of this list, and not http URL.

And the links from admin/users interfaces are https URLs, and coded as http URLs.

In mm_cfg.py, there is
DEFAULT_URL_PATTERN = 'http://%s/cgi-bin/mailman/'

And no https directive in <domain>.vhost

Mystery...

falko 21st November 2011 11:58

Which distribution do you use?

pier56 21st November 2011 12:07

system
 
Debian lenny, bundled with ispconfig (3.0.1, if I remember).
I updated from 3.0.2 to 3.0.4, by shell.

falko 22nd November 2011 14:24

Can you check if your Mailman is set up as follows (this is taken from the ISPConfig 3 Manual):

Quote:

3.1.2 Mailman

This chapter covers the Mailman installation on Debian/Ubuntu. It is probably similar on other distributions (please note that ISPConfig expects the Mailman commands (like newlist, change_pw, rmlist) in the directory /usr/lib/mailman/bin/, so you might have to create symlinks).

Install Mailman as follows:

apt-get install mailman

Before we can start Mailman, a first mailing list called mailman must be created:

newlist mailman

root@server1:~# newlist mailman
Enter the email of the person running the list: <-- admin email address, e.g. info@example.com
Initial mailman password: <-- admin password for the mailman list
To finish creating your mailing list, you must edit your /etc/aliases (or
equivalent) file by adding the following lines, and possibly running the
`newaliases' program:

## mailman mailing list
mailman: "|/var/lib/mailman/mail/mailman post mailman"
mailman-admin: "|/var/lib/mailman/mail/mailman admin mailman"
mailman-bounces: "|/var/lib/mailman/mail/mailman bounces mailman"
mailman-confirm: "|/var/lib/mailman/mail/mailman confirm mailman"
mailman-join: "|/var/lib/mailman/mail/mailman join mailman"
mailman-leave: "|/var/lib/mailman/mail/mailman leave mailman"
mailman-owner: "|/var/lib/mailman/mail/mailman owner mailman"
mailman-request: "|/var/lib/mailman/mail/mailman request mailman"
mailman-subscribe: "|/var/lib/mailman/mail/mailman subscribe mailman"
mailman-unsubscribe: "|/var/lib/mailman/mail/mailman unsubscribe mailman"

Hit enter to notify mailman owner... <-- ENTER

root@server1:~#

Open /etc/aliases afterwards...

vi /etc/aliases

... and add the following lines:

[...]
mailman: "|/var/lib/mailman/mail/mailman post mailman"
mailman-admin: "|/var/lib/mailman/mail/mailman admin mailman"
mailman-bounces: "|/var/lib/mailman/mail/mailman bounces mailman"
mailman-confirm: "|/var/lib/mailman/mail/mailman confirm mailman"
mailman-join: "|/var/lib/mailman/mail/mailman join mailman"
mailman-leave: "|/var/lib/mailman/mail/mailman leave mailman"
mailman-owner: "|/var/lib/mailman/mail/mailman owner mailman"
mailman-request: "|/var/lib/mailman/mail/mailman request mailman"
mailman-subscribe: "|/var/lib/mailman/mail/mailman subscribe mailman"
mailman-unsubscribe: "|/var/lib/mailman/mail/mailman unsubscribe mailman"

Run

newaliases

afterwards and restart Postfix:

/etc/init.d/postfix restart

Finally we must enable the Mailman Apache configuration:

ln -s /etc/mailman/apache.conf /etc/apache2/conf.d/mailman.conf

This defines the alias /cgi-bin/mailman/ for all Apache vhosts, which means you can access the Mailman admin interface for a list at http://<vhost>/cgi-bin/mailman/admin/<listname>, and the web page for users of a mailing list can be found at http://<vhost>/cgi-bin/mailman/listinfo/<listname>.

Under http://<vhost>/pipermail you can find the mailing list archives.

Restart Apache afterwards:

/etc/init.d/apache2 restart

If you use nginx instead of Apache, take a look at chapter 5.27.2 to find out how to configure Mailman for nginx.

Then start the Mailman daemon:

/etc/init.d/mailman start

albegior 27th November 2011 13:03

Hello FALKO
I have the same problem on debian 6 and ISPConfig 3.0.4.1

I installed mailman as described above with a little difference:

for aliases, file: /etc/aliases it's wrong..

I wrote them inside: /var/lib/mailman/data/aliases

after it I run: "newaliases"

The main list called "MAILMAN" works fine:
http://test.justdinnerclub.net/cgi-b.../admin/mailman

If I create a new list called "TEST" for virtualdomain www.servilux.it i receive the email with Subject: Your new mailing list: test
but I can't manage the list trough web interface for 404 errors on both links:

http://servilux.it/cgi-bin/mailman/admin/test

http://servilux.it/cgi-bin/mailman/listinfo/test

Best regards
Alberto

falko 28th November 2011 13:30

But
http://test.justdinnerclub.net/cgi-b...man/admin/test
and
http://test.justdinnerclub.net/cgi-b.../listinfo/test
work fine, so there seems to be something wrong with the servilux.it vhost. Can you check if CGI and suExec are enabled for this site? If so, can you switch them off and try again?

albegior 29th November 2011 09:46

Ciao Falko
Only cgi-bin was enabled on servilux.it because they have one cgi on website, now it's switched off and mailman works fine....

do you mean cig-bin and mailman can't run together?

Thank you!
Alberto


All times are GMT +2. The time now is 08:21.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.