HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Changed FQDN with an older version and now using SSL with the old domain (http://www.howtoforge.com/forums/showthread.php?t=54990)

Nioubee 18th November 2011 14:24

Changed FQDN with an older version and now using SSL with the old domain
 
Hello,

I have followed somewhere on this forum a post on how to change my FQDN of my server with at the end running the hostname.sh file.
Everythings work fine. So i have upgraded my ISPConfig server to version 3.0.4 and while choosing the preferred options i have enabled the SSL login...

My problem is; my old domaine name will expire, and with the SSL enabled by default the old domain is only available and not the new.

For example, let's say my old domaine is : domain1.tld

With the older version i was accessing the panel with http://hostname.domain1.tld:8080

With the panel updated to 3.0.4 and SSL enabled, the panel is only available from the old domain and not https://hostname.domain2.tld:8080/

Have you an idea how to help me, do i need to reinstall completely ? Or i am forced to use the old domain ?

falko 19th November 2011 12:00

I think you can use any hostname that points to this server, but to go sure, please check the ServerName and ServerAlias lines in the ISPConfig Apache vhost.

Nioubee 19th November 2011 16:12

Quote:

Originally Posted by falko (Post 267850)
I think you can use any hostname that points to this server, but to go sure, please check the ServerName and ServerAlias lines in the ISPConfig Apache vhost.

Hi Falko,

Thanks you for your answer.
Ive followed what you said, but since i have no idea where the vhost of ispconfig was... I found that command on the website if someone have the same problem as me..

Code:

apache2ctl -S
So yes i just added manually

Code:

######################################################
# This virtual host contains the configuration
# for the ISPConfig controlpanel
######################################################

 Listen 8080
NameVirtualHost *:8080
ServerName hostname.domain2.tld

<VirtualHost _default_:8080>
...

And then restarted Apache 2.

It works fine now, thank you very much ! :)


All times are GMT +2. The time now is 20:17.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.