HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Billing Module question (http://www.howtoforge.com/forums/showthread.php?t=54979)

pititis 17th November 2011 18:48

Billing Module question
 
Hi,

I have a issue when I want to download a invoice directly from the dashboard. I got invoice_get_pdf.php as file instead a regular pdf invoice. This file is really a invoice but with the .php file extension.

Any idea?

Cheers

till 17th November 2011 22:17

And downloading the same invoice as admin from the billing module of works? Is this just one invoice or are all incoices even older one affected by this?

pititis 18th November 2011 13:33

Danke Till,

As admin or normal user don't work. New and old invoices are affected.

Cheers

till 18th November 2011 13:46

I must say that I've no real Idea how this can happen, I did not had this problem yet.

1) Have you changed any settings in php.ini recently?
2) Did you try another webbrowser?
3) Try to set the correct settings for the invoice sdir again:

chmod -R 775 /usr/local/ispconfig/interface/invoices
chown -R ispconfig:ispconfig /usr/local/ispconfig/interface/invoices

4) Have the files in the dircetory /usr/local/ispconfig/interface/invoices/ the ending .pdf?
5) Which invoice prefix do you use and has this been changed recently?

till 18th November 2011 13:49

One other idea, which error reporting level have you set in php? Maybe PHP prints a php notice before the pdf download script can set the headers for the pdf file so that the headers that set the filename for the downloaded file are ignored.

pititis 18th November 2011 14:02

Hi,

1) Only this :
disable_functions = exec,passthru,popen,ini_set,system,show_source,she ll_exec,proc_open,phpinfo

2) I use Firefox (on linux), Opera (on smartphone) and Webkit.
3) Permissions, owner and group are ok
4) Yes
5) Default prefix - INV2011 . No changes


I will try with iexplorer...but I have no idea

pititis 18th November 2011 14:05

Quote:

Originally Posted by till (Post 267800)
One other idea, which error reporting level have you set in php? Maybe PHP prints a php notice before the pdf download script can set the headers for the pdf file so that the headers that set the filename for the downloaded file are ignored.

Good Idea,

I will try it

Thanks

till 18th November 2011 14:19

1) Thats ok for the cgi/php.ini and apache/php.ini, as long as you do not set this in the cli/php.ini as it would disable ispconfigs server part :)
2-5) ok.

pititis 18th November 2011 14:38

Sure, only apache/php.ini

I set :

display_errors = On
error_reporting = E_ALL & ~E_NOTICE

No error, only the tipical warning for the init_set() function

:mad: :confused:

till 18th November 2011 14:53

Quote:

No error, only the tipical warning for the init_set() function
This warning can cause the problem. Either remove ini_set from disabled functions or edit the /usr/local/ispconfig/interface/lib/config.inc.php file from ispconfig and comment out the ini_set line in line 38 there.


All times are GMT +2. The time now is 12:34.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.