HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   dedicated email setup. Email sent from main server only delivered locally. (http://www.howtoforge.com/forums/showthread.php?t=54877)

dinsdale 10th November 2011 17:22

dedicated email setup. Email sent from main server only delivered locally.
 
Hi,

I have a two server setup with dedicated webserver and mail server.
Mail sent to a hosted client domain from the webserver (e.G. a web form) is delivered via maildrop and not relayed to the destination as I would expect.
It then can be found locally in the vmail directory on the webserver.
Any other mail to other domains coming from the webserver is delivered correctly, just local domains are delivered, well, locally.

I don't understand why, since mail from the outside arrives correctly at the mail server.

Nov 10 10:57:42 webserver postfix/pipe[24329]: A30FF308D: to=<name@domain.com>, relay=maildrop, delay=0.11, delays=0.05/0.02/0/0.04, dsn=2.0.0, status=sent (delivered via maildrop service)

I'm running IPSConfig 3.0.3 on ubuntu 11.04

I checked mydestination in main.cf which points correctly to the hostname. webserver.domain.com

Any hint where to dig would be appreciated. Where appart from mydestination does ispconfig or postfix think that they are responsible for a domain? The webserver is not configured as mail server at all.

Thanks in advance

falko 11th November 2011 12:04

Did you create domain.com as an email domain on the webserver? Or is your webserver's hostname domain.com?

dinsdale 11th November 2011 13:39

Thx for your reply, actually the hostname was only set to webserver1 and email. Not the FQN. I changed the /etc/hostname so it became now the same as /etc/mailname

webserver1.domain.com
email.domain.com

and rebooted, but no change so far.

In ISPConfig under Sites and Email the corresponding server is selected with the FQN webserver1.domain.com and email.domain.com

I also can ping between the two servers using their FQN.

I'm still unsure why webserver1 thinks that it is responsible for maildelivery via maildrop instead of contacting email for mail delivery as it does with any other domain.

At some point in the past I had to rename the main serverdomain which included several manual changes in config files but I would be surprised if that's the issue since the problem domains are virtual (client) domains.

till 11th November 2011 14:06

Quote:

At some point in the past I had to rename the main serverdomain which included several manual changes in config files but I would be surprised if that's the issue since the problem domains are virtual (client) domains.
Thats mots likely the reason for the problem, as domain definitions in postfix or system config files override virtual domain settings in postfix. So if you missed to change the domain in a single palce, then the local postfix instance will behave as authoritive server for that domain. Have you checked /etc/hosts as well?

dinsdale 11th November 2011 16:19

/etc/hosts looks fine on first inspection. I guess I will have to grep for the old domain name across the hd.

Quick question inbetween, Would upgrading ispconfig not rewrite all configuration files? Since I'm still on 3.0.3 I could upgrade to 3.0.4.

till 11th November 2011 18:32

A upgrade rewrites some configuration files, but it never changes the hostname in one of the files.


All times are GMT +2. The time now is 13:23.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.