HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Ftp and Swedish characters in Directory field (http://www.howtoforge.com/forums/showthread.php?t=54680)

damir 28th October 2011 09:50

Ftp and Swedish characters in Directory field
 
Hi all,

This issues came up after moving to new server. Everything is identical besides hardware. OS Debian 6.0.3

I have a issue regarding FTP part in ISPConfig 3. I have created new FTP user and i have changed the path i Directory field to a folder inside user webspace. Problem is that created folder contains swedish characters.

Code:

/var/www/clients/client1/web1/webdav/ftp/testing/skåne
With this path i get error connect with Filezilla:

Code:

Home directory doesn't exist. Abort.
If i remove skåne part than it connects correct. In dbispconfig database path looks correct. Could it be that Pureftpd doesn't translate "skåne" part correctly.

Any thoughts?

till 28th October 2011 10:23

Quote:

Could it be that Pureftpd doesn't translate "skåne" part correctly.
That can be the case. ISPConfig supports all foreign characters as it uses UTF-8, but this does not mean that all other software are able to use the paths in their configuration even if they are correctly stored in mysql. Have you tried to enable debugging in pure-ftpd and check the log for errors then?

damir 28th October 2011 15:20

Hi Till and thank for reply.

I enabled verbose logging and this is the error i receive while i try to connect to folder that contains swedish char Å:

Code:

Oct 28 15:15:53 test pure-ftpd: (?@10.0.0.30) [ERROR] Home directory not available - aborting

falko 29th October 2011 11:11

I highly recommend not to use any special characters in paths, usernames, etc.

damir 29th October 2011 11:44

Quote:

Originally Posted by falko (Post 266181)
I highly recommend not to use any special characters in paths, usernames, etc.

I'm aware of that :) The thing is it worked well on Lenny but not on Squeeze and my client is hangedup on the, it worked before.

till 29th October 2011 21:31

Which Linux charset did you use on Lenny and which charset do you use on Squeeze now?

damir 30th October 2011 12:02

Quote:

Originally Posted by till (Post 266197)
Which Linux charset did you use on Lenny and which charset do you use on Squeeze now?

I have used "sv_SE.UTF-8" as default on both.

If i remove "skåne" from Directory path in ISPConfig and add "skåne" to remote path in Filezilla instead, than it connects without problems.

Only when i want to lock user to folder "skåne" and adding that to Directory path in ISPConfig that i cannot connect. I recive: "421: Home directory not available - aborting"

If i can connect to "skåne" folder when adding it to Filezilla's remote path than Pure-ftpd understands "å" character?


All times are GMT +2. The time now is 19:49.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.