HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Problem on slave/master configuration on ispconfig 3.0.3.3 (http://www.howtoforge.com/forums/showthread.php?t=54659)

themark 26th October 2011 20:21

Problem on slave/master configuration on ispconfig 3.0.3.3
 
Hi there,

today we have a strange problem on slave/master configuration (ispconfig 3.0.3.3).

If we install a slave server and choosing the installation without interface; from the server monitor control of the master server we receive the following error, about the server slave:

Replication failed. Error: (sys_group) in MySQL server: (localhost) Table 'dbispconfig.sys_group' doesn't exist # SQL: REPLACE INTO sys_group (`groupid`,`name`,`description`,`client_id`) VALUES ('2','customer','','1')

Any Ideas?
:)

till 27th October 2011 09:32

Please check if the the dbispconfig database on the slave contains any tables. If not or if the number of tables is lower then on the master, then the installation on the slave has failed. This might happen e.g. if you did not use the mysql root user when ispconfig installer asked for the root user, the installation process requires all permissions in the mysql slave db and using a different mysql user can cause the setup to fail in this way. You should then uninstall ispconfig on the slave with the uninstall.php script, then delete the record for the slave in the server table of the master database and then install ispconfig on the slave again.


All times are GMT +2. The time now is 02:52.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.