HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   SMTP Server offline (http://www.howtoforge.com/forums/showthread.php?t=54633)

shibble 24th October 2011 21:37

SMTP Server offline
 
Hi everyone,

My VPS provider got DDOS'ed last week, after they have fixed this and my VPS got back online the SMTP Server doesnt work anymore.
Now i have looked on many places to find the problem but i cant find the problem anywhere.

main.cf:
Quote:

# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific: Specifying a file name will cause the first
# line of that file to be used as the name. The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = /usr/share/doc/postfix

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = system.webcustoms.org
alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
myorigin = /etc/mailname
mydestination = system.webcustoms.org, localhost, localhost.localdomain
relayhost =
mynetworks = 127.0.0.0/8 [::1]/128
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
html_directory = /usr/share/doc/postfix/html
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf, hash:/var/lib/mailman/data/virtual-mailman
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /var/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
smtpd_tls_security_level = may
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
virtual_create_maildirsize = yes
virtual_maildir_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota."
virtual_overquota_bounce = yes
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
maildrop_destination_concurrency_limit = 1
maildrop_destination_recipient_limit = 1
virtual_transport = dovecot
header_checks = regexp:/etc/postfix/header_checks
mime_header_checks = regexp:/etc/postfix/mime_header_checks
nested_header_checks = regexp:/etc/postfix/nested_header_checks
body_checks = regexp:/etc/postfix/body_checks
dovecot_destination_recipient_limit = 1
smtpd_sasl_type = dovecot
smtpd_sasl_path = private/auth
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
message_size_limit = 0
smtpd_client_message_rate_limit = 100
owner_request_special = no
Kindly regards,

shibble

Mark_NL 25th October 2011 10:26

We need to see some errors before we can help you out.

shibble 25th October 2011 13:04

Hi,

I did the following command to take a look at the mail.* log files.

egrep -r '(error|fatal|warning|panic):' /var/log/mail.*

This gave me:
Quote:

Oct 25 13:48:19 system amavis[5251]: (05251-01) (!)FWD via SMTP: <smmsp@webcustoms.org> -> <root@webcustoms.org>, 451 4.5.0 From MTA([127.0.0.1]:10025) during fwd-connect (Negative greeting: at (eval 84) line 555, <GEN28> line 44.): id=05251-01
/var/log/mail.err:Oct 25 13:48:18 system postfix/smtpd[9217]: fatal: no SASL authentication mechanisms
/var/log/mail.info:Oct 25 13:48:18 system postfix/smtpd[9217]: warning: SASL: Connect to private/auth failed: No such file or directory
/var/log/mail.info:Oct 25 13:48:18 system postfix/smtpd[9217]: fatal: no SASL authentication mechanisms
/var/log/mail.info:Oct 25 13:48:19 system postfix/master[7998]: warning: process /usr/lib/postfix/smtpd pid 9217 exit status 1
/var/log/mail.info:Oct 25 13:48:19 system postfix/master[7998]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
/var/log/mail.info:Oct 25 13:49:01 system postfix/smtp[8047]: warning: 3CF5516A9033: defer service failure
/var/log/mail.info:Oct 25 13:49:02 system postfix/smtp[8047]: warning: connect to private/scache: Connection refused
/var/log/mail.info:Oct 25 13:49:02 system postfix/smtp[8047]: warning: disabling connection caching
/var/log/mail.info:Oct 25 13:50:02 system postfix/postqueue[19610]: warning: Mail system is down -- accessing queue directly
/var/log/mail.log:Oct 25 13:48:18 system postfix/smtpd[9217]: warning: SASL: Connect to private/auth failed: No such file or directory
/var/log/mail.log:Oct 25 13:48:18 system postfix/smtpd[9217]: fatal: no SASL authentication mechanisms
/var/log/mail.log:Oct 25 13:48:19 system postfix/master[7998]: warning: process /usr/lib/postfix/smtpd pid 9217 exit status 1
/var/log/mail.log:Oct 25 13:48:19 system postfix/master[7998]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
/var/log/mail.log:Oct 25 13:49:01 system postfix/smtp[8047]: warning: 3CF5516A9033: defer service failure
/var/log/mail.log:Oct 25 13:49:02 system postfix/smtp[8047]: warning: connect to private/scache: Connection refused
/var/log/mail.log:Oct 25 13:49:02 system postfix/smtp[8047]: warning: disabling connection caching
/var/log/mail.log:Oct 25 13:50:02 system postfix/postqueue[19610]: warning: Mail system is down -- accessing queue directly
/var/log/mail.warn:Oct 25 13:48:18 system postfix/smtpd[9217]: warning: SASL: Connect to private/auth failed: No such file or directory
/var/log/mail.warn:Oct 25 13:48:18 system postfix/smtpd[9217]: fatal: no SASL authentication mechanisms
/var/log/mail.warn:Oct 25 13:48:19 system postfix/master[7998]: warning: process /usr/lib/postfix/smtpd pid 9217 exit status 1
/var/log/mail.warn:Oct 25 13:48:19 system postfix/master[7998]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
/var/log/mail.warn:Oct 25 13:49:01 system postfix/smtp[8047]: warning: 3CF5516A9033: defer service failure
/var/log/mail.warn:Oct 25 13:49:02 system postfix/smtp[8047]: warning: connect to private/scache: Connection refused
/var/log/mail.warn:Oct 25 13:49:02 system postfix/smtp[8047]: warning: disabling connection caching
/var/log/mail.warn:Oct 25 13:50:02 system postfix/postqueue[19610]: warning: Mail system is down -- accessing queue directly
There is more in the mail log files i uploaded the log files:

http://www.webcustoms.org/logs/mail.err
http://www.webcustoms.org/logs/mail.info
http://www.webcustoms.org/logs/mail.log
http://www.webcustoms.org/logs/mail.warn

Are there any other log files to add?

Kindly regards,

shibble

Mark_NL 25th October 2011 13:15

edit:

There is nothing listening on port 10025 ..

also, does /etc/postfix/main.cf contain "smtpd_sasl_type = dovecot" ?

shibble 25th October 2011 13:17

The outcome of that command is:

Quote:

tcp 0 0 127.0.0.1:10024 0.0.0.0:* LISTEN 4057/amavisd (maste
tcp 0 0 127.0.0.1:46614 127.0.0.1:3306 ESTABLISHED 11325/amavisd (ch1-
tcp 0 0 127.0.0.1:46554 127.0.0.1:3306 ESTABLISHED 5250/amavisd (ch1-a
Kindly regards,

shibble

shibble 25th October 2011 14:03

Quote:

Originally Posted by Mark_NL (Post 265910)
edit:

There is nothing listening on port 10025 ..

also, does /etc/postfix/main.cf contain "smtpd_sasl_type = dovecot" ?

Yes in my mainpost you see almost at the end:

smtpd_sasl_type = dovecot


If im right, and there is nothing listening on port 10025 something is going wrong with postfix?
But i cant find the what is going wrong looked al over the internet.

My master.cf:
Quote:

#
# Postfix master process configuration file. For details on the format
# of the file, see the master(5) manual page (command: "man 5 master").
#
# Do not forget to execute "postfix reload" after editing this file.
#
# ================================================== ========================
# service type private unpriv chroot wakeup maxproc command + args
# (yes) (yes) (yes) (never) (100)
# ================================================== ========================
smtp inet n - - - - smtpd
#submission inet n - - - - smtpd
# -o smtpd_tls_security_level=encrypt
# -o smtpd_sasl_auth_enable=yes
# -o smtpd_client_restrictions=permit_sasl_authenticate d,reject
# -o milter_macro_daemon_name=ORIGINATING
#smtps inet n - - - - smtpd
# -o smtpd_tls_wrappermode=yes
# -o smtpd_sasl_auth_enable=yes
# -o smtpd_client_restrictions=permit_sasl_authenticate d,reject
# -o milter_macro_daemon_name=ORIGINATING
#628 inet n - - - - qmqpd
pickup fifo n - - 60 1 pickup
cleanup unix n - - - 0 cleanup
qmgr fifo n - n 300 1 qmgr
#qmgr fifo n - - 300 1 oqmgr
tlsmgr unix - - - 1000? 1 tlsmgr
rewrite unix - - - - - trivial-rewrite
bounce unix - - - - 0 bounce
defer unix - - - - 0 bounce
trace unix - - - - 0 bounce
verify unix - - - - 1 verify
flush unix n - - 1000? 0 flush
proxymap unix - - n - - proxymap
proxywrite unix - - n - 1 proxymap
smtp unix - - - - - smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay unix - - - - - smtp
-o smtp_fallback_relay=
# -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq unix n - - - - showq
error unix - - - - - error
retry unix - - - - - error
discard unix - - - - - discard
local unix - n n - - local
virtual unix - n n - - virtual
lmtp unix - - - - - lmtp
anvil unix - - - - 1 anvil
scache unix - - - - 1 scache
#
# ================================================== ==================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent. See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ================================================== ==================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop unix - n n - - pipe
flags=DRhu user=vmail argv=/usr/bin/maildrop -d vmail ${extension} ${recipient} ${user} ${nexthop} ${sender}
#
# See the Postfix UUCP_README file for configuration details.
#
uucp unix - n n - - pipe
flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
#
# Other external delivery methods.
#
ifmail unix - n n - - pipe
flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp unix - n n - - pipe
flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix - n n - 2 pipe
flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman unix - n n - - pipe
flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
${nexthop} ${user}

dovecot unix - n n - - pipe
flags=DRhu user=vmail:vmail argv=/usr/lib/dovecot/deliver -f ${sender} -d ${user}@${nexthop}
amavis unix - - - - 2 smtp
-o smtp_data_done_timeout=1200
-o smtp_send_xforward_command=yes

127.0.0.1:10025 inet n - - - - smtpd
-o content_filter=
-o local_recipient_maps=
-o relay_recipient_maps=
-o smtpd_restriction_classes=
-o smtpd_client_restrictions=
-o smtpd_helo_restrictions=
-o smtpd_sender_restrictions=
-o smtpd_recipient_restrictions=permit_mynetworks,rej ect
-o mynetworks=127.0.0.0/8
-o strict_rfc821_envelopes=yes
-o receive_override_options=no_unknown_recipient_chec ks,no_header_body_checks
-o smtpd_bind_address=127.0.0.1

shibble 25th October 2011 18:42

After testing whole of things again sended mails from my hotmail to my mail and when i start the postfix just after i sended the mail from my hotmail it delivers sometimes to my mail but after a few seconds the SMTP Server is offline again.

is there nobody who knows how i can fix this problem?

till 25th October 2011 19:05

Please check the mail log file for errors.

shibble 25th October 2011 19:40

I already did but i cleaned the mail logs and rebooted the system now this are the log files now:

www.webcustoms.org/logs/mail.err
www.webcustoms.org/logs/mail.info
www.webcustoms.org/logs/mail.log
www.webcustoms.org/logs/mail.warn

i also inserted the syslog file:
www.webcustoms.org/logs/syslog

Kindly regards,

shibble

till 25th October 2011 19:43

Is this a ubuntu server and you updated it to ubuntu 11.10? Then you might face this ubuntu bug:

http://www.howtoforge.com/forums/sho...1&postcount=25


All times are GMT +2. The time now is 06:47.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.