HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   why multiple domains are directed towards same the host (http://www.howtoforge.com/forums/showthread.php?t=54530)

c-gundo 13th October 2011 21:34

why multiple domains are directed towards same the host
 
I have a strange problem with my (new) server (OVH.net automatic installation)
i have 2 domains http://www.cgundoffice.com and http://www.modulance.net
each are configured on a separed DNS server with the A Zone linked to the IP of the ISPconfig3 server
On the ISPconfig3 server, i have created 2 sites, one for each domains

But now, when i try to connect to those URL, each of them are directed to the same domain (http://www.cgundoffice.com) ... why ?

any suggestion ?

thx :-)

kwickcut 13th October 2011 22:15

check and make sure the two site directories are not the same



kwick

c-gundo 14th October 2011 07:12

i have checked the folder
and also the vhost files
/etc/apache2/sites-available/cgundoffice.com.vhost

Code:

<VirtualHost 91.121.92.131:80>
      DocumentRoot /var/www/cgundoffice.com/web
 
    ServerName cgundoffice.com
    ServerAlias www.cgundoffice.com
    ServerAdmin webmaster@cgundoffice.com

    ErrorLog /var/log/ispconfig/httpd/cgundoffice.com/error.log

/etc/apache2/sites-available/modulance.net.vhost
Code:

<VirtualHost 91.121.92.131:80>
      DocumentRoot /var/www/modulance.net/web
 
    ServerName modulance.net
    ServerAlias www.modulance.net
    ServerAdmin webmaster@modulance.net

    ErrorLog /var/log/ispconfig/httpd/modulance.net/error.log

but what i see is that all the request to my server go to the same host
http://91.121.92.131 ... same host

i have reloaded Apache, restart the server ... not better

c-gundo 14th October 2011 08:39

resolved
 
i have found the solution :)
in the web domain config page, i must set IP on * and not on the real IP of the server :rolleyes:
apache restart and all work fine


All times are GMT +2. The time now is 09:56.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.