HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   How set the Right Client FTP connection in ISPConfig (http://www.howtoforge.com/forums/showthread.php?t=54403)

Salital 3rd October 2011 03:13

How set the Right Client FTP connection in ISPConfig
 
Hi Guys,

Your forum is great and I appreciate very much your efforts ... How set the Right FTP connection of a Client in ISPConfig? It seems that all I made work but when the Client want connect via FTP at its directory where is its website appear the following message (the TRANSFER SETTING of the Client FTP is active/passive)

Quote:

Status: Resolving address of ftp.qmywebsite.com
Status: Connecting to 201.171.62.147:21...
Status: Connection established, waiting for welcome message...
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 1 of 50 allowed.
Response: 220-Local time is now 15:52. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER clientftpusername
Response: 331 User clientftpusername OK. Password required
Command: PASS **********
Error: Connection timed out
Error: Could not connect to server
Status: Waiting to retry...
Status: Resolving address of ftp.mywebsite.com
Status: Connecting to 201.171.62.147:21...
Status: Connection established, waiting for welcome message...
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 2 of 50 allowed.
Response: 220-Local time is now 15:53. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER clientftpusername
Response: 331 User clientftpusername OK. Password required
Command: PASS **********
Error: Connection timed out
Error: Could not connect to server
IN THE FTP-User I have the following data

Quote:

Active Server Website Username

v server1.mywebsite.com mywebsite.com clientftpusername

anyway I try a connection also with the following data

ftp host: server1.mywebsite.com
Username: clientftpusername
Password: ******

And I receive from the Client FTP the following answer

Quote:

Status: Resolving address of server1.mywebsite.com
Status: Connection attempt failed with "EAI_NONAME - Neither nodename nor servname provided, or not known".
Error: Could not connect to server
with the follow command from root I saw the following enabled services:

# netstat -tap

Quote:

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:sunrpc *:* LISTEN 750/portmap
tcp 0 0 *:ftp *:* LISTEN 2478/pure-ftpd (SER
tcp 0 0 server1.mywebsite.c:domain *:* LISTEN 1278/named
tcp 0 0 *:ssh *:* LISTEN 2500/sshd
tcp 0 0 *:mysql *:* LISTEN 2190/mysqld
tcp 0 0 server1.mywebsite.com:ssh 201.170.138.84:64372 ESTABLISHED 25275/0
tcp6 0 0 [::]:imap2 [::]:* LISTEN 1804/couriertcpd
tcp6 0 0 [::]:http-alt [::]:* LISTEN 1475/apache2
tcp6 0 0 [::]:www [::]:* LISTEN 1475/apache2
tcp6 0 0 [::]:tproxy [::]:* LISTEN 1475/apache2
tcp6 0 0 [::]:ftp [::]:* LISTEN 2478/pure-ftpd (SER
tcp6 0 0 [::]:domain [::]:* LISTEN 1278/named
tcp6 0 0 [::]:ssh [::]:* LISTEN 2500/sshd
tcp6 0 0 [::]:https [::]:* LISTEN 1475/apache2
tcp6 0 0 [::]:imaps [::]:* LISTEN 1854/couriertcpd
tcp6 0 0 [::]:pop3s [::]:* LISTEN 1880/couriertcpd
tcp6 0 0 [::]:pop3 [::]:* LISTEN 1866/couriertcpd
I hope that it's all clear ... It seems that Pure-ftpd works I don't know where is my error

thank you in advance

S

falko 3rd October 2011 19:12

Did you try both active and passive transfers in your FTP client?

Is this a physical server or a virtual machine?

Salital 3rd October 2011 20:17

Quote:

Did you try both active and passive transfers in your FTP client?
yes

Quote:

Is this a physical server or a virtual machine?
Is a physical server

regards,

S

eko_taas 3rd October 2011 20:50

Firewall in between?
 
Do you have firewall between (I had similar issue some time back with same timeout, I was gently quided to my firewall settings :) )

Mine login is looking like (FTPES - FTP over explicit TSL/SSH)
Code:

Status:        Connecting to 192.168.xx.yyy:21...
Status:        Connection established, waiting for welcome message...
Response:        220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response:        220-You are user number 1 of 50 allowed.
Response:        220-Local time is now 18:35. Server port: 21.
Response:        220-This is a private system - No anonymous login
Response:        220-IPv6 connections are also welcome on this server.
Response:        220 You will be disconnected after 15 minutes of inactivity.
Command:        AUTH TLS
Response:        234 AUTH TLS OK.
Status:        Initializing TLS...
Status:        Verifying certificate...
Command:        USER user1
Status:        TLS/SSL connection established.
Response:        331 User user1 OK. Password required
Command:        PASS **********
Response:        230-User ftp1 has group access to:  client4    sshusers 
Response:        230 OK. Current restricted directory is /
Command:        SYST
Response:        215 UNIX Type: L8
Command:        FEAT
Response:        211-Extensions supported:
Response:        EPRT
Response:        IDLE
Response:        MDTM
Response:        SIZE
Response:        REST STREAM
Response:        MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
Response:        MLSD
Response:        AUTH TLS
Response:        PBSZ
Response:        PROT
Response:        UTF8
Response:        ESTA
Response:        PASV
Response:        EPSV
Response:        SPSV
Response:        ESTP
Response:        211 End.
Command:        OPTS UTF8 ON
Response:        200 OK, UTF-8 enabled
Command:        PBSZ 0
Response:        200 PBSZ=0
Command:        PROT P
Response:        200 Data protection level set to "private"
Status:        Connected
Status:        Retrieving directory listing...
Command:        PWD
Response:        257 "/" is your current location
Command:        TYPE I
Response:        200 TYPE is now 8-bit binary
Command:        PASV
Response:        227 Entering Passive Mode (192,168,xx,yyy,196,204)
Command:        MLSD
Response:        150 Accepted data connection
Response:        226-Options: -a -l
Response:        226 9 matches total
Status:        Directory listing successful

and as plain....
Code:

Status:        Connecting to 192.168.xx.yyy:21...
Status:        Connection established, waiting for welcome message...
Response:        220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response:        220-You are user number 2 of 50 allowed.
Response:        220-Local time is now 18:41. Server port: 21.
Response:        220-This is a private system - No anonymous login
Response:        220-IPv6 connections are also welcome on this server.
Response:        220 You will be disconnected after 15 minutes of inactivity.
Command:        USER user1
Response:        331 User user1 OK. Password required
Command:        PASS **********
Response:        230-User ftp1 has group access to:  client4    sshusers 
Response:        230 OK. Current restricted directory is /
Command:        OPTS UTF8 ON
Response:        200 OK, UTF-8 enabled
Status:        Connected
Status:        Retrieving directory listing...
Command:        PWD
Response:        257 "/" is your current location
Status:        Directory listing successful


Salital 3rd October 2011 21:33

but your FTP connection at your webserver is inside your network

did you try an outside FTP connection to reach your webserver?

thanks,

S

eko_taas 3rd October 2011 22:32

Yes, I showed only as internal "call", (true) internet

actually in my case:
- my server1 is on "1st layer" (Buffalo ADSL router, server1 as DMZ) and home users are on "2nd layer" (Buffalo WLAN router behind ADSL-router). This way (possible) family-PCs / NAS-units always as safe as normal home ;-) .

web and ftp works same way both from 2nd layer and from internet - only problem here has been SMTP (port 25) which has been closed (in&out) by ISP (I learned hard way). Planning to change my ISP to get them opened (receiving emails main issue now).

When using domain-name (instead of local IP-address=:
Code:

Status:        Resolving address of example.com
Status:        Connecting to xx.245.abc.def:21...
Status:        Connection established, waiting for welcome message...
Response:        220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response:        220-You are user number 1 of 50 allowed.
Response:        220-Local time is now 20:17. Server port: 21.
Response:        220-This is a private system - No anonymous login
Response:        220-IPv6 connections are also welcome on this server.
Response:        220 You will be disconnected after 15 minutes of inactivity.
Command:        AUTH TLS
Response:        234 AUTH TLS OK.
Status:        Initializing TLS...
Status:        Verifying certificate...
Command:        USER user1
Status:        TLS/SSL connection established.
Response:        331 User user1 OK. Password required
Command:        PASS **********
Response:        230-User ftp1 has group access to:  client4    sshusers 
Response:        230 OK. Current restricted directory is /
Command:        SYST
Response:        215 UNIX Type: L8
Command:        FEAT
Response:        211-Extensions supported:
Response:        EPRT
Response:        IDLE
Response:        MDTM
Response:        SIZE
Response:        REST STREAM
Response:        MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
Response:        MLSD
Response:        AUTH TLS
Response:        PBSZ
Response:        PROT
Response:        UTF8
Response:        ESTA
Response:        PASV
Response:        EPSV
Response:        SPSV
Response:        ESTP
Response:        211 End.
Command:        OPTS UTF8 ON
Response:        200 OK, UTF-8 enabled
Command:        PBSZ 0
Response:        200 PBSZ=0
Command:        PROT P
Response:        200 Data protection level set to "private"
Status:        Connected
Status:        Retrieving directory listing...
Command:        PWD
Response:        257 "/" is your current location
Command:        TYPE I
Response:        200 TYPE is now 8-bit binary
Command:        PASV
Response:        227 Entering Passive Mode (192,168,xx,yyy,196,3)
Status:        Server sent passive reply with unroutable address. Using server address instead.
Command:        MLSD
Response:        150 Accepted data connection
Response:        226-Options: -a -l
Response:        226 9 matches total
Status:        Directory listing successful

and
Code:

Status:        Resolving address of example.com
Status:        Connecting to aa.245.bb.ccc:21...
Status:        Connection established, waiting for welcome message...
Response:        220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response:        220-You are user number 1 of 50 allowed.
Response:        220-Local time is now 20:21. Server port: 21.
Response:        220-This is a private system - No anonymous login
Response:        220-IPv6 connections are also welcome on this server.
Response:        220 You will be disconnected after 15 minutes of inactivity.
Command:        USER user1
Response:        331 User user1 OK. Password required
Command:        PASS **********
Response:        230-User ftp1 has group access to:  client4    sshusers 
Response:        230 OK. Current restricted directory is /
Command:        SYST
Response:        215 UNIX Type: L8
Command:        FEAT
Response:        211-Extensions supported:
Response:        EPRT
Response:        IDLE
Response:        MDTM
Response:        SIZE
Response:        REST STREAM
Response:        MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
Response:        MLSD
Response:        AUTH TLS
Response:        PBSZ
Response:        PROT
Response:        UTF8
Response:        ESTA
Response:        PASV
Response:        EPSV
Response:        SPSV
Response:        ESTP
Response:        211 End.
Command:        OPTS UTF8 ON
Response:        200 OK, UTF-8 enabled
Status:        Connected
Status:        Retrieving directory listing...
Command:        PWD
Response:        257 "/" is your current location
Command:        TYPE I
Response:        200 TYPE is now 8-bit binary
Command:        PASV
Response:        227 Entering Passive Mode (aa,245,bbb,cc,196,211)
Command:        MLSD
Response:        150 Accepted data connection
Response:        226-Options: -a -l
Response:        226 9 matches total
Status:        Directory listing successful

l works also with laptop / GPRS (i.e. from internet). I hope some help for you....


All times are GMT +2. The time now is 14:04.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.