HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   postfix error after upgrade (http://www.howtoforge.com/forums/showthread.php?t=54351)

kwickcut 30th September 2011 06:14

postfix error after upgrade
 
hello all i have just upgraded to ubuntu 10.04 and ispconfig 3.0.3.3 and now i am having troubles

first thing is in ispconfig under Status of Services it shows dns- server is not running and smtp server is not running.

now i restarted postfix
Code:

sudo /etc/init.d/postfix restart
and it is running but it still shows not running under under ispconfig.


when i goto a site and send an email i am getting the following error
Code:

(connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
i i found that this could mean that amavis is not running so i did the following

Code:

postconf -e 'content_filter = amavis:[127.0.0.1]:10024'
Reload/Restart postfix ..
Code:

postfix reload
And check if amavis is running..
Code:

netstat -tap | grep amavis
(you should see a LISTEN port..) but i dont get anything

any ideas


kwick

till 30th September 2011 10:05

You have to upgrade ispconfig after you upgraded ubuntu and then select to reconfigure services in ispconfig. If you upgraded ispconfig first, then you have to do a manual ispconfig update now and choose to reconfigure services.

kwickcut 30th September 2011 11:46

ok i did upgrade ubuntu first then ungraded ispconfig. where would i find this reconfigure services in ispconfig



kwick

till 30th September 2011 12:10

download ispconfig tar.gz, unpack it and then run upfate.php script again.

kwickcut 30th September 2011 14:02

so should i
Code:

cd /tmp
wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
tar xfz ISPConfig-3-stable.tar.gz
cd ispconfig3_install/install/

then run
Code:

php -q install.php
and do the set up again like i did when i first installed ispconfig?

and this will not bother any sites that are running?

thanks again

kwick

kwickcut 1st October 2011 00:42

ok i have downloaded and ran the update script and i have the save issue postfix is running but ispconfig does not see it i think went wrong with the upgrade of Ubuntu



kwick

kwickcut 1st October 2011 07:07

UPDATE
i cant start amavisd this is what i get when i try any ideas?


Code:

root@myhost:~# sudo /etc/init.d/amavis restart
Stopping amavisd: (not running).
Starting amavisd: hostname: Name or service not known
  The value of variable $myhostname is "", but should have been
  a fully qualified domain name; perhaps uname(3) did not provide such.
  You must explicitly assign a FQDN of this host to variable $myhostname
  in /etc/amavis/conf.d/05-node_id, or fix what uname(3) provides as a host's
  network name!


falko 1st October 2011 09:16

Open your amavisd configuration and set the correct $myhostname value (usually localhost should work).

kwickcut 1st October 2011 15:43

sorry for this but i cant find the config file unless it is this
Code:

/etc/amavis/conf.d/15-content_filter_mode
if this is it this is the output and i am not sure where to add it

Code:

use strict;

# You can modify this file to re-enable SPAM checking through spamassassin
# and to re-enable antivirus checking.

#
# Default antivirus checking mode
# Uncomment the two lines below to enable it
#

@bypass_virus_checks_maps = (
  \%bypass_virus_checks, \@bypass_virus_checks_acl, \$bypass_virus_checks_re);


#
# Default SPAM checking mode
# Uncomment the two lines below to enable it
#

@bypass_spam_checks_maps = (
  \%bypass_spam_checks, \@bypass_spam_checks_acl, \$bypass_spam_checks_re);

1;  # insure a defined return


kwick

falko 1st October 2011 20:57

Did you check the other files in the /etc/amavis/conf.d/ directory (and also in the parent directory /etc/amavis/)?


All times are GMT +2. The time now is 07:58.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.