HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   short_open_tag disabling for a certain site (http://www.howtoforge.com/forums/showthread.php?t=54301)

JEU 27th September 2011 22:04

short_open_tag disabling for a certain site
 
Hello guys, im trying to get some site developed with symfony up, my problem is that the "check.php" who test the enviroment for symfony keeps telling me that "short_open_tag = On". I have "php_flag short_open_tag Off" on the php.ini configuration for that site, but doesnt work.

Any ideas??

P.S.: phpinfo() is telling the same thing about short_open_tag.

till 27th September 2011 22:59

Which php mode do you use in that site?

JEU 27th September 2011 23:05

Quote:

Originally Posted by till (Post 264328)
Which php mode do you use in that site?

It has Enabled CGI/SuEXEC and PHP is set on "Fast-CGI"

till 27th September 2011 23:18

Ok. Then you have to enter this line into the php.ini field of the website, press save and wait a minute:

short_open_tag = On

The syntax with php flag that you used is for mod php only and is used in the apache directives field then and not the php ini field.

JEU 27th September 2011 23:49

Quote:

Originally Posted by till (Post 264330)
Ok. Then you have to enter this line into the php.ini field of the website, press save and wait a minute:

short_open_tag = On

The syntax with php flag that you used is for mod php only and is used in the apache directives field then and not the php ini field.

Excellent!. Its working now thks!! :D.

Of course that i didnt knew that about syntax, can you briefly resume which syntax must be used which each PHP setting?
I assume it will be the same that you've showed me for CGI/FastCGI, but what happens if im using ModPHP or suPHP?

I have a Moodle installation (Fast-CGI) and it seems to work fine with:

Code:

php_flag magic_quotes_gpc Off
php_flag magic_quotes_runtime Off
php_flag file_uploads On
php_flag short_open_tag On
php_flag session.auto_start Off
php_flag session.bug_compat_warn Off
php_value upload_max_filesize 2M
php_value post_max_size 2M

in the php.ini from that site, but now i realize that is wrong, however why it worked? (or at least moodle didnt complained about it).

Thks for being patient :)


All times are GMT +2. The time now is 11:29.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.