HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Pure-FTPd configuration (http://www.howtoforge.com/forums/showthread.php?t=54239)

msp 23rd September 2011 04:21

Pure-FTPd configuration
 
Hi there

I'd like to enable file transfer resume on Pure-FTPd server, on my ISPConfig3 installation.

The reason is that I have large (2GB +) files to transfer by SFTP or FTPS.

Is this something I should do through ISPConfig interface, config files, or through Pure-FTPd config files?

If so, please can someone tell me where to look?

Thanks,

Mat

till 23rd September 2011 09:21

This has to be configured in the pure-ftpd config files. Which Linux distribution do you use?

msp 23rd September 2011 13:06

Hi,

I'm using Debian Squeeze.

There are a bunch of files in /etc/pure-ftpd/conf

Each file is a setting. Do I need to create a new file?

- I read somewhere that by setting an option called "KeepAllFiles", this prevents users from deleting files as well as allowing resume upload. Is that right? I don't want to prevent users from deleting files. I just want to be able to resume upload.

- I also read somewhere that there is a 2GB file size limit for resuming uploads. (i.e. if the file is over 2GB, upload will not resume). My question is: why?! And can I stop that?

Do I need to configure a new FTP daemon if I need file upload resume AND ability to delete files?

Sorry for all the questions. The pure-ftpd docs are ... shall we say, not clear on the matter!

msp 26th September 2011 04:54

Quick bump -

Does anyone know how to configure file upload resume *but* also not prevent file deletions with pure-ftpd? (On Debian Squeeze)

Thanks!

Mat

falko 26th September 2011 09:52

I've just taken a look at pure-ftpd's man page, but could not find anything about upload resume...

cbj4074 27th September 2011 22:44

Quote:

Originally Posted by msp (Post 264048)
I'd like to enable file transfer resume on Pure-FTPd server, on my ISPConfig3 installation.

Have you confirmed that resuming file transfers does not already function as expected (by default)?

If so, is there a particular error message that the client or server produces when resuming is unsuccessful?

Finally, is your system architecture 64-bit and is large file support enabled in pureFTPd?

See this thread, too: http://www.howtoforge.com/forums/arc...p/t-46972.html

msp 28th September 2011 01:55

Quote:

Originally Posted by cbj4074 (Post 264332)
Have you confirmed that resuming file transfers does not already function as expected (by default)?

If so, is there a particular error message that the client or server produces when resuming is unsuccessful?

Yes - file resume to other FTP servers (i.e. other hosting providers with their own FTP servers) always works but it doesn't work on my own private server.

There is no error. My client (Filezilla for Windows - very common open source client) prompts for the action if a file exists: restart transfer, resume, skip, etc. When you click "resume transfer", it doesn't error, the log of the ftp session is completely as it should be (simply issues a PUT command), but it just restarts the file from 0 bytes.



Quote:

Originally Posted by cbj4074 (Post 264332)
Finally, is your system architecture 64-bit and is large file support enabled in pureFTPd?

See this thread, too: http://www.howtoforge.com/forums/arc...p/t-46972.html

I haven't been able to check whether I installed a 64 or 32 OS, I'll check.

I haven't made any changes to the daemon since installing the recommended setup for Debian Squeeze.


All times are GMT +2. The time now is 15:01.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.