HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Email Routing (http://www.howtoforge.com/forums/showthread.php?t=54162)

SamTzu 16th September 2011 20:41

Email Routing
 
I built a mail-relay server behind a fire-wall and cant get it to relay mail back to internet.
It bounces the email immediately if the receiving external server is down.

Quote:

Sep 16 21:23:16 list-fi postfix/qmgr[796]: 67B1D52AA92: from=<sami@sender.com>, size=1993, nrcpt=1 (queue active)
Sep 16 21:23:16 list-fi postfix/smtpd[817]: disconnect from unknown[10.10.11.1]
Sep 16 21:23:17 list-fi postfix/smtpd[827]: connect from localhost.localdomain[127.0.0.1]
Sep 16 21:23:17 list-fi postfix/smtpd[827]: C1D5F52AA9F: client=localhost.localdomain[127.0.0.1]
Sep 16 21:23:17 list-fi postfix/cleanup[823]: C1D5F52AA9F: message-id=<ffe99b92-9de0-4f36-907b-45b9b26989f1@server17>
Sep 16 21:23:17 list-fi postfix/qmgr[796]: C1D5F52AA9F: from=<sami@sender.com>, size=2504, nrcpt=1 (queue active)
Sep 16 21:23:17 list-fi postfix/smtpd[827]: disconnect from localhost.localdomain[127.0.0.1]
Sep 16 21:23:17 list-fi amavis[32093]: (32093-03) Passed CLEAN, LOCAL [10.10.11.1] [79.133.108.180] <sami@sender.com> -> <info@receiver.com>, Message-ID: <ffe99b92-9de0-4f36-907b-45b9b26989f1@server17>, mail_id: i9u5Eq4uTaWF, Hits: 0.645, size: 1992, queued_as: C1D5F52AA9F, 1334 ms
Sep 16 21:23:17 list-fi postfix/smtp[824]: 67B1D52AA92: to=<info@receiver.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=1.4, delays=0.1/0.01/0/1.3, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=32093-03, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as C1D5F52AA9F)
Sep 16 21:23:17 list-fi postfix/qmgr[796]: 67B1D52AA92: removed
Sep 16 21:23:17 list-fi postfix/smtp[829]: connect to mail.receiver.com[79.133.125.179]:25: Connection refused
Sep 16 21:23:18 list-fi postfix/smtp[829]: C1D5F52AA9F: to=<info@receiver.com>, relay=none, delay=0.18, delays=0.05/0.01/0.11/0, dsn=4.4.1, status=deferred (connect to mail.reciver.com[79.133.125.179]:25: Connection refused)
Sep 16 21:23:18 list-fi postfix/qmgr[796]: C1D5F52AA9F: from=<sami@sender.com>, status=expired, returned to sender
I'm pretty sure these settings are correct.

Email Routing
- Domain = receiver.com
- Destination = mail.receiver.com
Email relay recipient
- info@receiver.com

What am I missing?

falko 17th September 2011 11:31

Please check if your server is blacklisted: http://mxtoolbox.com/blacklists.aspx

SamTzu 17th September 2011 13:12

Nope, neither sender, relay or receiving are not blacklisted.

falko 18th September 2011 10:28

Do you have this problem for all recipients, or just for certain ones (same domain?)?

OnePercentile 22nd September 2011 18:09

ISPConfig 3.0.3.3 Alias Email Domain Not rejecting bad users
 
I'm sorry if this is not in the right category:

In ISPConfig 3.0.3.3, Postfix is mishandling Alias Email Domain messages when user portion of email address is misspelled.

Example.

Alias Email Domain: A-domain -> B-domain

User: userA (mailbox in B-domain).

WORKING:
Send a message to userA@B-domain (gets to userA@B-domain)
Send a message to userA@A-domain (gets to userA@B-domain)
Send a message to userB@B-domain (gets rejected)

NOT WORKING:
Send a message to userB@A-domain (creates userB in the B-domain folder, but should be rejected because userB doesn't exist @B-domain. Over time I have tons of Maildir folders with mistyped users@alias-domains that have to be cleaned up..

Will continue to find possible mail drop issues that might be breaking in the mail user verify through alias domains..

Thank you

till 22nd September 2011 18:11

Thats a known problem with some imap daemons (please see bugtracker) and has been fixed already in svn.


All times are GMT +2. The time now is 01:45.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.