HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   apache restart mysql connection problem (http://www.howtoforge.com/forums/showthread.php?t=54140)

(O)fer_cz 15th September 2011 11:29

apache restart mysql connection problem
 
Hi,
I have ISP Config multi server running on Debian 6 Squeeze.
I had exacly same instalation as described in how to. But then I wanted to split web.example.tld to admin.example.tld

(ex web.example.tld) and web1.example.tld (newly insalled). I managed to get it work.
But now, if I wanna restart apache with /etc/init.d/apache restart, i get error problem with mysqldatabase.


in error log:
Quote:

DBI connect('database=dbispconfig;host=web.example.tld :3306','ispcsrv6',...) fai led: Unknown MySQL server host

'web.example.tld' (1) at /usr/local/ispconfig/ser ver/scripts/vlogger line 257
[Wed Sep 14 21:51:52 2011] [notice] Apache/2.2.16 (Debian) DAV/2 mod_fcgid/2.3.6 PHP/5.3.3-7+squeeze3 with Suhosin-

Patch mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16) m od_ssl/2.2.16 OpenSSL/0.9.8o configured -- resuming normal operations
DBI connect('database=dbispconfig;host=web.example.tld :3306','ispcsrv6',...) fai led: Unknown MySQL server host

'web.example.tld' (1) at /usr/local/ispconfig/ser ver/scripts/vlogger line 514
DBI Error: at /usr/local/ispconfig/server/scripts/vlogger line 514, <STDIN> lin e 13.
I have fixed this by pointing web.example.tld to web1.example.tld (or should I point it to admin.example.tld?)
What config should I change to get rid of this problem? Thank for reply.

now i have problems with this

Quote:

piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d

"/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
Unrecognized argument USaa!x at /usr/local/ispconfig/server/scripts/vlogger line 147
BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 149.
logs are from web1.example.tld

till 15th September 2011 11:55

Seems as if you have a syntax error in the file /etc/vlogger-dbi.conf. Make sure that you use the same username and password for the ispconfig master database in that file that are used inside the /usr/local/ispconfig/server/lib/config.inc.php file for the master database.

(O)fer_cz 15th September 2011 19:25

http://i.imgur.com/hgyOb.png

in /etc/vlogger-dbi.conf was host set to old web.example.tld so i changed it to admin.example.tld. Its still writiing entries to error log:

Quote:

piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
Unrecognized argument USaa!x at /usr/local/ispconfig/server/scripts/vlogger line 147
BEGIN failed--compilation aborted at /usr/local/ispconfig/server/scripts/vlogger line 149.
After some time, i cannt load any of my websites, or theyr loading very very slow. (timeout / connection terminated...)
After apache restart, everythink is fine and fast.

(O)fer_cz 15th September 2011 21:23

this is what gives error
Quote:

line 147: use sigtrap qw(handler exitall HUP USaa!x
line 148: M!x
line 149: :x INT PIPE);
problem is somewhere with this vlogger config, cause its still writing same to error log, which is growing (now its 30mb...)

theese lines were f*cked up, i dont know why, it should look like this without line 148 and 149

Quote:

line 147: use sigtrap qw(handler exitall HUP USR1 TERM INT PIPE);
=delete=ine 148: M!x
=delete=line 149: :x INT PIPE);
few other lines below and above were same

thanks for help with config change.


All times are GMT +2. The time now is 20:22.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.