HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   SMTP Server Offline (http://www.howtoforge.com/forums/showthread.php?t=54068)

zenny 7th September 2011 10:08

[SOLVED]: SMTP Server Offline
 
I have updated Centos 5.6 (updated with some perl-Compress-Raw-Bzip2 and perl-Compress-Raw-Zlib errors, but solved by downgrading and upgrading as stated http://www.centos.org/modules/newbb/...25120&forum=37 and reinstalled all dependencies including amavisd-new and spamassasin and all other 5 dependencies). I still have ISPConfig 3.0.2.2.

It was a running ISPConfig server but went amok after CentOS update. with the SMTP Server always offline. So far, I tried:

1) /etc/init.d/postfix restart
(gives not error, but dies after a few seconds)

2) The last 20 lines of maillog (tail -n 20 /var/log/maillog) shows this line repeatedly:

Sep 7 09:56:35 server1 amavis[6165]: (!)Net::Server: 2011/09/07-09:56:35 Couldn't open lock file "/var/amavis/amavisd.lock"[Permission denied]\n at line 203 in file /usr/lib/perl5/vendor_perl/5.8.8/Net/Server/PreForkSimple.pm

3) I checked with postfix -d | grep mynetworks which results:

mynetworks = 127.0.0.0/8 PUBLIC_IP_1/30 PUBLIC_IP_2/32
mynetworks_style = subnet
parent_domain_matches_subdomains = debug_peer_list,fast_flush_domains,mynetworks,perm it_mx_backup_networks,qmqpd_authorized_clients,rel ay_domains,smtpd_access_maps
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks
smtpd_client_event_limit_exceptions = ${smtpd_client_connection_limit_exceptions:$mynetw orks}
smtpd_recipient_restrictions = permit_mynetworks, reject_unauth_destination

4) I cheked with 'postfix -n | grep mynetworks' which results:

mynetworks = 127.0.0.0/8 [::1]/128
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination

Could not figure out where did I go wrong? Thanks in advance for any inputs.

/zenny

till 7th September 2011 10:16

Download the ispconfig 3 tar.gz and run the update.php script. Choose to reconfigure services during update.

Such problems are commoin when you update Centos as YUM destroys the existing configuration during update. For that reason you should consider to use Debian in case that you install a new server in future as the Debian.

zenny 7th September 2011 10:24

Solved
 
But strange thing is that when I ran 'amavisd debug' command and it started working on it's own without reconfiguring anything.

Thanks Till, do I need just to update or just update to 3.0.3.3 is enough using ispconfig_update.sh script?

till 7th September 2011 11:06

If you have not updated to 3.0.3.3 yet, then its enough to run the ispconfig_update.sh script.

zenny 8th September 2011 08:15

update script halts
 
Hi Till;

Just wanted to inform you that ispconfig_update.sh halts in CentOS5.6 as follows:

Quote:

>> Update

Operating System: CentOS 5 or compatible

This application will update ISPConfig 3 on your server.
mysqldump: Got error: 1045: Access denied for user 'root'@'localhost' (using password: YES) when trying to connect
mysqldump: Got error: 1045: Access denied for user 'root'@'localhost' (using password: YES) when trying to connect
PHP Warning: mysql_connect(): Access denied for user 'root'@'localhost' (using password: YES) in /tmp/ispconfig3_install/install/lib/mysql.lib.php on line 78
PHP Fatal error: Cannot use string offset as an array in /tmp/ispconfig3_install/install/lib/update.lib.php on line 98
Just for your info.

Update: This is because I changed my mysql root password. There were two options to solve it:
1) Either I make changes in /usr/local/ispconfig/server/mysqlclient_db.conf and append the new password; But still configs the /usr/local/ispconfig/interface/ folder needed to be changed either.

2) Therefore, I took an easy way: I changed the mysql root password to the old one.

And the installation got completed with the following:

Quote:

--------------------------------------------------------------------------------
_____ ___________ _____ __ _ ____
|_ _/ ___| ___ \ / __ \ / _(_) /__ \
| | \ `--.| |_/ / | / \/ ___ _ __ | |_ _ __ _ _/ /
| | `--. \ __/ | | / _ \| '_ \| _| |/ _` | |_ |
_| |_/\__/ / | | \__/\ (_) | | | | | | | (_| | ___\ \
\___/\____/\_| \____/\___/|_| |_|_| |_|\__, | \____/
__/ |
|___/
--------------------------------------------------------------------------------


>> Update

Operating System: CentOS 5 or compatible

This application will update ISPConfig 3 on your server.
Starting full database update.
Starting full PowerDNS database update.
Reconfigure Permissions in master database? (yes,no) [no]:

Reconfigure Services? (yes,no) [yes]:

Configuring Postfix
Configuring Jailkit
Configuring SASL
Configuring PAM
Configuring Courier
Configuring Spamassassin
Configuring Amavisd
Configuring Getmail
Configuring Pureftpd
Configuring PowerDNS
Configuring Apache
Configuring vlogger
Configuring Apps vhost
Configuring Database
Configuring Firewall
Updating ISPConfig
ISPConfig Port [8080]:

Create new ISPConfig SSL certificate (yes,no) [no]:

Reconfigure Crontab? (yes,no) [yes]:

Updating Crontab
Restarting services ...
Stopping MySQL: [ OK ]
Starting MySQL: [ OK ]
Shutting down postfix: [FAILED]
Starting postfix: [ OK ]
Stopping saslauthd: [ OK ]
Starting saslauthd: [ OK ]
Shutting down Mail Virus Scanner (amavisd): [ OK ]
Starting Mail Virus Scanner (amavisd): [ OK ]
Stopping Clam AntiVirus Daemon: [ OK ]
Starting Clam AntiVirus Daemon: Bytecode: Security mode set to "TrustSigned".
LibClamAV Warning: Detected duplicate databases /var/clamav/main.cvd and /var/clamav/main.cld, please manually remove one of them
[ OK ]
Stopping Courier authentication services: authdaemond
Starting Courier authentication services: authdaemond
Stopping Courier-IMAP server: imap imap-ssl pop3 pop3-ssl
Starting Courier-IMAP server: imap imap-ssl pop3 pop3-ssl
Stopping httpd: [ OK ]
Starting httpd: [ OK ]
Stopping pure-ftpd: [ OK ]
Starting pure-ftpd: [ OK ]
Update finished.
Yet, the smtp server seems offline eventhough ISPConfig3 panel shows all servers are running alright :-(

zenny 8th September 2011 09:02

smtp error
 
I am getting these errors at /var/log/maillog, when I connect to webmail and try to send an email:

Quote:

# tail -f /var/log/maillog
Sep 8 08:54:42 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
Sep 8 08:54:42 server1 imapd: LOGIN, user=zenny@domain.tld, ip=[::ffff:127.0.0.1], port=[54533], protocol=IMAP
Sep 8 08:54:43 server1 imapd: LOGOUT, user=zenny@domain.tld, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=33, sent=277, time=1
Sep 8 08:55:01 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
Sep 8 08:55:01 server1 pop3d: Disconnected, ip=[::ffff:127.0.0.1]
Sep 8 08:55:01 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
Sep 8 08:55:01 server1 imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
Sep 8 08:55:16 server1 imapd: Connection, ip=[::ffff:127.0.0.1]
Sep 8 08:55:16 server1 imapd: LOGIN, user=zenny@domain.tld, ip=[::ffff:127.0.0.1], port=[54541], protocol=IMAP
Sep 8 08:55:30 server1 postfix/smtpd[29395]: fatal: unsupported dictionary type: mysql
Sep 8 08:55:31 server1 postfix/qmgr[29397]: fatal: unsupported dictionary type: mysql
Sep 8 08:55:31 server1 postfix/master[27112]: warning: process /usr/libexec/postfix/smtpd pid 29395 exit status 1
Sep 8 08:55:31 server1 postfix/master[27112]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Sep 8 08:55:32 server1 postfix/master[27112]: warning: process /usr/libexec/postfix/qmgr pid 29397 exit status 1
Sep 8 08:55:32 server1 postfix/master[27112]: warning: /usr/libexec/postfix/qmgr: bad command startup -- throttling
Sep 8 08:56:31 server1 postfix/smtpd[29435]: fatal: unsupported dictionary type: mysql
Sep 8 08:56:32 server1 postfix/qmgr[29436]: fatal: unsupported dictionary type: mysql

zenny 8th September 2011 09:47

Solved
 
OKAY I fixed the error by reinstalling postfix with mysql support.

Details at: http://www.question-defense.com/2011...maillog-errors

http://www.howtoforge.com/perfect-se...ispconfig-3-p4 and search for 'Applying Quota Patch to Postfix'

Reporting for informational purpose to help others who has similar problems.

Thanks, Falko and Till for your admirable work!


All times are GMT +2. The time now is 08:08.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.