HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   ISPCONFIG3 Centos5 php 5.3 pear problem (http://www.howtoforge.com/forums/showthread.php?t=54019)

andyace 2nd September 2011 14:37

ISPCONFIG3 Centos5 php 5.3 pear problem
 
Hi
I am hosting a new website for a company, the website has been transferred to us from another hosting company. and uses pear for mail
We have ispconfig3 running on centos5 php 5.3 and typically use postfix for all other mail websites which works fine.
i have yum installed pear and it works from the cli, the website throws a 500 error when the page with the pear mail reference loads, if i copy the pear mail folder to the website pagem, the page loads and pear works, i have set the path .:/usr/share/pear etc in php.ini and have set the vhost path and recreated the website vhost and copied the files back, still no luck, im guessing its a pathing or rights issue, do i need to set an allow directive to the usr/share/pear folder somewhere? also i cant see any log files with any relevant errors in.

thanks for checking my thread.

Andy

falko 3rd September 2011 11:14

Did you check Apache's error log?

andyace 5th September 2011 17:08

HI
Yep nothing in error_log in httpd, apart from some xend shell errors and timezone set incorrectly for some sites.

till 5th September 2011 22:20

You can find the exact error message in the error.log of the website. Dont llok in the global error.log, use the error.log of the website.

till 5th September 2011 22:21

And please do not post duplicate threads!

andyace 5th September 2011 22:43

Hi

Sorry about the double post i found this forum was more specific to the problem

In the php page if i hash out the 2 mail.php calls the page loads but the email function on the page doesn't work

# GET PEAR FUNCTIONS
# ("Mail.php");
# ("Mail/mime.php");

If i remove the hashes the page gets this error

HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

and all i get this (i think unrelated) error in the websites error log

[Mon Sep 05 21:26:43 2011] [warn] mod_fcgid: stderr: PHP Warning: date() [<a href='function.date'>function.date</a>]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/London' for 'BST/1.0/DST' instead in /var/www/clients/client21/web90/web/destinations/index.php on line 182

if i copy all the pear folders and files from the /usr/share/pear folder to the website directory that this php file is being called from it all works but isn't very practical

Thanks

Andy

falko 6th September 2011 10:50

I think you need to add /usr/share/pear to your OpenBasedir directories in ISPConfig.

andyace 6th September 2011 11:55

thanks
I have added the PEAR path in the ispconfig openbasedir tab on this websites config, tentatively it seems to be ok.

will report back when i have removed all the pear folders splattered all over the website.

Thanks So Far So Good

andyace 6th September 2011 21:59

That fixed it, easy when your led in the right direction, hope this helps someone else.

Thanks Again

Andy

rsonline 26th April 2012 21:05

It's helps me :)


All times are GMT +2. The time now is 15:48.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.