HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   apache2 throws up a few warns during restart (ISPConfig3) (http://www.howtoforge.com/forums/showthread.php?t=54008)

wake2010 1st September 2011 21:03

apache2 throws up a few warns during restart (ISPConfig3)
 
Hey,
I am testing this script on a Home made Server.

All set up well, I managed to modify a DNS Record on my primary web host to redirect my subdomain local.xyz.tld and it works well I manage to get the default index page, However i noticed While using my Shell Access to restart the services Apache brings up the following:
Code:

[Thu Sep 01 19:55:23 2011] [warn] NameVirtualHost 192.168.0.200:80 has no VirtualHosts
[Thu Sep 01 19:55:23 2011] [warn] NameVirtualHost 192.168.0.200:443 has no VirtualHosts
 ... waiting [Thu Sep 01 19:55:24 2011] [warn] NameVirtualHost 192.168.0.200:80 has no VirtualHosts
[Thu Sep 01 19:55:24 2011] [warn] NameVirtualHost 192.168.0.200:443 has no VirtualHosts

:confused::confused:

My setup is as follows

My Server is setup via a router with DMZ enabled (for now) and my router IP is semi-static (only changes if i turn off my router which is never) so my server has a local STATIC IP as shown above.

also i can not access webmail when using outside the internal network.

Any Help would be massive!! thanks =]:D

mentes 1st September 2011 22:21

Don't worry. This is because you haven't created any site on this ip.

How do you try access to webmail? http://local.xyz.tld/webmail ?

wake2010 1st September 2011 22:22

well at first it was domain.com/webmail but with that not working i decided to try a mod to allow webmail.domain.com both fail

wake2010 1st September 2011 22:23

also my ispconfig system messages log says "unable ro read /var/log/messages"

mentes 1st September 2011 22:33

For webmail.domain.com you need create a subdomain and add A DNS record.

When you try to access to your webmail ...
... error.log shows something ?
... do you get some error in your browser?

Can you access from your internal network ?

wake2010 1st September 2011 22:46

Quote:

For webmail.domain.com you need create a subdomain and add A DNS record.
I did that from outset. I forgot to mention i had checked all DNS record as i run companies shared hosts dns records =]


Quote:

When you try to access to your webmail ...
... error.log shows something ?
where is that again? being a total *unix noob and used to cpanel...

Quote:

... do you get some error in your browser?
yes when i run via domain.com/webmail i get 404 as of writing i am restarting server

Quote:

Can you access from your internal network ?
i am accessing the server through http and by ssh on local network

im at a loss

wake2010 1st September 2011 22:56

ok i realised what i did wrong i used a A record on my main host dns and not a ns record for the subdomain.

time to contact webhost :S any ideas of what domain registrars allow subdomain NS records if this goes bad?

mentes 1st September 2011 22:59

Quote:

Originally Posted by wake2010 (Post 262771)
being a total *unix noob and used to cpanel...

Well, then step by step.

In ssh console, type:

Code:

tail -f /var/www/yourdomain.com/log/error.log
"tail" reads the last lines of a file.

Then, try to access to domain.com/webmail and paste here the new lines you get.

wake2010 1st September 2011 23:01

Code:

[Thu Sep 01 20:03:09 2011] [error] [client 192.168.0.254] File does not exist: /var/www/local.advancetechuk.com/web/webmail
[Thu Sep 01 21:23:34 2011] [error] [client 192.168.0.254] File does not exist: /var/www/local.advancetechuk.com/web/webmail
[Thu Sep 01 21:23:34 2011] [debug] mod_deflate.c(615): [client 192.168.0.254] Zlib: Compressed 1806 to 791 : URL /error/404.html
[Thu Sep 01 21:25:16 2011] [error] [client 192.168.0.254] File does not exist: /var/www/local.advancetechuk.com/web/webmail
[Thu Sep 01 21:25:16 2011] [debug] mod_deflate.c(615): [client 192.168.0.254] Zlib: Compressed 1806 to 791 : URL /error/404.html
[Thu Sep 01 21:25:16 2011] [error] [client 192.168.0.254] File does not exist: /var/www/local.advancetechuk.com/web/favicon.ico
[Thu Sep 01 21:25:16 2011] [debug] mod_deflate.c(615): [client 192.168.0.254] Zlib: Compressed 1806 to 791 : URL /error/404.html


mentes 1st September 2011 23:04

Quote:

Originally Posted by wake2010 (Post 262772)
ok i realised what i did wrong i used a A record on my main host dns and not a ns record for the subdomain.

You don't need NS record for subdomain like webmail.domain.com

Quote:

Originally Posted by wake2010 (Post 262772)
time to contact webhost :S any ideas of what domain registrars allow subdomain NS records if this goes bad?

Maybe is better you delegate DNS to ISPConfig.


All times are GMT +2. The time now is 08:27.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.