HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   mail module doesnt work (http://www.howtoforge.com/forums/showthread.php?t=53945)

matej 28th August 2011 16:54

mail module doesnt work
 
I've installed fresh ISP config 3 on Centos 6.0 (folowed perfect manual). Everything went fine, but when I login into ISPConfig panel and click into "Email" module (big icon in header) nothing hapens (ispconfing doesnt show list of email domains...). Sites, dns... everthing works well, just email doesn't work (same if I click domain/alisa, email-mailbox... doesn't show list).

Please help.

CSsab 28th August 2011 17:07

Is postfix running?
Is mysql running?

Check the outputs of:
netstat -tap

matej 28th August 2011 17:52

yes both of them are running.
As I said, all other "modules" are working fine (so mysql works..), just when I click something inside "email" - it does show any list.
In apache log I cannot find any error. Is there any other (ispconfig specific) log to look at?

CSsab 28th August 2011 18:07

In Server -> services is your mail server showing as online?

Have you tried logging into ISPConfig with a different browser?

Yes you can try this:

sh /usr/local/ispconfig/server/cron_daily.sh

If all is well it will say "finished."

Also to get a verbose output do this:

sh -x /usr/local/ispconfig/server/cron_daily.sh

And post the outputs.

matej 28th August 2011 18:20

1 Attachment(s)
Output of cronjob is:

Code:

+ PATH=/sbin:/usr/sbin:/bin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin
+ /usr/bin/php -q /usr/local/ispconfig/server/cron_daily.php
PHP Warning:  strtotime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead in /usr/local/ispconfig/server/cron_daily.php on line 120
PHP Warning:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead in /usr/local/ispconfig/server/cron_daily.php on line 120
PHP Warning:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead in /usr/local/ispconfig/server/cron_daily.php on line 219
PHP Warning:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead in /usr/local/ispconfig/server/cron_daily.php on line 235
PHP Warning:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead in /usr/local/ispconfig/server/cron_daily.php on line 352
finished.

Probably thease warnings shouldn't be problem?

I'm not sure if I described my problem correctly.
When I click on "Email" in header of ispconfig, I get on left side correct navigator "Email Accounts", and below "Domain, Domain Alias...", but the "main part" of windows remains (it doesn't show "Email Domain list".). I'm attaching screenshot - after login i have clicked Email...

Thanks for help.

CSsab 28th August 2011 18:42

Yes you described your problem correctly although I have never had this problem which is why I am asking you possibly silly questions :p.

Okay the timezone problem can be fixed by following the steps here:
http://www.howtoforge.com/forums/showthread.php?t=53610

matej 28th August 2011 18:47

Ok, I hope that someone will have any idea what can I do to fix this problem.

CSsab 28th August 2011 18:52

Did you fix your timezone?

matej 28th August 2011 19:06

Yes I did. cron_daily.php gives no error. But "mail module" in ISP config still doesn't work.

CSsab 28th August 2011 19:11

Can you please restart your services:
/etc/init.d/postfix restart
/etc/init.d/mysql restart
/etc/init.d/apache2 restart

There are other things you can look at if this doesn't work.


All times are GMT +2. The time now is 00:44.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.