HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   PhpMyadmin 3.4.4 errors (http://www.howtoforge.com/forums/showthread.php?t=53921)

neobcn 26th August 2011 17:08

PhpMyadmin 3.4.4 errors
 
Hi i upload the new version of Phpmyadmmin, i reupload de config.inc.php.

all ok but appear this errors, please see the attach capture.

http://fotos.inteltel.com/?dm=JXUP
http://fotos.inteltel.com/?dt=8PSY

ande 26th August 2011 18:38

Looks like phpMyAdmin works fine, it complains only that you'll have to create the "Linked Tables Infrastructure" if you want to use SQL-History, Relations manager etc.

See http://www.phpmyadmin.net/documentation/#linked-tables

As far as I remember, you'll have to

- create a database mostly called "phpmyadmin" . There is a SQL file for that that you may import.
- create an underpriviledged user and give it (him?) only rights to that database, and SELECT rights on teh database "mysql".
- write user / password / database in the config.inc.php

It was always not very intuitive, but after RTFM it works mostly..

New phpMyAdmin version looks nice, BTW.

neobcn 26th August 2011 19:11

Very Thx ande but my novice in Linux, please is possible put a guide????

thx a new

i create user "pma" and "pass" the rights i select all in the columm "data"

i import the script create_tables.sql

i edit in : /etc/phpmyadmin/config.inc.php

<?php
/**
* Debian local configuration file
*
* This file overrides the settings made by phpMyAdmin interactive setup
* utility.
*
* For example configuration see /usr/share/doc/phpmyadmin/examples/config.default.php.gz
*
* NOTE: do not add security sensitive data to this file (like passwords)
* unless you really know what you're doing. If you do, any user that can
* run PHP or CGI on your webserver will be able to read them. If you still
* want to do this, make sure to properly secure the access to this file
* (also on the filesystem level).
*/


$i = 0;
// The $cfg['Servers'] array starts with $cfg['Servers'][1]. Do not use $cfg['Servers'][0].
// You can disable a server config entry by setting host to ''.
$i++;

/**
* Read configuration from dbconfig-common
* You can regenerate it using: dpkg-reconfigure -plow phpmyadmin

*/
if (is_readable('/etc/phpmyadmin/config-db.php')) {
require('/etc/phpmyadmin/config-db.php');
}

/* Configure according to dbconfig-common if enabled */
if (!empty($dbname)) {
/* Authentication type */
$cfg['Servers'][$i]['auth_type'] = 'cookie';
/* Server parameters */
if (empty($dbserver)) $dbserver = 'localhost';
$cfg['Servers'][$i]['host'] = $dbserver;

if (!empty($dbport)) {
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['port'] = $dbport;
}
//$cfg['Servers'][$i]['compress'] = false;
/* Select mysqli if your server has it */
$cfg['Servers'][$i]['extension'] = 'mysqli';
/* Optional: User for advanced features */
$cfg['Servers'][$i]['controluser'] = $dbuser;
$cfg['Servers'][$i]['controlpass'] = $dbpass;
/* Optional: Advanced phpMyAdmin features */
$cfg['Servers'][$i]['pmadb'] = $dbname;
$cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
$cfg['Servers'][$i]['relation'] = 'pma_relation';
$cfg['Servers'][$i]['table_info'] = 'pma_table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma_column_info';
$cfg['Servers'][$i]['history'] = 'pma_history';
$cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';
$cfg['Servers'][$i]['tracking'] = 'pma_tracking';

/* Uncomment the following to enable logging in to passwordless accounts,
* after taking note of the associated security risks. */
// $cfg['Servers'][$i]['AllowNoPassword'] = TRUE;

/* Advance to next server for rest of config */
$i++;
}

how to add the new valors???

thx

ande 26th August 2011 20:26

Dear Barcelona guy :)

Quote:

Originally Posted by neobcn (Post 262329)
i create user "pma" and "pass"

That is fine as long as you use a much better password than "pass"!

Quote:

the rights i select all in the columm "data"
No, not necessary to select columns.

1. Create a user with NO rights at all, but password and host = localhost (not "%"!)

2. Grant that user SELECT, INSERT, DELETE, UPDATE permissions only for the database "pma".

That should already resolve most of the problems.

3. Grant that user SELECT permissions for database "mysql".

Quote:

import the script create_tables.sql
Very good, You've seen those tables have been created I assume.

Quote:

i edit in : /etc/phpmyadmin/config.inc.php
Yes, but you see that with Debian, it points to another file:

Quote:

if (is_readable('/etc/phpmyadmin/config-db.php')) {
require('/etc/phpmyadmin/config-db.php');
}
and as I have Debian as wll, I saw that even the other file is empty. So I have no idea right now where phpMyAdmin sits. :-/ Maybe inside /var/local/ispconfig - but please dont tinker there.. might break things.

Till?

neobcn 26th August 2011 20:35

Yes my install is dedian 6 , and i install ispconfig 3 , see the guide in howtooforge

any solution for solve this??


All times are GMT +2. The time now is 17:24.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.