HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Ispconfig 3 Help (http://www.howtoforge.com/forums/showthread.php?t=53912)

r4faga 25th August 2011 18:48

Ispconfig 3 Help
 
i m new user with ispconfig 3 on opensuse 11.4. And i need help. after to install Ispconfig i have to do something more? i mean i have to configurate dovecot, imap, amavis and the others stuffs??? when i finished, i go to admin on my browser (by the way my ip is not 192.168.0.1 is 169.254.xxx.xxx, i have to change on configuration of my programs and asignate this ip?), and when i try to create a new client, the ispconfig program freeze it, and i have to kill and start it again. the system stats is ok and mark green, I saw on logs and saw this:

Mail - Log (Server : xxxxxxxxxxxxx)

Refresh Sequence:
Data from: 2011-08-24 10:50

final part:

Aug 24 10:45:01 condor postfix/smtpd[3932]: connect from localhost[::1]
Aug 24 10:45:01 condor postfix/smtpd[3932]: lost connection after CONNECT from localhost[::1]
Aug 24 10:45:01 condor postfix/smtpd[3932]: disconnect from localhost[::1]
Aug 24 10:46:11 condor clamd[1789]: SelfCheck: Database status OK.
Aug 24 10:50:02 condor dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Aug 24 10:50:02 condor dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured

Mail-Warn - Log (Server : xxxxxxxxxxxxxxxx)

Refresh Sequence:
Data from: 2011-08-24 10:55
Aug 22 16:36:03 linux postfix/postfix-script[2924]: fatal: the Postfix mail system is not running
Aug 22 16:36:28 linux postfix/postfix-script[5142]: fatal: the Postfix mail system is not running
Aug 22 16:36:34 linux postfix/postfix-script[5463]: fatal: the Postfix mail system is not running
Aug 22 16:36:42 linux postfix/postfix-script[5851]: fatal: the Postfix mail system is not running
Aug 23 17:33:22 condor dovecot: Killed with signal 15 (by pid=17743 uid=0 code=kill)
Aug 24 08:14:11 condor dovecot: dovecot: Killed with signal 15 (by pid=6549 uid=0 code=kill)
Aug 24 10:25:09 condor dovecot: dovecot: Killed with signal 15 (by pid=8372 uid=0 code=kill)

Mail-Error - Log (Server : xxxxxxxxxx)

Refresh Sequence:
Data from: 2011-08-24 10:55
Aug 22 16:36:03 linux postfix/postfix-script[2924]: fatal: the Postfix mail system is not running
Aug 22 16:36:28 linux postfix/postfix-script[5142]: fatal: the Postfix mail system is not running
Aug 22 16:36:34 linux postfix/postfix-script[5463]: fatal: the Postfix mail system is not running
Aug 22 16:36:42 linux postfix/postfix-script[5851]: fatal: the Postfix mail system is not running


ystem Messages - Log (Server : xxxxxxxxxxxxxxxxxxxxx)

Refresh Sequence:
Data from: 2011-08-24 10:55

Aug 24 10:50:01 condor /USR/SBIN/CRON[4364]: (root) CMD (/usr/local/ispconfig/server/server.sh &> /dev/null)
Aug 24 10:50:02 condor pure-ftpd: (?@::1) [INFO] New connection from ::1
Aug 24 10:50:02 condor pure-ftpd: (?@::1) [INFO] Logout.
Aug 24 10:51:01 condor /USR/SBIN/CRON[4487]: (root) CMD (/usr/local/ispconfig/server/server.sh &> /dev/null)
Aug 24 10:52:01 condor /USR/SBIN/CRON[4584]: (root) CMD (/usr/local/ispconfig/server/server.sh &> /dev/null)
Aug 24 10:53:01 condor /USR/SBIN/CRON[4678]: (root) CMD (/usr/local/ispconfig/server/server.sh &> /dev/null)
Aug 24 10:54:01 condor /USR/SBIN/CRON[4786]: (root) CMD (/usr/local/ispconfig/server/server.sh &> /dev/null)
Aug 24 10:55:01 condor /USR/SBIN/CRON[4876]: (getmail) CMD (/usr/local/bin/run-getmail.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
Aug 24 10:55:01 condor /USR/SBIN/CRON[4875]: (root) CMD (/usr/local/ispconfig/server/server.sh &> /dev/null)
Aug 24 10:55:02 condor pure-ftpd: (?@::1) [INFO] New connection from ::1
Aug 24 10:55:02 condor pure-ftpd: (?@::1) [INFO] Logout.


Freshclam - Log (Server : xxxxxxxxxxxxxxxxx)

Refresh Sequence:
Data from: 2011-08-24 11:10
Unable to read /var/log/freshclam.log


ClamAV - Log (Server : xxxxxxxxxxxxxxx)

Refresh Sequence:
Data from: 2011-08-24 11:10
Unable to read /var/log/clamd.log

Fail2Ban Log (Server : xxxxxxxxxxxxxxxx)

Data from: 2011-08-24 11:10
Unable to read /var/log/fail2ban.log


Sorry if some one think that i m a noob user, but is my firts time with ispconfig, and i want to used for my company.

I installed isp on opensuse 11.4. But i dont know if other source of linux like red hat is better to work with ispconfig or ispconfig work fine with suse.

Tanks For help.
Edit/Delete Message

CSsab 25th August 2011 19:13

Postfix (and possibly a few other services) are not running:

For postfix:
/etc/init.d/postfix reload
/etc/init.d/postfix restart

Also check that your mysql database is running.

You can so this in System -> Server Services

You don't usually have to configure anything else if you have installed ISPConfig 3 following one of the recommended Howtos.

Hope this helps

r4faga 25th August 2011 19:43

Tanks men postfix is running but i reload and restart and mark done. Same to mysql is running. By that way, when i was installing isp and configurate programs to run on start server, i get this warning messege eje:
chkconfing --add postfix.
insserv: service network is missed in the runlevels 2 to use mysql
Postfix 0.off 1.off 2.off 3.on 4.off 5.on 6.off .=:
I have to set level 2 on insserv service??

CSsab 25th August 2011 20:12

Is the package chkconfig installed by default on opensuse?

Looks like a bug in the mysql init script have a look here:
http://lists.opensuse.org/opensuse-b.../msg00030.html

Try:
chkconfig -l | grep network

and changing the runlevel for mysql to something else like this:
chkconfig --level 20 mysql on

Or some other number.

r4faga 25th August 2011 21:18

ok tanks, i assign to 2 3 5 on, and default start on level 20 or other number. Ill see again logs.

r4faga 25th August 2011 23:43

Still freezed ispconfig 3, when i try to create a new user, it freezed. I dont have nothing more on my opensuse, and i installed step by step my isp 3 with falko manual. If i dont have to do something more after install isp, i dont know what is going on. It make green on status server like all programs re fine, but on logs still show errors...

Mail-Error - Log (Server : xxxxxxxxxx)

Refresh Sequence:
Data from: 2011-08-24 10:55
Aug 22 16:36:03 linux postfix/postfix-script[2924]: fatal: the Postfix mail system is not running
Aug 22 16:36:28 linux postfix/postfix-script[5142]: fatal: the Postfix mail system is not running

And postfix is running, i dont know what i have to do....

falko 26th August 2011 13:04

Is this a physical server or a virtual machine? If you use OpenVZ, what's the output of
Code:

cat /proc/user_beancounters
?

r4faga 26th August 2011 15:35

Is a physical server falko and /user_beancounters is no exist on this folder.

falko 27th August 2011 12:27

How much RAM does the system have?

r4faga 29th August 2011 21:42

have 4 g ram.

Falko i reinstall all system, and i do it again, step by step with your manual. All steps i do it well. Mark fine with out erros. What do you suggest me, install opensuse or other linux and try to install isp therer?

My server is a dell poweredge t110 2.

If i change the name server when i installed, (server1.example.com to company.example.com) this affect to something on my installation??


All times are GMT +2. The time now is 22:11.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.