HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Perfect server ubuntu 10.10 mail problem Ispconfig 3 (http://www.howtoforge.com/forums/showthread.php?t=53795)

afigar 16th August 2011 16:22

Perfect server ubuntu 10.10 mail problem Ispconfig 3
 
I've followed the instructions and installed perfect server on ubuntu 10.10 running on an amazon microinstance.

I get this error from squirrel login:

ERROR: Connection dropped by IMAP server. Query: CAPABILITY

amavis-new was not running. I wonder if postfix-mysql needs some extra configuration. I don't see any mail related database on phpmyadmin, should I ?

Thanks,

falko 17th August 2011 10:37

Quote:

Originally Posted by afigar (Post 261705)
I get this error from squirrel login:

ERROR: Connection dropped by IMAP server. Query: CAPABILITY

Are there any errors in your mail log?

Quote:

Originally Posted by afigar (Post 261705)
amavis-new was not running.

Did you restart it?

Quote:

Originally Posted by afigar (Post 261705)
I don't see any mail related database on phpmyadmin, should I ?

The tables are part of the ISPConfig database.

afigar 18th August 2011 14:30

I restarted amavis-new and I've got this on mail.err:

Aug 16 11:20:02 ip-10-195-xxx-xxx amavis[18961]: (18961-11) (!!)file(1) utility (/usr/bin/file) FAILED: run_command: can't fork: Cannot allocate memory at /usr/sbin/amavisd-new line 3077.

I'm running perfect server ubuntu 64b 10.10 on an amazon microinstance.

till 18th August 2011 14:55

Seems as if your amazon server has not enough RAM to start amavisd. You will either have to use a server with more RAM or you deactivate amavis (which will deactivate all spam and antivirus scanning) on that server.

http://www.faqforge.com/linux/contro...n-ispconfig-3/

afigar 23rd August 2011 14:41

I've done this but I still get this error when trying to login to squirrellmwebmail:

ERROR: Connection dropped by IMAP server. Query: CAPABILITY

Thanks,

till 23rd August 2011 14:45

Please post the exact errors from the mail.log file.

falko 24th August 2011 10:04

Take a look here: http://www.howtoforge.com/forums/showthread.php?t=36928

If that doesn't solve your problem, take a look here: http://www.linuxmail.info/squirrelma...5/#comment-200

afigar 24th August 2011 14:33

I think I solved the problem. Running Ubuntu Perfect Server 64b 10.10 on an amazon microinstance has some issues. There are memory issues and amavis won't run properly so I removed it. I don't know why but I had to manually edit mail_user table from ispconfig database to set disableimap to "n" when it was "y". Then everything started working fine and I was able to use ispconfig control panel again. Once I fixed this I was able to create new mail accounts that worked fine from creation. It might have been the amavis issue that caused some misconfiguration of mail accounts.

Thanks for your support,


All times are GMT +2. The time now is 06:01.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.