HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   "Monitor" Doesn't show anything (http://www.howtoforge.com/forums/showthread.php?t=53670)

xstnc 5th August 2011 13:04

"Monitor" Doesn't show anything
 
Hi,

I've just done a setup of two servers running ISPConfig 3 and Ubuntu 10.04.
The master server contains all roles for ISPConfig and the second server is just a DNS (and registrered such in the "system" tab).

But when I go to "Monitor" the second server doesn't have any information at all.

What do I have to do, to let the master server gather the information from the second server?

till 5th August 2011 14:46

Thats most likely a problem with mysql permissions. The slave server is not able to connect to the master, so he can not update the monitor.

Have you entered the hostname of the master mysql server while you setup the slave in the ispconfig installer as requested and not the IP of the master? If you entered the IP, then the connection will fail. Another possible problem is if you did not alter the /etc/hosts files on both servers as described in the multiserver guide, the connection will only work if both servers can resolve their hostnames in the same way.

xstnc 5th August 2011 15:45

The install of ISPConfig on the second server went OK.
And I made sure to use hostnames for every question it asked.

I had no problems setting it up, and getting things to whirl around.
(No MySQL connection problems).

I can still access the main server from mysql command on the second server.

I did not however edit the hosts file, and will have a read in the multi servers guide to see what it actually wants me to input.

But both servers can ping eachother via internet, so the name must resolve somewhere?

till 5th August 2011 16:01

You can test the mysql connectin like this: Open the file /usr/local/ispconfig/server/lib/config.inc.php. Inside the file, you will find login details to the local database and to the remote (master) database. Use the login details for the master database to execute this command on the shell of the slave to test the connection:

mysql -h masterhostname -u username -p ispconfigdatabasename

The command will query you the for the password.

xstnc 6th August 2011 13:13

The Mysql connection was tested OK from the beginning.
Added the host file records, as you said - and now it works!

Thanks for the great tip! :)

haluk yildirim 11th January 2012 13:47

Monitor tab is blank
 
Hi,

I did install several ISPConfig 3 on several fedora 14 servers. everything is running as normal except, after updates from 3.0.4.x, monitor tab does not display anything. When you click on the "show server state" items on the left menu, they work except show overview.

I have the same problem on several installations.
Tried with different browsers.
What am I doing wrong? and how can I fix it ?

Thank you

http://www.bosspacific.com.au/ISPCon...itor%20tab.jpg

till 11th January 2012 13:54

Please install ISPConfig 3.0.4.2 as this fixes the monitor bug from ISPConfig 3.0.4.

haluk yildirim 11th January 2012 14:22

Hi Till,
 
Hi Till,

This screen jpg is after 3.0.4.2.

thank you for your quick reply.

till 11th January 2012 14:37

Might be a problem with your php configuration, e.g. you might have disabled some functions. Check the apache error.log.

haluk yildirim 11th January 2012 14:41

apache error msg
 
Hi Till,

PHP Deprecated: Call-time pass-by-reference has been deprecated in /usr/local/ispconfig/interface/web/monitor/show_sys_state.php on line 199, referer: https://mail.bosspacific.com.au:8080/index.php


Any idea?


All times are GMT +2. The time now is 13:48.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.