HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   webmail url (http://www.howtoforge.com/forums/showthread.php?t=53662)

mentes 4th August 2011 20:27

webmail url [solved]
 
I have installed Roundcube, and it is working fine but I have some questions about the url to access them.

I can access from http://clientdomain.com:8080/webmail

Why I need to use port 8080? How can I access without typing port?

How I can do a subdomain for access from http://webmail.clientdomain.com/ to Roundcube? Can I do that it automatically for a new sites ?

I have checked /etc/roundcube/main.inc.php & /etc/roundcube/apache.conf but I haven't seen anything port related.

till 4th August 2011 20:28

Quote:

Why I need to use port 8080? How can I access without typing port?
Just remove :8080 from the URL.

Quote:

How I can do a subdomain for access from http://webmail.clientdomain.com/
Create a new website webmail.clientdomain.com and install roundcube into that website.

Quote:

Can I do that it automatically for a new sites ?
No.

mentes 4th August 2011 20:35

If I remove :8080 I get an ERROR 500 - Internal Server Error!

I don't want install roundcube for each domain. I think I can use http://webmail.clientdomain.com/ using CNAME, but I'm not sure how do that.

till 4th August 2011 20:43

Quote:

If I remove :8080 I get an ERROR 500 - Internal Server Error!
Check the error.log of the website for the error message.

Quote:

I think I can use http://webmail.clientdomain.com/ using CNAME, but I'm not sure how do that.
CNAME is a dns record, this is required because otherwise the subdomain does not exist, but that not enough to display the website. You will have to add a aliasdomain to that website for every additional domain too.

mentes 4th August 2011 21:02

[Thu Aug 04 19:48:08 2011] [error] [client 81.39.9.247] SoftException in Application.cpp:221: File "/usr/share/roundcube/index.php" is not in document root of Vhost "/var/www/domain.es/web"
[Thu Aug 04 19:48:08 2011] [error] [client 81.39.9.247] Premature end of script headers: index.php

And I have tried to create a subdomain for redirect to roundcube but doesn't work:

Host: webmail
Domain: clientdomain.com
Redirect Type: R, L
Redirect: Path: http://www.clientdomain.com/webmail/
Active: yes

till 4th August 2011 21:18

Quote:

[Thu Aug 04 19:48:08 2011] [error] [client 81.39.9.247] SoftException in Application.cpp:221: File "/usr/share/roundcube/index.php" is not in document root of Vhost "/var/www/domain.es/web"
[Thu Aug 04 19:48:08 2011] [error] [client 81.39.9.247] Premature end of script headers: index.php
Which php mode do you use for that website? And have you added the path /usr/share/roundcube/ to the allowed open_basedir paths of that website?

Quote:

And I have tried to create a subdomain for redirect to roundcube but doesn't work:

Host: webmail
Domain: clientdomain.com
Redirect Type: R, L
Redirect: Path: http://www.clientdomain.com/webmail/
Active: yes
Thats wont work as you acn not reach roundcube at the URL http://www.clientdomain.com/webmail. Please see my description above on how to configure roundcube for that.

mentes 4th August 2011 21:32

I'm trying with all php modes. Fast-CGI usually.

This is the new error when I have added the path to open_basedir

Code:

[Thu Aug 04 20:21:00 2011] [error] [client 81.39.9.247] PHP Warning:  Unknown: open_basedir restriction in effect. File(/usr/share/roundcube/index.php) is not within the allowed path(s): (/var/www/clients/client1/web1/web:/var/www/clients/client1/web1/tmp:/var/www/domain.es/web:/srv/www/domain.es/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin) in Unknown on line 0
[Thu Aug 04 20:21:00 2011] [error] [client 81.39.9.247] PHP Warning:  Unknown: failed to open stream: Operation not permitted in Unknown on line 0
[Thu Aug 04 20:21:00 2011] [error] [client 81.39.9.247] PHP Fatal error:  Unknown: Failed opening required '/var/lib/roundcube/index.php' (include_path='.:/usr/share/php:/usr/share/pear') in Unknown on line 0

And now without :8080 doesn't show nothing, with :8080 stil working

Do I need to add the path for each domain ?

pititis 4th August 2011 23:04

You need set aliasdomain. Check it in /etc/roundcube/apache.conf . Alias must point to your roundcube path. Make sure that don't exist already an aliasdomain called webmail ok? And check if exist a symbolic link pointing to /etc/roundcube/apache.conf in /etc/apache2/conf.d (typical location for includes files in ubuntu/debian)

Suerte

mentes 6th August 2011 14:26

If I don't create any "site" I can access through www.domain.com/webmail but when I create a "site" I can access only through www.domain.com:8080/webmail

In www.domain.com/webmail I get Error 500 - Internal Server Error and in /var/www/domain.com/log/error.log I get this:

Code:

[Sat Aug 06 12:37:37 2011] [error] [client 81.202.46.31] SoftException in Application.cpp:221: File "/usr/share/roundcube/index.php" is not in document root of Vhost "/var/www/domain.com/web"
[Sat Aug 06 12:37:37 2011] [error] [client 81.202.46.31] Premature end of script headers: index.php
[Sat Aug 06 12:37:37 2011] [error] [client 81.202.46.31] File does not exist: /var/www/domain.com/web/favicon.ico, referer: http://domain.com/webmail/

I get the same result and error, with ssl enabled or disabled (if I disable ssl I comment mod_rewrite rules on /etc/roundcube/apache.conf)

I get that error with PHP: Disabled, Fast-CGI and SuPHP

And with CGI, Mod-PHP I get:

Code:

[Sat Aug 06 13:08:18 2011] [error] [client 81.202.46.31] PHP Warning:  include(): open_basedir restriction in effect. File(/usr/share/php/PEAR.php) is not within the allowed path(s): (/var/www/clients/client4/web3/web:/var/www/clients/client4/web3/tmp:/var/www/domain.es/web:/srv/www/domain.es/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/roundcube/) in /usr/share/roundcube/program/include/iniset.php on line 99
[Sat Aug 06 13:08:18 2011] [error] [client 81.202.46.31] PHP Warning:  include(/usr/share/php/PEAR.php): failed to open stream: Operation not permitted in /usr/share/roundcube/program/include/iniset.php on line 99
[Sat Aug 06 13:08:18 2011] [error] [client 81.202.46.31] PHP Warning:  include(): Failed opening 'PEAR.php' for inclusion (include_path='/var/lib/roundcube/:/var/lib/roundcube/program:/var/lib/roundcube/program/lib:/var/lib/roundcube/program/include:.:/usr/share/php:/usr/share/pear') in /usr/share/roundcube/program/include/iniset.php on line 99
[Sat Aug 06 13:08:18 2011] [error] [client 81.202.46.31] PHP Fatal error:  Class 'PEAR' not found in /usr/share/roundcube/program/include/iniset.php on line 122

I try adding /usr/share/roundcube/ to open_basedir too.

Note:
I can access to www.domain.com/phpmyadmin always, without typing port.
It's a fresh installation on Debian 6.0.2.1 following "The Perfect Server Howto" step by step carefully.

mentes 6th August 2011 20:04

Seems there are a problem between Roundcube & Debian/Ubuntu & SuPHP

http://www.crazysquirrel.com/computi...il-server.jspx

My solution:

root@main:~# a2dismod suphp
Module suphp disabled.

root@main:~# /etc/init.d/apache2 restart


All times are GMT +2. The time now is 07:36.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.