HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Server is not receiving external emails (http://www.howtoforge.com/forums/showthread.php?t=53580)

gawry 29th July 2011 19:02

Server is not receiving external emails
 
I have a different setup from the usual Perfect server. What i've done was a mix from the Installing a multple ISPConfig server on Debian Lenny Howto and Debian Squeeze Howto

1 Main Web server (where is ISPConfig panel)
1 Mail server - Postfix, courier, roundcube with lighttpd
1 Secondary Web server
1 MySQL Server - Running phpmyadmin with lighttpd

I can send emails to any email but I can only receive from internal email addresses. Why does is this happening

some emails returned couple days later.


Quote:

Delivery to the following recipient has been delayed:

email@domain.com

Message will be retried for 2 more day(s)

Technical details of temporary failure:
The recipient server did not accept our requests to connect. Learn more at http://mail.google.com/support/bin/a...py?answer=7720
[domain.com (1): Connection refused]


falko 30th July 2011 13:04

Any errors in your mail log? What's the output of
Code:

netstat -tap
?

Did you check if your MX record points to the correct server? You can check that with
Code:

dig mx yourdomain.com


All times are GMT +2. The time now is 08:32.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.