HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Having login issues with ISPconfig3 after several months of use. (http://www.howtoforge.com/forums/showthread.php?t=53558)

merovinq 27th July 2011 18:09

Having login issues with ISPconfig3 after several months of use.
 
I use ispconfig 3 on several servers for years and really love it. It gets better with every release.

I am having this issue on 1 server, not sure when it started, but I am no longer able to login.

It does not do the normal:
Error
Username or Password wrong.

as it does on my other servers when typing the wrong password.

I've upgraded it to the newest release using the upgrade script, but have the same results.

You can view the problem here: http://208.64.37.102:8080

Anyone know what I can do to fix this?

till 28th July 2011 11:28

Looks like a problem with the mysql database, e.g. a crashed database table. Please login to phpmyadmin and check all tables of the ispconfig database with the mysql check and repair functions.

merovinq 28th July 2011 15:50

It seems that I am also having issues logging into phpmyadmin as well... I don't use it much as I usually use Navicat Mysql to manage my databases.

phpMyAdmin is doing the exact same thing as ispconfig3. Does not login and no error message.

I repaired the dbispconfig table in Navicat Mysql as well as the mysql table, but am still having the same issue. very strange, going to lookup this problem for phpMyAdmin and see if that can help me solve both problems.

falko 29th July 2011 11:53

Is this a virtual machine or a physical server?

Maybe PHP needs more RAM than is available?

merovinq 29th July 2011 19:46

That is not it, the server is a physical box I built and colocated with many websites on it with a 6 core AMD phenom II with 8GB of ram.

I did not get much time to look into it yesterday except I saw that other have reported this problem with phpMyAdmin... I hope to have time this afternoon to look into it more.

falko 30th July 2011 12:07

Please let us know if you find out more. Did you check your logs?

merovinq 2nd August 2011 16:43

here are the apache logs from an attempted login...

xxx - - [02/Aug/2011:09:23:55 -0500] "POST /content.php HTTP/1.1" 200 446 "http://208.64.37.102:8080/" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0"
xxx - - [02/Aug/2011:09:23:55 -0500] "GET /nav.php?nav=side HTTP/1.1" 200 51 "http://208.64.37.102:8080/" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0"
xxx - - [02/Aug/2011:09:23:55 -0500] "GET /nav.php?nav=top HTTP/1.1" 200 113 "http://208.64.37.102:8080/" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0"

(Firebug also shows 200 replies.)


Here are the mysql queries that are performed...

110802 9:36:16 1248 Connect ispconfig@localhost on
1248 Query SET NAMES utf8
1248 Query SET character_set_results = 'utf8', character_set_client = 'utf8', character_set_connection = 'utf8', character_set_database = 'utf8', character_set_server = 'utf8'
1248 Init DB dbispconfig
1248 Query SELECT * FROM sys_session WHERE session_id = '6226d4d569dc0cd54b691b67b565906d'
1248 Init DB dbispconfig
1248 Query UPDATE sys_session SET last_updated = '2011-08-02 09:36:16' WHERE session_id = '6226d4d569dc0cd54b691b67b565906d'
1248 Init DB dbispconfig
1248 Query DELETE FROM sys_session WHERE last_updated < '2011-08-02 09:12:16'
1248 Quit
1249 Connect ispconfig@localhost on
1249 Query SET NAMES utf8
1249 Query SET character_set_results = 'utf8', character_set_client = 'utf8', character_set_connection = 'utf8', character_set_database = 'utf8', character_set_server = 'utf8'
1249 Init DB dbispconfig
1249 Query SELECT * FROM sys_session WHERE session_id = '6226d4d569dc0cd54b691b67b565906d'
1249 Init DB dbispconfig
1249 Query UPDATE sys_session SET last_updated = '2011-08-02 09:36:16' WHERE session_id = '6226d4d569dc0cd54b691b67b565906d'
1249 Init DB dbispconfig
1249 Query DELETE FROM sys_session WHERE last_updated < '2011-08-02 09:12:16'
1249 Quit
1250 Connect ispconfig@localhost on
1250 Query SET NAMES utf8
1250 Query SET character_set_results = 'utf8', character_set_client = 'utf8', character_set_connection = 'utf8', character_set_database = 'utf8', character_set_server = 'utf8'
1250 Init DB dbispconfig
1250 Query SELECT * FROM sys_session WHERE session_id = '6226d4d569dc0cd54b691b67b565906d'
1250 Init DB dbispconfig
1250 Query UPDATE sys_session SET last_updated = '2011-08-02 09:36:16' WHERE session_id = '6226d4d569dc0cd54b691b67b565906d'
1250 Init DB dbispconfig
1250 Query DELETE FROM sys_session WHERE last_updated < '2011-08-02 09:12:16'
1250 Quit

I'm still stuck as to what is causing this...

till 2nd August 2011 16:48

Have you been able to fix the issue with phpmyadmin? Have you tried a different browser? It might be that the login fails when the browser ahs some ad or scriptblock extensions installed or it does not accept the session cookies from phpmyadmin and ispconfig.

merovinq 2nd August 2011 17:11

Quote:

Originally Posted by till (Post 260782)
Have you been able to fix the issue with phpmyadmin? Have you tried a different browser? It might be that the login fails when the browser ahs some ad or scriptblock extensions installed or it does not accept the session cookies from phpmyadmin and ispconfig.

No it seems like the same issue with both ispconfig and phpmyadmin though...

Switching browsers does not fix the issue and logging onto an ispconfig installation on a different server works fine.

merovinq 29th September 2011 01:06

I've been so busy starting another business, I have not had time to mess with this cause every is configured how I need at the moment. However I need to get on ispconfig and change FTP settings in the next 24-48 hours and I don't even know where to start on fixing this problem.

If anyone has any suggestions I have not tried yet, it would be much appreciated.


All times are GMT +2. The time now is 05:39.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.