HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   SSL in domain (http://www.howtoforge.com/forums/showthread.php?t=53463)

qb7 19th July 2011 19:26

SSL in domain
 
I made one ssl certificate in a domain, and not run. When point https://www.mydomain.com in broser, the result is apache http server test Page powered. After this i did erase the certificate and don't run when point http://www.mydomain.com. The result is other domain park in the server. Why? Please hep my to this big problem for my.

ispconfig 3.0.3.2 CentOS. 5.5

Thank

qb7 19th July 2011 21:13

SSL problem wich domain
 
Is posible wich cron job solution for this issue:(

qb7 20th July 2011 14:33

No isn't cron job solution.
 
Quote:

Originally Posted by qb7 (Post 260071)
Is posible wich cron job solution for this issue:(

How I most go back the process to ssl domain in ispconfig, for normal fuction: http://www.mydomain.com?
Please help me the domain is in production.

falko 20th July 2011 18:37

Did you download the ISPConfig 3 Manual? If so, please check out chapter 5.4.

qb7 20th July 2011 21:26

I read 5.4 capitulo
 
Hi Falko I don't have the solution. This domain now when I going point the broser http://www.mydomain.com, the broser show me other web, the next alphabetical order. When I pointing the broser https://www.mydomain.com, the broser show me the page Apache 2 Test Page powered by CentOS.

The sistem is IspConfig 3.0.2 and run in Centos 5.5

Only change the mode SSL in domain and not work.

I see this post http://www.howtoforge.com/forums/showthread.php?t=41597 how to made this for one posible solution? post of Till.
:confused:

falko 21st July 2011 13:48

Can you post the vhost configurations for the mydomain.com http and https vhosts?

qb7 25th July 2011 13:13

I find the error and possible issue
 
I have to put in the web site of domain the wildcard (*) in ip field and them run ok: www.mydomain.com
If I put the ip 111.111.111.111 them not run. This ip is the same wich the server IP (the internet static IP wich i have of my internet provider).

If the SSL is active them https:// show me the page of server other time.

How I can put SSL in only one domain?


The issue wich I find is:

When I disable one web site in the server and after I point the broser in the domain disable, the broser show me the page of the next alphabetical order domain active.

This is from my point of view one issue (hole).

Sistem: Centos 5.5 IspConfig 3.0.3.2
Can I report this issue?

qb7 25th July 2011 15:49

When point https://www.mydomain.com
 
1 Attachment(s)
this is the cert to show in the broser:

Attachment 2231

falko 26th July 2011 17:53

What about my question in post #6?

qb7 28th July 2011 14:05

I have solved this problem
 
Hello to all, I have solved this problem in my system:

Centos 5.5

IspConfig 3.0.3.3 (I upgrade it)

In the ssl.conf (etc/httpd/conf.d/ssl.conf) I have applied this policy

<IfDefine 0>
##
## SSL Virtual Host Context
##

<VirtualHost _default_:443>
...
</VirtualHost>
</IfDefine>

This fixed the default vhost and run OK the cert of mydomain.

Thank Falko


All times are GMT +2. The time now is 08:52.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.