HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   mod_fcgid: stderr: PHP Warning: (http://www.howtoforge.com/forums/showthread.php?t=53320)

alexloko 5th July 2011 23:14

mod_fcgid: stderr: PHP Warning:
 
Hi there.
I saw that this problem have been posted yet in same thread but nothing not help me. So...
CentOS 5.6 ISPConfig 3.0.3.3 Apache2.2.3 PHP5.3.6 MySQL 5.5.13 Joomla 1.6.3
I recive next error -

[warn] mod_fcgid: stderr: PHP Warning: include() [<a href='function.include'>function.include</a>]:
open_basedir restriction in effect. File() is not within the allowed path(s): (/var/www/clients/client1/web1/web:/var/www/clients/client1/web1/tmp:/var/www/DOMAIN.TLD/web:/srv/www/DOMAIN.TLD/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin)
in /var/www/clients/client1/web1/web/libraries/joomla/application/component/view.php on line 606

When i select SuPHP for PHP- everything its OK. But any other selects (Fast-CGI, CGI, ModPHP) work with this error.

If i swith off "show error" in joomla admin panel - this error not appears, but written in error.log (in 4 days - 162 Mb)

Pleace, how can i fix it
Thanks and sorry for my English )

till 6th July 2011 12:49

Joomla tries to access a file which is not within the paths that are defined in the open_basedir field in the web settings. Add the path where the file that joomla wants to access in the open_basedir field, separated by ":".

alexloko 6th July 2011 14:28

ok...
My open_basedir was ->

/var/www/clients/client1/web1/web:
/var/www/clients/client1/web1/tmp:
/var/www/domain.tld/web:
/srv/www/domain.tld/web:
/usr/share/php5:
/tmp:
/usr/share/phpmyadmin:
/etc/phpmyadmin:
/var/lib/phpmyadmin
---
i modifed it to ->

/var/www/clients/client1/web1/web:
/var/www/clients/client1/web1/web/includes:
/var/www/clients/client1/web1/tmp:
/var/www/domain.tld/web:
/var/www/domain.tld/web/includes:
srv/www/domain.tld/web:
/srv/www/domain.tld/web/includes:
/usr/share/php5:
/tmp:
/usr/share/phpmyadmin:
/etc/phpmyadmin:
/var/lib/phpmyadmin
---
but... without succes. May by it`s need to add some other folders to open_basedir ?:confused:

dimas 6th July 2011 15:14

If the open_basedir field in the web settings is OK, then it's most likely the
eaccellerator bug (if you have it installed).

I had the same problem some time ago on a very similar setup.

I had to remove eaccellerator - and the problem went away.

On CentOS it should be

yum remove php-eaccelerator

I wish I knew the way to keep it, though, and avoid the bug -so if anyone has any ideas, I'd welcome it very much!

alexloko 6th July 2011 15:29

EDITED
-------------
Oh no ((( It`no work (((
After restart httpd - error appears again... Sorry for next
--------------
OK - Resolved! (EDITED - Not Resolved)
Just erase the folder /web in a string /var/www/domain.tld/web:
/srv/www/domain.tld/web: and al its ok!

But i`am afraid that this have potential security hole, becose that means that the scripts from ./web wil have access to ./domain.tld/ is`nt?
---
Ok, in any case, with this sting all work correctly. THANK YOU very much!

/var/www/clients/client1/web1/web:
/var/www/clients/client1/web1/tmp:
/var/www/domain.tld/web: (don`t type it -(erase /web ))
/srv/www/domain.tld/web: (don`t type it -(erase /web ))
/usr/share/php5:
/tmp:
/usr/share/phpmyadmin:
/etc/phpmyadmin:
/var/lib/phpmyadmin

alexloko 6th July 2011 16:01

Quote:

Originally Posted by dimas (Post 259405)
yum remove php-eaccelerator

Thank you! after remove php-eaccelerator the error is not appeare.
May appear some other problems after delete it?

dimas 6th July 2011 19:25

eAccelerator is a PHP accelerator & optimizer.

Its official web sites states that it increases the performance of PHP scripts by caching them in their compiled state.

They also say that eAccelerator should reduce server load and increase the speed of PHP code by 1-10 times.

Well, that's theory. In practice, frankly speaking, I couldn't tell the difference with or without it - on a few relatively busy php sites.

So - there will not be any problems apart from (potentially) slower operation of the php-driven sites.

Lionheart82 6th February 2012 14:42

+1 for eAccelerator removal, it does stop these errors.
Thank you!

till 6th February 2012 14:49

You can use xcache instead of eaccelerator. After you uninstalled eaccelaretor with:

yum remove php-eaccelerator

install xcache with:

yum install php-xcache

xcache is a php binary cache like eaccelerator but it does not cause these problems with joomla and phpmyadmin.

Lionheart82 6th February 2012 15:01

I guess you can install with
yum install php-xcache but i am on centos and needs to be build
(http://www.howtoforge.com/integratin....5-and-apache2)

anyway caching is not a problem right now... i was waching server logs for something else and stubled across this bug :S


All times are GMT +2. The time now is 04:54.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.