HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Relay access denied error -- ISPConfig v2.2.39 / CentOS 5.6 / postfix / dovecot (http://www.howtoforge.com/forums/showthread.php?t=53319)

Fairbanks 5th July 2011 19:48

Relay access denied error -- ISPConfig v2.2.39 / CentOS 5.6 / postfix / dovecot
 
4 Attachment(s)
Hi Gang,

(Forgive my English as my native language is French from Canada / Quebec, and I’m no Linux guru either).

I have an old version of ISPConfig running on an old box from which I plan to migrate all sites/domains (± 35) to a newer box. This setup as been running for ±4 years on OpenSUSE.

In preparation of all this, I’ve installed the new box using the installation instruction from ISPConfig.org (“CentOS 5.6 (x86_64): http://www.howtoforge.com/perfect-se...64-ispconfig-2). This box is running with domain “khameleo.ca” on a public IP (69.70.100.146) which forward to the ISPConfig console (under port 81) for which an SSL certificate was bought with GoDaddy.

Having the 2 environments operating side-by-side, I’m writing a “cookbook” for my resellers that will give them instructions to move their sites from one box to the other. The idea is to create a site on the new box along with its web code, mySQL database, users, etc (with re-config of few elements) and then switch the “name servers” at the registrar over the weekend to get the domain serviced by the new box.

I’ve tested the approach with one domain (“club-ventes.com”, 2 users) and everything looks perfect with the exception of mail e.g. the web site is fine (www.club-ventes.com), FTP ok, myPHPAdmin for the db user, … but here’s the issue with mail… (for admin@club-ventes.com for example).

From Outlook, this user can send mail to anyone using “mail.khameleo.ca” as in-out POP3/SMTP servers using “outgoing server (SMTP) authentication”. The same user can send mail using Roundcube webmail which has been installed.

When trying to send mail to this user, I get the error below:
Original-recipient: rfc822;admin@club-ventes.com
Final-recipient: rfc822;admin@club-ventes.com
Action: failed
Status: 5.7.1 (Remote SMTP server has rejected address)
Remote-MTA: dns;mail.club-ventes.com
(TCP|10.23.32.19|45392|69.70.100.146|25)
(NS1.KHAMELEO.CA ESMTP Postfix)
Diagnostic-code: smtp;554 5.7.1
<admin@club-ventes.com>: Relay access denied

If I remove the “mydestination” param in main.cf, the email just get lost “on the net” (I never get any mail nor any error message).

At this point, I tried trillions of changes reading forums without any success and I now rely on the wisdom of one of you guys… Attaches are config files I think would help starting the exchange, but please ask if you need something else (be clear with commands if required since I’m no expert like à said).

I thank you in advance.

G

Attached (all renamed *.txt)
- /etc/postfix/local-host-names
- /etc/postfix/main.cf (stripped to keep important info)
- /etc/postfix/master.cf
- /etc/postfix/virtusertable

till 7th July 2011 12:52

Please reconfigure the websites in ISPConfig and ensure that all domain names are typed lowercase. The mail delivery will fail if a domain is typed in uppercase lettters as the Linux filesystem is case sensitive.

Fairbanks 8th July 2011 18:22

4 Attachment(s)
Hi Till (Thanks for the reply).

I did reconfig ISPConfig, CentOS network and everything else where I suspected some Upcase, but I end up with the same result e.g. web52_sale can send message (either from Outlook or WebMail) but I get the same error message when I send eMail to 4sale@club-ventes.com (showing lowercase thought) - see below (some french in the message but I'm sure you will figure the message). Attached are newer versions of my files...

Adresse du destinataire : 4sale@club-ventes.com
Raison : Remote SMTP server has rejected address
Code de diagnostic : smtp;554 5.7.1 <4sale@club-ventes.com>: Relay access denied
Système distant : dns;mail.khameleo.ca (TCP|10.23.32.77|52990|69.70.100.146|25) (ns1.khameleo.ca ESMTP Postfix)

Guy

P.S. I really appreciate your help...

falko 9th July 2011 11:31

The mydestination line in your main.cf is the problem. Please run

Code:

postconf -e 'mydestination = /etc/postfix/local-host-names'
/etc/init.d/postfix restart


Fairbanks 10th July 2011 20:24

Bingo Falko - BIG THANKS...


All times are GMT +2. The time now is 12:06.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.