HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Ports blocked despite firewall off in groupware setup (http://www.howtoforge.com/forums/showthread.php?t=53278)

avamk 1st July 2011 03:51

Ports blocked despite firewall off in groupware setup
 
I am trying to setup a groupware server running on Scientific Linux 6 ("SL 6", which is literally RHEL 6 sans brand) for personal use.
So far I've setup test virtual machines, both running fully updated Sscientific Linux 6, with the Citadel and Kolab groupware servers. For both, I've ran into similar issues with certain functions not working because of connections refused:

Kolab
I've successfully installed Kolab 2.3.2 in SL 6, and have
been able to access the admin page, create a user, and login to the built in Horde web interface (all from both within and outside of my local network).
However, when I try to send a test email from the web interface, I get the following error:
Quote:

There was an error sending your message: Failed to connect to localhost:587 [SMTP: Failed to connect socket: Connection refused (code: -1, response: )]
I have the postfix master.cf template file used by Kolab posted here.
What is wrong with my setup? And why is Kolab trying to use port 587 instead of 25 or 465 for SMTPS?

Citadel
I also setup Citadel groupware server in another SL 6 virtual machine, it all works including web access, Thunderbird client sync, etc.
However, for the Citadel server to sync with my iPhone, I need to, and have have downloaded and successfully started the latest Groupware Sync Server from here. The Groupware Sync Server is basically an installation of Funambol, specially made to work with Citadel.
I tried to connect to the server from my iPhone with the Funambol connector app, and the Synthesis SyncML app, but none of them worked when I pointed them to: :8080/funambol/ds]http://[hostname]:8080/funambol/ds (which is what the Groupware Sync Server documentation told me). Of course, I replaced [hostname] with my actual hostname.
I checked the logs of both sync apps, and they both say the following:
Quote:

[ERROR] processItemStatus: server sent status 506 in SYNC
[ERROR] Error #506 in source addressbook
On the Citadel and Groupware Sync Server forums, I was told that error 506 meant its something on the server going on, so I got the two relevant log files, /opt/Funambol/logs/ds-server/ds-server.log, and /opt/tools/tomcat/logs/catalina.out (the links point to pastebins of the output). The logs point to this:
Quote:

...Connection to http://[hostname]:2000 refused...
The problem is, I completely disabled the firewall in both cases from the Firewall GUI program in the server's Administration menu, and I don't know why they both seem to have permission problems, or ports being blocked.

The respective mailing lists and forums for the software did not help, but they have suggested it might be other security polices on my system that's blocking them.

That's why I am asking here: Is there more to turning off the firewall than what I did? Any ideas would be appreciated. Thanks!


All times are GMT +2. The time now is 17:19.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.