HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   [ask] BIND Problems - setting up DNS server in centos 5.5 (http://www.howtoforge.com/forums/showthread.php?t=53268)

h4rm0n14 30th June 2011 08:42

[ask] BIND Problems - setting up DNS server in centos 5.5
 
Hi, there..

i'm a completely noob in linux.. but, i'm willing to learn the arts...

i want to install nginx+mysql+php-fm on a centos 5.5 linux...

i'm using this script from here:
http://freevps.us/thread-528.html

now, i want to use my domain (strideridecoupons1.com) as my DNS name => ns1.strideridecoupons1.com and ns2.strideridecoupons1.com

i have redirected the DNS to point ns1.strideridecoupons1.com (216.189.1.169) and ns2.strideridecoupons1.com (216.189.1.169)

***

i want to setup the DNS server using BIND in my vps. so i use this tutorial here:
http://www.seo-webz.com/tutorials/li...nd-fedora.html

but, when i restarted the named service (# service named restart), it always show 'failed'

here's the details:
Quote:

Stopping named: [ OK ]
Starting named:
Error in named configuration:
zone localdomain/IN: loaded serial 42
zone localhost/IN: loaded serial 42
zone 0.0.127.in-addr.arpa/IN: loaded serial 1997022700
zone 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0. 0.0.0.0.0.0.ip6.arpa/IN: loaded serial 1997022700
zone 255.in-addr.arpa/IN: loaded serial 42
zone 0.in-addr.arpa/IN: loaded serial 42
my.internal.zone.db:1: no TTL specified; using SOA MINTTL instead
zone my.internal.zone/IN: loaded serial 1
zone my.ddns.internal.zone/IN: loading master file slaves/my.ddns.internal.zone.db: file not found
internal/my.ddns.internal.zone/IN: file not found
my.external.zone.db:1: no TTL specified; using SOA MINTTL instead
zone my.external.zone/IN: loaded serial 1
[FAILED]
here's my named.conf.local:

Quote:

//
// Sample named.conf BIND DNS server 'named' configuration file
// for the Red Hat BIND distribution.
//
// See the BIND Administrator's Reference Manual (ARM) for details, in:
// file:///usr/share/doc/bind-*/arm/Bv9ARM.html
// Also see the BIND Configuration GUI : /usr/bin/system-config-bind and
// its manual.
//
options
{
// Those options should be used carefully because they disable port
// randomization
// query-source port 53;
// query-source-v6 port 53;
listen-on-v6 { none; };
listen-on { 216.189.1.169; };
// Put files that named is allowed to write in the data/ directory:
directory "/var/named"; // the default
dump-file "data/cache_dump.db";
statistics-file "data/named_stats.txt";
memstatistics-file "data/named_mem_stats.txt";
dnssec-enable yes;
recursion no;
allow-notify { 216.189.1.169; };
version "cilandak dns server";
auth-nxdomain no;
};
logging
{
/* If you want to enable debugging, eg. using the 'rndc trace' command,
* named will try to write the 'named.run' file in the $directory (/var/named).
* By default, SELinux policy does not allow named to modify the /var/named directory,
* so put the default debug log file in data/ :
*/
channel default_debug {
file "data/named.run";
severity dynamic;
};
};
//
// All BIND 9 zones are in a "view", which allow different zones to be served
// to different types of client addresses, and for options to be set for groups
// of zones.
//
// By default, if named.conf contains no "view" clauses, all zones are in the
// "default" view, which matches all clients.
//
// If named.conf contains any "view" clause, then all zones MUST be in a view;
// so it is recommended to start off using views to avoid having to restructure
// your configuration files in the future.
//
view "localhost_resolver"
{
/* This view sets up named to be a localhost resolver ( caching only nameserver ).
* If all you want is a caching-only nameserver, then you need only define this view:
*/
match-clients { localhost; };
match-destinations { localhost; };
recursion yes;
# all views must contain the root hints zone:
include "/etc/named.root.hints";

/* these are zones that contain definitions for all the localhost
* names and addresses, as recommended in RFC1912 - these names should
* ONLY be served to localhost clients:
*/
include "/etc/named.rfc1912.zones";
};
view "internal"
{
/* This view will contain zones you want to serve only to "internal" clients
that connect via your directly attached LAN interfaces - "localnets" .
*/
match-clients { localnets; };
match-destinations { localnets; };
recursion yes;
match-destinations { localnets; };
recursion yes;
// all views must contain the root hints zone:
include "/etc/named.root.hints";

// include "named.rfc1912.zones";
// you should not serve your rfc1912 names to non-localhost clients.

// These are your "authoritative" internal zones, and would probably
// also be included in the "localhost_resolver" view above :

zone "my.internal.zone" {
type master;
file "my.internal.zone.db";
};
zone "my.slave.internal.zone" {
type slave;
file "slaves/my.slave.internal.zone.db";
masters { /* put master nameserver IPs here */ 127.0.0.1; } ;
// put slave zones in the slaves/ directory so named can update them
};
zone "my.ddns.internal.zone" {
type master;
allow-update { key ddns_key; };
file "slaves/my.ddns.internal.zone.db";
// put dynamically updateable zones in the slaves/ directory so named can update them
};
};
key ddns_key
{
algorithm hmac-md5;
secret "use /usr/sbin/dns-keygen to generate TSIG keys";
};
view "external"
{
/* This view will contain zones you want to serve only to "external" clients
* that have addresses that are not on your directly attached LAN interface subnets:
*/
match-clients { any; };
match-destinations { any; };
match-clients { any; };
match-destinations { any; };

recursion no;
// you'd probably want to deny recursion to external clients, so you don't
// end up providing free DNS service to all takers

allow-query-cache { none; };
// Disable lookups for any cached data and root hints

// all views must contain the root hints zone:
include "/etc/named.root.hints";

// These are your "authoritative" external zones, and would probably
// contain entries for just your web and mail servers:

zone "strideridecoupons1.com" {
type master;
file "/var/named/strideridecoupons1.com";
allow-transfer { key TRANSFER; };
};
and this is my zone file:

Quote:

$TTL 86400
@ IN SOA ns1.strideridecoupons1.com (
2906201201 ; serial (d. adams)
3H ; refresh
15M ; retry
1W ; expiry
1D ) ; minimum
@ 3600 IN NS ns1.strideridecoupons1.com
@ 3600 IN NS ns2.strideridecoupons1.com
@ 3600 IN TXT "v=spfl mx~all"
@ 3600 IN A 216.189.1.169
www 3600 IN A 216.189.1.169
www.strideridecoupons1.com 3600 IN CNAME strideridecoupons1.com

i am using host.strideridecoupons1.com as my hostname...

where have i been mistaken?
where and how to fix the mistake?

thank you!!!

falko 1st July 2011 15:11

Code:

slaves/my.ddns.internal.zone.db: file not found
internal/my.ddns.internal.zone/IN: file not found

Do the missing files/directories exist in /var/named/?

Code:

$TTL 86400
@ IN SOA ns1.strideridecoupons1.com (
2906201201 ; serial (d. adams)
3H ; refresh
15M ; retry
1W ; expiry
1D ) ; minimum
@ 3600 IN NS ns1.strideridecoupons1.com
@ 3600 IN NS ns2.strideridecoupons1.com
@ 3600 IN TXT "v=spfl mx~all"
@ 3600 IN A 216.189.1.169
www 3600 IN A 216.189.1.169
www.strideridecoupons1.com 3600 IN CNAME strideridecoupons1.com

You must use some dots in your zone file, like this:

Code:

$TTL 86400
@ IN SOA ns1.strideridecoupons1.com. (
2906201201 ; serial (d. adams)
3H ; refresh
15M ; retry
1W ; expiry
1D ) ; minimum
@ 3600 IN NS ns1.strideridecoupons1.com.
@ 3600 IN NS ns2.strideridecoupons1.com.
@ 3600 IN TXT "v=spfl mx~all"
@ 3600 IN A 216.189.1.169
www 3600 IN A 216.189.1.169
www.strideridecoupons1.com. 3600 IN CNAME strideridecoupons1.com.

(see http://www.howtoforge.com/traditional_dns_howto_p4 )

Also, you can remove one of the last two records because it does not make sense to have an A and a CNAME record for www.

h4rm0n14 1st July 2011 15:47

Thank You Falko!

i've added the dot sign n also removed the last two A and CNAME line in my zone file...

for these two files, i'll look around...
Quote:

slaves/my.ddns.internal.zone.db: file not found
internal/my.ddns.internal.zone/IN: file not found
i'll try to troubleshoot again, and let you know the result...

Thanks for the guidance Falko!

falko 2nd July 2011 16:24

Quote:

Originally Posted by h4rm0n14 (Post 259217)
also removed the last two A and CNAME line in my zone file...

Don't remove both - just one.


All times are GMT +2. The time now is 18:33.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.