HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   from Dovecot to Courier on ispconfig3 (http://www.howtoforge.com/forums/showthread.php?t=53026)

juancr12 10th June 2011 22:51

from Dovecot to Courier on ispconfig3
 
Some weeks ago I installed a new ispconfig3 server with posfix/dovecot, the problem was with the mail traffic, it was on "0" for all accounts, I readed on the furum that is not posible to generate the mail traffic with dovecot server, For this reason I removed dovecot and I installed Courier on my server and I did the following:

1) I downloaded ispconfig and ran the ispconfig update.php script. I Choosed yes when the updater asked me to reconfigure services.

2) The maildir structure of dovecot and courier are not compatible, I moved all files which are in the "Maildir" subfolder to the root folder of the maildir accounts. E.g.:

mv /var/vmail/domain.tld/user/Maildir/* /var/vmail/domain.tld/user/

3) I Edited the postfix main.cf and comment out the line that contains the authentication "private/auth" and I replace the "smtpd_sasl_type" from "dovecot" to "cyrus":

smtpd_sasl_type = cyrus
#smtpd_sasl_path = private/auth

Then I restarted postfix.


Evereting works, Accounts send and receive emails, not big problem and now the system is generating the mail traffic.

BUT the problem start when I created a new account, the sistem create the root folder for the account normaly but the folders .Send .Draft .Trash are being generate inside of Maildir folder and the Courier do not detects this folder inside of Maildir, I have to move it to the root directory manually

How can I solve this issue?

juancr12 12th June 2011 02:54

I found what is the problem
 
On the ispconfig panel, I went to system > server config > server > mail and change the POP3/IMAP Daemon from Dovecot to Courier and the Mailfilter Syntax to Maildrop, I ran the update scrip again and everything works fine again.

Now the problem is when you use outlook or some email client the folders are on the Inbox folder and not on the root of the account , If someone know fix that, please let me know How to fix it

thanks


All times are GMT +2. The time now is 20:10.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.