HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Custom php.ini and suPHP (http://www.howtoforge.com/forums/showthread.php?t=52797)

pititis 23rd May 2011 01:00

Custom php.ini and suPHP
 
Hello,

I can set customs values in a custom php.ini file using CGI + suPHP but in the manual (chapter 4.5.1.1) we found something diferent.

I own the v1.1 of the manual. Manual or ispconfig issue??

Cheers

till 23rd May 2011 12:04

You can use custom php.ini settings for php-cgi, php-fcgi and suphp. Only mod_php does not support this. Thats also described in the manul like this:

Quote from the manual:

Quote:

Please note that you can use this field only with Fast-CGI, CGI, or SuPHP - you cannot use it if you have enabled Mod-PHP for this web site.

pititis 23rd May 2011 16:11

But I don't use the settings field in options, thats I mean till.

till 23rd May 2011 16:23

Then you should use it, as thats the way to set custom php.ini settings on a ISPConfig server. ISPConfig creates the custom php.ini file automatically.

pititis 23rd May 2011 16:35

ok but what about clients? They can override defaults setting in this way without the admin control

Cheers

till 23rd May 2011 16:52

Quote:

ok but what about clients? They can override defaults setting in this way without the admin control
No. The simple reason is that if it would be allowed to your clients to create a custom php.ini, then they would be able to disavble php security functions.

pititis 23rd May 2011 16:59

Sure Till, for this reason I have posted this issue, as normal web user I have created a php.ini and changed the "post_max_size" setting!

till 23rd May 2011 17:05

And where have you created that file? Maybe you have a php extension installed or enabled that loads these files automatically, as far as I know, there is such a function available since php 5.3.

pititis 23rd May 2011 17:07

Here

/var/www/clients/client3/web12/etc/php.ini

a php extension... :cool: I will investigate...

efrog 8th March 2013 19:34

Interesting... I could not find this path...

Not sure that I'm posting this is the right place... I modified my post_max_size in ISPconfig but it doesn't seem to take effect?

Server reboots n all :)

Is there something that could over-ride a user's ISP's php.ini additions?


All times are GMT +2. The time now is 05:33.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.