HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Can't login (w/ remote MySQL) (http://www.howtoforge.com/forums/showthread.php?t=52686)

menganito 16th May 2011 11:40

Can't login (w/ remote MySQL)
 
I've installed ISPConfig3 according to http://www.howtoforge.com/perfect-se...64-ispconfig-3, but using two servers: one for web+mail and the other one just contains MySQL.

After installation, I try to log in but I can't it: "Username or Password wrong".
I can connect remotely to MySQL server:

Code:

# mysql -u dbispconfig -p -h 10.0.24.102
Enter password:
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 93
Server version: 5.1.56 Source distribution

Copyright (c) 2000, 2010, Oracle and/or its affiliates. All rights reserved.
This software comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to modify and redistribute it under the GPL v2 license

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> show databases;
+--------------------+
| Database          |
+--------------------+
| information_schema |
| dbispconfig        |
| mysql              |
+--------------------+
3 rows in set (0.00 sec)

I didn't change any config.inc.php settings:

Code:

# grep db_ /usr/local/ispconfig/server/lib/config.inc.php
$conf['db_type'] = 'mysql';
$conf['db_host'] = '10.0.24.102';
$conf['db_database'] = 'dbispconfig';
$conf['db_user'] = 'dbispconfig';
$conf['db_password'] = 'a65f36082652d86d2032320e04464c73';
$conf['db_charset'] = 'utf8'; // same charset as html-charset - (HTML --> MYSQL: "utf-8" --> "utf8", "iso-8859-1" --> "latin1")
define('DB_TYPE',$conf['db_type']);
define('DB_HOST',$conf['db_host']);
define('DB_DATABASE',$conf['db_database']);
define('DB_USER',$conf['db_user']);
define('DB_PASSWORD',$conf['db_password']);
define('DB_CHARSET',$conf['db_charset']);

My mysql_clientdb.conf:

Code:

<?php

$clientdb_host                  = '10.0.24.102';
$clientdb_user                  = 'dbispconfig';
$clientdb_password              = '*****';

?>

Any idea to solve it will be appreciated.

Thanks

till 16th May 2011 13:50

You enterd wrong mysql details while you installed ispconfig. The mysql server of a ispconfig 3 install is defined by its hostname (and not IP address) and the hostname of the local mysql server should be localhost. Thats a system requirement for ispconfig, please see multiserver guides. ISPConfig needs the local mysql database for its own settings and to replicate data.

To fix this, uninstall ISPConfig by using the uninstall.php script which can be found in the install folder and then reinstall ispconfig. When the installer asks you for the hostname of the mysql server, enter "localhost" as the installer suggests.

menganito 16th May 2011 16:39

Ok,

I'll install ISPConfig as usual way and then a separated MySQL server, managed via PHPMyadmin.

Thanks.

till 16th May 2011 16:43

Quote:

I'll install ISPConfig as usual way and then a separated MySQL server, managed via PHPMyadmin.
I wont recommend that as it does not make much sense to set it up that way. ISPConfig can manage your external mysql server, you just installed ispconfig the wrong way. Please see multiserver setup guide, the guide explains how to install ispconfig with a dedicated mysl server.

http://www.howtoforge.com/installing...th-ispconfig-3


All times are GMT +2. The time now is 20:52.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.