HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Setting a Default Website when no Virtual Host for Domain (http://www.howtoforge.com/forums/showthread.php?t=52473)

roadster 28th April 2011 00:36

Setting a Default Website when no Virtual Host for Domain
 
I need to reset the default site that is displayed when there is no site configured for a domain (i.e. no entry in the virtual hosts file) but the DNS settings (set on external nameserver) point to any of the ip addresses used on my server. Basically it's when a site is disabled for some reason and I'd like a suitable generic 'holding' page to display.

I don't see anything obvious in httpd.conf.

Thanks in anticipation.

Note to Mod: Sorry, this was first inadvertently posted in the Linux Forum - you may wish to remove from there - my apologies

till 2nd May 2011 10:20

Which ISPConfig version do you use?

roadster 2nd May 2011 10:25

ISPConfig 2, Till

till 2nd May 2011 11:48

ISPConfig 2 has a default vhost, ist the "Shared IP" page which is shown in case that no corresponding website exists. You can find it in /var/www/sharedip/

roadster 4th May 2011 10:52

Thanks, Till

Unfortunately this does not work for some reason on my setup. Any domain which is pointed in DNS to my server, resolves to one of the existing websites on the server when that new domain is not setup on the server as a vhost. ???

Thanks.

Roadster


All times are GMT +2. The time now is 05:49.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.