HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   dovecot (updated) problem (http://www.howtoforge.com/forums/showthread.php?t=52337)

marcozeus 17th April 2011 11:07

dovecot (updated) problem
 
Hi,
I have a problem with email:

Apr 17 10:40:55 kaweb dovecot: pop3-login: Disconnected (auth failed, 1 attempts): user=, method=PLAIN, rip=93.43.214.125, lip=192.168.1.120
Apr 17 10:41:04 kaweb dovecot: pop3-login: Disconnected (auth failed, 1 attempts): user=, method=PLAIN, rip=93.43.214.125, lip=192.168.1.120
Apr 17 10:42:08 kaweb clamd.amavisd[1437]: SelfCheck: Database status OK.
Apr 17 10:45:02 kaweb postfix/smtpd[14652]: connect from localhost[::1]
Apr 17 10:45:02 kaweb postfix/smtpd[14652]: warning: SASL: Connect to private/auth failed: No such file or directory
Apr 17 10:45:02 kaweb postfix/smtpd[14652]: fatal: no SASL authentication mechanisms
Apr 17 10:45:02 kaweb dovecot: imap-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
Apr 17 10:45:02 kaweb dovecot: pop3-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
Apr 17 10:45:03 kaweb postfix/master[13238]: warning: process /usr/libexec/postfix/smtpd pid 14652 exit status 1
Apr 17 10:45:03 kaweb postfix/master[13238]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Apr 17 10:48:30 kaweb dovecot: master: Warning: Killed with signal 15 (by pid=14904 uid=0 code=kill)
Apr 17 10:48:31 kaweb dovecot: master: Dovecot v2.0.11 starting up (core dumps disabled)
Apr 17 10:49:13 kaweb dovecot: pop3-login: Disconnected (auth failed, 1 attempts): user=, method=PLAIN, rip=93.43.214.125, lip=192.168.1.120
Apr 17 10:49:23 kaweb dovecot: pop3-login: Disconnected (auth failed, 1 attempts): user=, method=PLAIN, rip=93.43.214.125, lip=192.168.1.120
Apr 17 10:49:32 kaweb dovecot: pop3-login: Disconnected (auth failed, 1 attempts): user=, method=PLAIN, rip=93.43.214.125, lip=192.168.1.120
Apr 17 10:49:37 kaweb dovecot: pop3-login: Disconnected (auth failed, 1 attempts): user=, method=PLAIN, rip=93.43.214.125, lip=192.168.1.120
Apr 17 10:49:43 kaweb dovecot: pop3-login: Disconnected (auth failed, 1 attempts): user=, method=PLAIN, rip=93.43.214.125, lip=192.168.1.120
Apr 17 10:50:01 kaweb dovecot: pop3-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
Apr 17 10:50:01 kaweb dovecot: imap-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
Apr 17 10:50:01 kaweb postfix/smtpd[15079]: connect from localhost[::1]
Apr 17 10:50:01 kaweb postfix/smtpd[15079]: warning: SASL: Connect to private/auth failed: No such file or directory
Apr 17 10:50:01 kaweb postfix/smtpd[15079]: fatal: no SASL authentication mechanisms
Apr 17 10:50:02 kaweb postfix/master[13238]: warning: process /usr/libexec/postfix/smtpd pid 15079 exit status 1
Apr 17 10:50:02 kaweb postfix/master[13238]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Apr 17 10:52:08 kaweb clamd.amavisd[1437]: SelfCheck: Database status OK.
Apr 17 10:54:33 kaweb dovecot: master: Warning: Killed with signal 15 (by pid=15469 uid=0 code=kill)
Apr 17 10:54:35 kaweb dovecot: master: Dovecot v2.0.11 starting up (core dumps disabled)
Apr 17 10:55:01 kaweb dovecot: imap-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured


I think my fault was a "yum install upgrade" one week ago... :(
I know ISP config 3 isn't compatible with dovecot 2..
Is this the problem?
How can I solve the problem?
Thanks in advantage

ISPConfig 3.0.3.3, I used The perfect Server Fedora 14 ISPConfig 3 tutorial

falko 18th April 2011 08:50

Quote:

Originally Posted by marcozeus (Post 255457)
I know ISP config 3 isn't compatible with dovecot 2..
Is this the problem?

Yes. Please try to downgrade to Dovecot 1.2.

marcozeus 23rd April 2011 20:32

Hi Falko,
I downgraded dovecot to 1.2 but I cannot use the mail server yet.
This is the actual log from ispconfig:

Apr 23 19:58:10 kaweb clamd[1416]: SelfCheck: Database status OK.
Apr 23 20:00:02 kaweb dovecot: pop3-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
Apr 23 20:00:02 kaweb dovecot: imap-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
Apr 23 20:00:02 kaweb postfix/smtpd[23864]: connect from localhost[::1]
Apr 23 20:00:02 kaweb postfix/smtpd[23864]: warning: SASL: Connect to private/auth failed: No such file or directory
Apr 23 20:00:02 kaweb postfix/smtpd[23864]: fatal: no SASL authentication mechanisms
Apr 23 20:00:03 kaweb postfix/master[3258]: warning: process /usr/libexec/postfix/smtpd pid 23864 exit status 1
Apr 23 20:00:03 kaweb postfix/master[3258]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Apr 23 20:05:01 kaweb dovecot: pop3-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
Apr 23 20:05:01 kaweb dovecot: imap-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
Apr 23 20:05:01 kaweb postfix/smtpd[24271]: connect from localhost[::1]
Apr 23 20:05:01 kaweb postfix/smtpd[24271]: warning: SASL: Connect to private/auth failed: No such file or directory
Apr 23 20:05:01 kaweb postfix/smtpd[24271]: fatal: no SASL authentication mechanisms
Apr 23 20:05:02 kaweb postfix/master[3258]: warning: process /usr/libexec/postfix/smtpd pid 24271 exit status 1
Apr 23 20:05:02 kaweb postfix/master[3258]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Apr 23 20:08:10 kaweb clamd[1416]: SelfCheck: Database status OK.
Apr 23 20:10:01 kaweb dovecot: pop3-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
Apr 23 20:10:01 kaweb dovecot: imap-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
Apr 23 20:10:01 kaweb postfix/smtpd[24664]: connect from localhost[::1]
Apr 23 20:10:01 kaweb postfix/smtpd[24664]: warning: SASL: Connect to private/auth failed: No such file or directory
Apr 23 20:10:01 kaweb postfix/smtpd[24664]: fatal: no SASL authentication mechanisms
Apr 23 20:10:02 kaweb postfix/master[3258]: warning: process /usr/libexec/postfix/smtpd pid 24664 exit status 1
Apr 23 20:10:02 kaweb postfix/master[3258]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Apr 23 20:15:01 kaweb dovecot: pop3-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
Apr 23 20:15:01 kaweb dovecot: imap-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
Apr 23 20:15:01 kaweb postfix/smtpd[25042]: connect from localhost[::1]
Apr 23 20:15:01 kaweb postfix/smtpd[25042]: warning: SASL: Connect to private/auth failed: No such file or directory
Apr 23 20:15:01 kaweb postfix/smtpd[25042]: fatal: no SASL authentication mechanisms
Apr 23 20:15:02 kaweb postfix/master[3258]: warning: process /usr/libexec/postfix/smtpd pid 25042 exit status 1
Apr 23 20:15:02 kaweb postfix/master[3258]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Apr 23 20:18:10 kaweb clamd[1416]: SelfCheck: Database status OK.
Apr 23 20:18:33 kaweb dovecot: pop3-login: Disconnected (auth failed, 1 attempts): user=, method=PLAIN, rip=93.43.213.45, lip=192.168.1.120
Apr 23 20:18:38 kaweb dovecot: pop3-login: Disconnected (auth failed, 1 attempts): user=, method=PLAIN, rip=93.43.213.45, lip=192.168.1.120
Apr 23 20:20:01 kaweb dovecot: pop3-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
Apr 23 20:20:01 kaweb dovecot: imap-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured


To downgrade, I used the step #11 of your howto http://www.howtoforge.com/perfect-se...ispconfig-3-p4

What do you think? Could you help me please?
Thanks in advantage

marcozeus 28th April 2011 10:46

Hi,
any idea for this problem?
thank you very much

till 28th April 2011 10:55

Make sure that you rerun the ispconfig update and choose to reconfigure services after you downgraded dovecot.

dennysp 5th August 2011 08:00

Sorry for bringing this back from the dead, but I'm having the same problem. How do I force ispconfig_update to reconfigure services? Since I'm on the latest version, it says it's already updated.

till 5th August 2011 09:17

Download the ispconfig tar.gz from ispconfig.org website, unpack it and then run the update.php script which is in the install folder.

dennysp 5th August 2011 16:56

I did this, and now I can log in, but only after I reset the password on the mailboxes. Also, all the mailboxes I've tried so far are empty. Any idea why?

EDIT: I noticed on the mailbox folders I log in, there is a new Maildir folder with cur, new and tmp which are empty. The ones I haven't logged in (or change the password) do not have the Maildir folder, just cur, new and tmp. How do I change this so that the emails don't go into this new Maildir folder and the users can see their old emails?

falko 6th August 2011 11:37

Are there any errors in your mail log (in the /var/log/ directory)?


All times are GMT +2. The time now is 16:31.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.