HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Inbound email issue (http://www.howtoforge.com/forums/showthread.php?t=52273)

MrMoo 13th April 2011 17:49

Inbound email issue
 
Hi

I have followed the perfect server guide from http://www.howtoforge.com/perfect-server-centos-5.2-p3

i installed everything without a hitch, the only thing that im having issues with is inbounde email, when i email from my home email address to my domain it doesn't deliver, havent seen a bounce back either.

when i email from my CentOS VPS to my home email account it arrives in seconds, i have squirrelMail installed but its not seeing anything inbound.

also checked the mail spooler files and there is no sign of the email, i do have an mx of mail.myserver.net and it pings/traces.

any ideas ?

Thanks

falko 14th April 2011 17:20

Quote:

Originally Posted by MrMoo (Post 255193)
i installed everything without a hitch, the only thing that im having issues with is inbounde email, when i email from my home email address to my domain it doesn't deliver, havent seen a bounce back either.

What do you mean with home email address? Is the mail server hosted on a dynamic IP at your home? Then you should check if it is blacklisted as most dynamic IPs are blacklisted: http://www.mxtoolbox.com/blacklists.aspx

MrMoo 14th April 2011 20:58

the VPS is on a server hosted in a DC, my home email as in my private email.

when i emailed from my private email address to my hosted VPS email address it doesnt arrive but it does work the other way around.

i have full root access to the VPS

falko 15th April 2011 15:18

Did you check that the MX record points to the correct server? You can check that as follows:
Code:

dig mx yourdomain.com

MrMoo 15th April 2011 22:56

thanks for all the suggestions problem solved now, i took it back to the basics, recreated DNS records and used a tutorial from here.

working as it should


All times are GMT +2. The time now is 14:15.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.