HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Developers' Forum (http://www.howtoforge.com/forums/forumdisplay.php?f=33)
-   -   Debugging the install script (http://www.howtoforge.com/forums/showthread.php?t=52190)

otacon 7th April 2011 16:21

Debugging the install script
 
Hello I am installing ispconfig on a new linux distribution and would like to know if there is a way to debug the installer. What I mean is I want to see where is it getting stuck at and correct that issue.

I tried to create a log with php -q install.php > install.log but that made it so I couldn't see the text and did not log the commands.

I also checked the man for php and I do not see an option for this.

Maybe I need a different program? Suggestions would be appreciated.


------------------------

I just wanted to tell you if you didn't know that I am getting a bunch of warnings saying that the Function split () is now depreciated in the lib/install.lib.php. I am running php 5.3. This will still work, but it may need to be corrected when they drop the function in later php versions.

till 7th April 2011 16:42

If you want to debug the install script, you can add echo statements inside the scripot and they will get displayed then when you test the installer. There is no separate software needed to debug php shell scripts, just use echo and print_r() to print the variables and messages on the shell.

otacon 7th April 2011 17:09

Ah ok I was just wondering if there was an easier way, but I will echo all the variables and see if one is not correct.


All times are GMT +2. The time now is 12:51.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.