HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Migrating to new server (http://www.howtoforge.com/forums/showthread.php?t=52121)

excalibur 1st April 2011 09:42

Migrating to new server
 
Hey folks,

I'm just wondering.

I'm migrating my old server to the new server.

I've created a few websites en mailboxes on my new server.

eg. website1.com and website2.com

On domain is already pointing to my new server (website1.com)
I'm preparing website2.com to migrate. (domain is not pointing to the new server yet)
So what did i do.
I've created a mailbox equals to the old server.
info@website2.com.

I'm using mb2md tool to convert the mailboxes.
So i did

Code:

user@server:~> ./mb2md.pl -s /tmp/mailbox1 -R -d /var/vmail/website2.com/info/Maildir
After running this, i can find all my mails in the /var/vmail/website2.com/info/Maildir/cur folder.

okay, that worked, so i surfed to my server http://www.server.com/webmail
Logged in with info@website2.com, everything works, BUT i can't see all my imported e-mails. :mad:

So, i did another test.
I've imported all the mails to my website1.com

Code:

user@server:~> ./mb2md.pl -s /tmp/mailbox1 -R -d /var/vmail/website1.com/info/Maildir
once again is surf to my server webmail http://www.server.com/webmail

Logged in with info@website1.com

What did i found?
All my mails are imported.

so my question is
Is it possible that i can't see my mails when i'm logging in to my website2.com webmail when my domain isn't pointing to my new server yet?
Or is there another explanation?

falko 3rd April 2011 19:56

Quote:

Originally Posted by excalibur (Post 254430)
so my question is
Is it possible that i can't see my mails when i'm logging in to my website2.com webmail when my domain isn't pointing to my new server yet?

No, that's not the reason. Did you check your mail log? Did you configure any quotas for web site 2?

Maybe you should try this tutorial to migrate the mail box: http://www.howtoforge.com/how-to-mig...-with-imapsync

excalibur 4th April 2011 11:40

solved
 
I've just removed the user and created again, run the mb2md command again
and it works, strange, but it's solved. :)

Tnx for the reply.


All times are GMT +2. The time now is 12:26.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.