HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Squid proxy connection refused firefox (http://www.howtoforge.com/forums/showthread.php?t=52037)

teros 26th March 2011 05:46

Squid proxy connection refused firefox
 
All,

I've tried the suggestions on both google and on this forum i can't seem to get Squid to allow external connections...Apologies this is on a headless Mybook world.

my lan information
current ip addressing 192.168.0.x
Squid box ip 192.168.0.8
Router Ip 192.168.0.1

Have tried playing with http_access flags without any luck any assistance is more than appreciated. apologies has been many many years since i setup a proxy

if any one could help would be much apperciated.

Using the below.
http_port 192.168.0.8:3128
acl our_networks src 192.168.0.0/24 192.168.2.0/24
http_access allow our_networks

#Recommended minimum configuration:
acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl to_localhost dst 127.0.0.0/8
acl our_networks src 192.168.0.1-192.168.0.100

This is basically going to be a home squid cache....

falko 26th March 2011 16:05

What's the output of
Code:

netstat -tap
?

Do you try to connect on port 3128?

teros 27th March 2011 04:48

Hey mate,

Yep i verified what i think the issue is...


When looking and playing around i found that if i use default config cache of /opt/var/squid/cache Squid works accepting connections etc. but i am trying to change it to /shares/Public/WWW/Squid/cache i get connections refused.

I've started /opt/bin/squid -z to create the required swap directory's in /shares/Public/Squid/cache
Run chmod -R 770 /shares/Public - to set full read write across whole directory
chown nobody:nobody /shares/Public -have also tried setting the permissions as root as described in forum posts.



Is weird the error above i've checked the permissions on both see below

/opt/var/squid
drwxr-xr-x 18 nobody nobody 4096 Mar 26 18:58 cache

dirs inside cache
drwxr-x--- 258 nobody jewab 4096 Mar 26 18:24 00

/shares/Public/WWW/Squid/cache
drwxrwx--- 18 nobody jewab 4096 Mar 26 19:16 cache




In the cache.log i can still see the following

/shares/Public/WWW/Squid/cache/swap.state: (13) Permission
FATAL: storeUfsDirOpenSwapLog: Failed to open swap log.

falko 27th March 2011 20:38

Can you make sure that all directories in the path to /shares/Public/WWW/Squid/cache also have the correct permissions? It's enough if there is one directory in the path where nobody has no read permssions...


All times are GMT +2. The time now is 20:23.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.