HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Disable pop/imap mailbox don't work (http://www.howtoforge.com/forums/showthread.php?t=51964)

spokke 21st March 2011 12:13

Disable pop/imap mailbox don't work
 
Hi,

i've ispconfig 3 up and running on a ubuntu 10.04 with 100 domains (web/email/dns ecc..)

I've to disable imap/pop login for some mailbox and when i've checked the box "Disable imap" and "Disable pop3" in the mailbox properties but ther is no effect, the mailbox are still reachable via imap or pop3....where is the problem??? i've missed something?

Suggestions?? :D

Thanks

Spk

falko 22nd March 2011 15:10

Did you check in the ISPConfig database if POP3/IMAP are really disabled (table mail_user; fields disable_pop3, disable_imap if you use Dovecot/field access if you use Courier)?

spokke 24th March 2011 12:34

Yes, the options in the db are set to "Yes" but i can connect via imap or pop3 whidout problems....

navin 18th May 2011 17:57

Disable pop/imap mailbox don't work
 
Facing same problem. Setting are dbispconfig ->mail_user->disableimap=y, disablepop3=y, disabledeliver=y, disablesmtp=y

Still getting(pop3) and sending mails through clients(outlook)

Please help/ any suggestion.

Magalex 1st June 2011 14:42

Quote:

Originally Posted by spokke (Post 253699)
Hi,

i've ispconfig 3 up and running on a ubuntu 10.04 with 100 domains (web/email/dns ecc..)

I've to disable imap/pop login for some mailbox and when i've checked the box "Disable imap" and "Disable pop3" in the mailbox properties but ther is no effect, the mailbox are still reachable via imap or pop3....where is the problem??? i've missed something?

Suggestions?? :D

Thanks

Spk

I have the same problem. I added a new task on ISPConfig bugtracker. I propose to postpone the discussion there...
Sorry for bad English...

dar_ek 2nd August 2011 13:58

I've update courier in my Debian Lenny to Squeeze package today (for other reason - "big quotas, over 2 GB problem"),
and voila - disableimap, and diablepop3 start WORKING.

Courier version BEFORE update (WITHOUT working disableimap/pop option):

ii courier-authdaemon 0.61.0-1+lenny1
ii courier-authlib 0.61.0-1+lenny1
ii courier-authlib-mysql 0.61.0-1+lenny1
ii courier-authlib-userdb 0.61.0-1+lenny1
ii courier-base 0.60.0-2
ii courier-imap 4.4.0-2
ii courier-imap-ssl 4.4.0-2
ii courier-maildrop 0.60.0-2
ii courier-pop 0.60.0-2
ii courier-pop-ssl 0.60.0-2
ii courier-ssl 0.60.0-2

Courier version AFTER update (WITH WORKING disableimap/pop option):

ii courier-authdaemon 0.63.0-3
ii courier-authlib 0.63.0-3
ii courier-authlib-mysql 0.61.0-1+lenny1
ii courier-authlib-userdb 0.63.0-3
ii courier-base 0.65.0-3
ii courier-imap 4.8.0-3
ii courier-imap-ssl 4.4.0-2
ii courier-maildrop 0.65.0-3
ii courier-pop 0.65.0-3
ii courier-pop-ssl 0.60.0-2
ii courier-ssl 0.60.0-2

Maybe previous version courier haven't got MYSQL_AUXOPTIONS_FIELD in /etc/courier/authmysqlrc? (or this param is damaged).

ps. funny is that I DONT upgrage "courier-authlib-mysql" - coz it want to upgrade mysql to squizze version (and I dont want this).

bharathchari 1st September 2011 16:31

Mysql_auxoptions_field
 
Quote:

Originally Posted by dar_ek (Post 260759)
I've update courier in my Debian Lenny to Squeeze package
Courier version AFTER update (WITH WORKING disableimap/pop option):

ii courier-authdaemon 0.63.0-3
ii courier-authlib 0.63.0-3
ii courier-authlib-mysql 0.61.0-1+lenny1
ii courier-authlib-userdb 0.63.0-3
ii courier-base 0.65.0-3
ii courier-imap 4.8.0-3
ii courier-imap-ssl 4.4.0-2
ii courier-maildrop 0.65.0-3
ii courier-pop 0.65.0-3
ii courier-pop-ssl 0.60.0-2
ii courier-ssl 0.60.0-2

Maybe previous version courier haven't got MYSQL_AUXOPTIONS_FIELD in /etc/courier/authmysqlrc? (or this param is damaged).

ps. funny is that I DONT upgrage "courier-authlib-mysql" - coz it want to upgrade mysql to squizze version (and I dont want this).

I finally figured out what the issue is after hammering my head against a wall. The issue is partly with ISPConfig and courier-authdaemon.
ISPConfig uses an ENUM field with 'n' and 'y' as the possible values. Courier-authdaemon (at least the 0.60 version) does not evaluate that to 0 and 1.
I have changed authmysqlrc as follows:

MYSQL_AUXOPTIONS_FIELD concat('disableimap=',if(disableimap='n','0','1'), ',disablepop3=',if(disablepop3='n','0','1'))

After restarting courier-authdaemon, everything works as expected. Please use this ONLY IF enabling / disabling does not work for you using the normal method.

Bharath
Bharath

fredol 28th January 2012 15:59

The solution doesn't work for me.
I've edited /etc/courier/authmysqlrc as follows :

MYSQL_SERVER localhost
MYSQL_USERNAME xxx
MYSQL_PASSWORD xxx
MYSQL_PORT 0
MYSQL_DATABASE dbispconfig
MYSQL_USER_TABLE mail_user
MYSQL_CRYPT_PWFIELD password
#MYSQL_CLEAR_PWFIELD password
MYSQL_UID_FIELD uid
MYSQL_GID_FIELD gid
MYSQL_LOGIN_FIELD login
MYSQL_HOME_FIELD homedir
MYSQL_MAILDIR_FIELD maildir
#MYSQL_NAME_FIELD
MYSQL_QUOTA_FIELD quota
#MYSQL_QUOTA_FIELD concat(quota,'S')
#MYSQL_WHERE_CLAUSE access='y'
#MYSQL_AUXOPTIONS_FIELD concat('disableimap=',disableimap,',disablepop3=', disablepop3)
MYSQL_AUXOPTIONS_FIELD concat('disableimap=',if(disableimap='n','0','1'), ',disablepop3=',if(disablepop3='n','0','1'))

and restarted courier-authdaemon

But users with disable IMAP checked still can login through IMAP

Any help would be greatly appreciated.

Fredol

fredol 29th January 2012 16:15

After too many hours, I discovered that Bharath's solution is working only for non-SSL connections

When a user connects to mail server with IMAP-SSL, the disable IMAP function is not working and the user can connect.

One step forward but not a complete solution.

Fredol

gog 21st November 2012 01:52

I just stumbled onto this thread, and judging by the Couriers documentation at http://www.courier-mta.org/authlib/README_authlib.html there is another option you can pass to Courier: disableinsecureimap


All times are GMT +2. The time now is 18:43.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.