HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Waitings with pure-ftpd (http://www.howtoforge.com/forums/showthread.php?t=51875)

cyberfido 14th March 2011 10:57

[SOLVED] Waitings with pure-ftpd
 
Hi all,
I'm new Italian user of this community and a newbie user of Linux Ubuntu Server.
I'd need a help with a problem that is annoying me since a week.
I have pure-ftpd server installed on my server and sometime it doesn't answer until request goes on timeout. If you try to contact immediately the ftp server it answers correctly and let you work, but some minutes or seconds after it "freezes" again until timeout.
Before of this week, it has never given a problem.
I thought that I was the cause of this problem, because I've modified some parameters on the server, but non related to pure-ftp.
I made changes on nsswitch.conf for NIS and on ISPConfig, I've only changed root password.
I also saw on var/log/messages if there's anything wrong, but it doesn't reveal any anomalies.
I really don't have a good knowledge, so I'm stuck here.
The server is hosted away from my office and other branches connecting to its ftp service meet the same problem, so I think it's not a LAN or firewall problem.
Do you have any ideas about it? Let me know if you need any other information.

falko 15th March 2011 15:29

Did you try both active and passive transfers in your FTP client?

cyberfido 15th March 2011 16:05

no, only passive mode, because the main programs that use ftp service use passive mode.
I've never changed the mode since server first installation.

falko 16th March 2011 14:33

Can you try with active mode?

cyberfido 16th March 2011 14:51

Do I need to modify some setting on pure-ftpd to try with active mode ?

can you explain me briefly what it could mean if active mode works and on other hand if active mode doesn't work?

I'm grateful to you.

falko 17th March 2011 19:20

Quote:

Originally Posted by cyberfido (Post 253451)
Do I need to modify some setting on pure-ftpd to try with active mode ?

No, you must select active mode in your FTP client.

Quote:

Originally Posted by cyberfido (Post 253451)
can you explain me briefly what it could mean if active mode works and on other hand if active mode doesn't work?

Most likely it's a firewall problem then.

cyberfido 18th March 2011 14:05

falko, this morning maybe i've resolved the problem.
Ill'wait to "sing victory" as in italy we are usde to say.
The problem maybe it's due to the option of zywall usg200 called "Enable link sticking"
This option permits to mantain the same session active to a long time.
This option was disabled and so I think pcs change session every time after authentication so they don't receive data. I'll inform you during the day about the reactions of clients.

cyberfido 18th March 2011 18:52

ok. I've ascertained that wae a firewall problem.
problem solved.
thaks a lot!


All times are GMT +2. The time now is 10:07.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.