HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Easy RoundCube (Over SSL) And Webmin With fail2ban For ISPConfig 3 On Debian Squeeze (http://www.howtoforge.com/forums/showthread.php?t=51742)

JohnnyBeGood 4th March 2011 10:04

Easy RoundCube (Over SSL) And Webmin With fail2ban For ISPConfig 3 On Debian Squeeze
 
Hi,

I was happy to see there's how-to on roundcube for Debian Squeeze and ISPconfig 3 because I couldn't get to work with squirrelmail http://www.howtoforge.com/forums/showthread.php?t=50797

After following tutorial to a T I get this error
when trying to access https://www.tld.com/webmail

Code:

Secure Connection Failed

     
         

An error occurred during a connection to www.tld.com.

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)

   


    *  The page you are trying to view can not be shown because the authenticity of the received data could not be verified.

    *  Please contact the web site owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.

What am I missing?

Thanks in advance!

8omas 4th March 2011 11:31

You have to type

http://www.tld.com/webmail
or
https://www.tld.com:8080/webmail

the same is for phpmyadmin or whatever else you set up following the guide

The ssl is setup for port 8080

JohnnyBeGood 4th March 2011 16:06

Quote:

Originally Posted by 8omas (Post 252630)
You have to type

http://www.tld.com/webmail
or
https://www.tld.com:8080/webmail

the same is for phpmyadmin or whatever else you set up following the guide

The ssl is setup for port 8080

I get same error when trying to access either one.
Does ssl needs to be enabled somewhere?

8omas 4th March 2011 20:17

In the beginning of the HowTo I mention :
Quote:

If you want to access ISPConfig Panel and webmail through SSL I also assume that you followed the chapter 6.2 Enabling SSL For The ISPConfig Web Interface of The ISPConfig 3 manual (this is only needed if you want to access the control panel AND the webmail interface through ssl on port 8080).

If you followed the above, then I finally assume that you read the workaround in this post.
You HAVE to do those things to have SSL over port 8080. After that you can follow anyone of the 2 links in my previous post.

8omas 4th March 2011 20:29

If you don't have the manual, the following will help:
http://www.faqforge.com/linux/contro...-controlpanel/

This does NOT include instruction for enabling SuExec for ISPConfig, so you probably will not need the last referred link (http://www.howtoforge.com/forums/showthread.php?t=51236). As I understand it only resolves the removing of symlink to /var/www/ispconfig, which you (probably didn't remove)

JohnnyBeGood 5th March 2011 12:57

Quote:

Originally Posted by 8omas (Post 252688)
In the beginning of the HowTo I mention :


You HAVE to do those things to have SSL over port 8080. After that you can follow anyone of the 2 links in my previous post.

Sorry, I missed that step. I did not enable ssl. Since I'm supporter of this site I do have ISPconfig manual.

No, I do not need SuExec.

After enabling ssl now I'm able to access roundcube
by typing http://www.tld.com/webmail which redirects me to https://www.tld.com:8080/webmail/ but I get the following error:

DATABASE ERROR: CONNECTION FAILED!

Unable to connect to the database!
Please contact your server-administrator.


If I remember correctly after I issued apt-get install roundcube command it asked if I wanted to auto configure DB, I selected no, I can't quote exact phrase but it was confusing and I thought it would mess up ISPconfig DB.

8omas 5th March 2011 13:24

This step would simply create the necessary roundcube db. It would ask for a user and a pass.
Remove (purge) and reinstall round cube

8omas 5th March 2011 14:17

Maybe I must include this to the guide.
When you run apt-get install roundcube, then you'll be asked about the database system to use (I use mysql). After that you'll be asked for the password of the db admin user (usually root). At the end you'll be asked for the password of roundcube database (the db-config system will create the roundcube database and the roundcube user)

If all the above do not help (and you cannot recreate or configure the db) then:
Code:

apt-get remove --purge roundcube roundcube-mysql
apt-get install  roundcube roundcube-mysql
dpkg-reconfigure roundcube-core

The last one will ask you a lot of questions (assuming that you install on a single server installation, I 'll post some possible answers):
1) ... IMAP = leave blank or enter localhost or even your server's full hostname
2) language = whatever you want
3) Reinstall database? = Yes
4) Database type = mysql
5) Connection method = unix socket
6) Name of the database's administrative user root (almost always .. few people changes this)
7) root password = the administrative user's password (this is needed to create the roundcube db and user)
8) username for roundcube = roundcube (or whatever you want)
9) database name for roundcube = roundcube (or whatever you want)
10) Web server(s) to configure automatically = apache2 (possibly)

If you already created the db, then in the last step you'll get an error. Ignore it, remove the db (roundcube's db) and the roundcube user, with the phpmyadmin and rerun the dpkg-reconfigure roundcube-core.

JohnnyBeGood 5th March 2011 22:35

1 Attachment(s)
Quote:

Originally Posted by 8omas (Post 252724)
Maybe I must include this to the guide.
When you run apt-get install roundcube, then you'll be asked about the database system to use (I use mysql). After that you'll be asked for the password of the db admin user (usually root). At the end you'll be asked for the password of roundcube database (the db-config system will create the roundcube database and the roundcube user)

If all the above do not help (and you cannot recreate or configure the db) then:
Code:

apt-get remove --purge roundcube roundcube-mysql
apt-get install  roundcube roundcube-mysql
dpkg-reconfigure roundcube-core

The last one will ask you a lot of questions (assuming that you install on a single server installation, I 'll post some possible answers):
1) ... IMAP = leave blank or enter localhost or even your server's full hostname
2) language = whatever you want
3) Reinstall database? = Yes
4) Database type = mysql
5) Connection method = unix socket
6) Name of the database's administrative user root (almost always .. few people changes this)
7) root password = the administrative user's password (this is needed to create the roundcube db and user)
8) username for roundcube = roundcube (or whatever you want)
9) database name for roundcube = roundcube (or whatever you want)
10) Web server(s) to configure automatically = apache2 (possibly)

If you already created the db, then in the last step you'll get an error. Ignore it, remove the db (roundcube's db) and the roundcube user, with the phpmyadmin and rerun the dpkg-reconfigure roundcube-core.

Thank you!
I works now. Finally webmail works because I gave up on trying to get SquirrelMail to work with ISPconfig.
Attached is the step that I messed up and selected "No"
If you can please edit your tutorial and add above instructions it might help some newbie like me :D

8omas 6th March 2011 00:35

You are right. After your previous post, I realized this and I already updated the guide.
Thanks for the suggestion


All times are GMT +2. The time now is 04:32.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.