HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   updated Lenny to Squeeze got some probs (http://www.howtoforge.com/forums/showthread.php?t=51684)

Ovidiu 1st March 2011 00:35

updated Lenny to Squeeze got some probs
 
Server was setup according to the perfect debian lenny with ISPCFG3 setup.

I had an alias set up in /etc/apache2/apache2.conf so that any domain can add /webmail/ to its end and use squirrelmail.
This is no longer working the error log says:


[Tue Mar 01 00:31:29 2011] [error] [client 93.222.116.130] Premature end of script headers: index.php
[Tue Mar 01 00:31:29 2011] [error] [client 93.222.116.130] SoftException in Application.cpp:221: File "/usr/share/squirrelmail//index.php" is not in document root of Vhost "/var/www/zice.ro/web"

not sure where this check comes from now... I'd like to remove it again.

running : dpkg-reconfigure sysv-rc

tells me: Unable to migrate to dependency-based boot system

Tests have determined that problems in the boot system exist which prevent migration to dependency-based boot sequencing:

insserv: warning: script 'K01mydns' missing LSB tags and overrides, insserv: warning: script 'mydns' missing LSB tags and overrides,

any hints?

Ovidiu 1st March 2011 12:40

Just realized my server was set up according to:

The Perfect Server Debian Lenny (Debian 5.0) With MyDNS & Courier [ISPConfig 3]

but it seems for squeeze only this one is available:


The Perfect Server Debian Squeeze (Debian 6.0) With BIND & Courier [ISPConfig 3]


what do you suggest? Should I change my set up according to the BIND one replacing mydns?

Ovidiu 1st March 2011 14:07

The alias I mentioned that doesn't work anymore looks like this and was working before the upgrade:

Code:

Alias /webmail /var/www/webmail/

<Directory "/var/www/webmail/">
Options Indexes FollowSymlinks
AllowOverride None
Order allow,deny
Allow from all
AddDefaultCharset off
</Directory>


falko 1st March 2011 16:44

Not sure, but maybe your alias is conflicting with the alias in /etc/apache2/conf.d/squirrelmail.conf? Take a look at http://www.howtoforge.com/enabling-s...r-debian-lenny

Ovidiu 1st March 2011 19:29

will see if I can use that tutorial to get it working. I had used the current solution for a couple of years and it worked until the update to squeeze,

what about the perfect server installation? can I continue running mydns with squeeze and somehow get rid of that warning?

Ovidiu 1st March 2011 19:35

checked that tutorial. the only difference ot what I was doing is this step:

Quote:

Now go to the PHP open_basedir field on the Options tab of your web site in ISPConfig and add the directories /usr/share/squirrelmail and /etc/squirrelmail (that's the directory where SquirrelMail's configuration is stored) to the line,
I think its quite bothersome to add those lines to every vhost.

where would I add those fi I want them enabled globally to ANY vhost? (existing and future)

###edit###
never mind I found the option inside the ispcfg3 setup.

Ovidiu 2nd March 2011 11:58

unfortunately setting those lines in the openbasedir field of the server config doesn't seem to affect existing hosts.
after saving it manually into 1 test-vhost, I navigate to this test URL but the browser download the file instead of displaying the php?

here is the link to show you what is happening: http://www.rum-reisen.de/webmail/src/login.php or simply: http://www.rum-reisen.de/webmail/ second one should also work.

Not sure why the tutorial linked above by falko doesn't work for me?
besides that this setup worked perfectly before hte upgrade. what could have changed?
any hints what to check?

ah, forgot to mention that the link to myserver.com:8080/webmail works !?

falko 2nd March 2011 19:24

Is PHP enabled for that web site?

Quote:

can I continue running mydns with squeeze and somehow get rid of that warning?
You can continue to use MyDNS, but I'm not sure how to get rid of the warning.

Ovidiu 3rd March 2011 00:18

PHP is enabled for that site.

I can live with that warning then, its just I didn't dare reboot :-)

the point is that I might move onto a new server so the problems wouldn't be so important. would you mind having a look at this post too: http://www.howtoforge.com/forums/sho...11&postcount=9

I am basically facing the choice of going to a new BIGGER server hoping my performance issues and these will be solved or go smaller and leave out ISPCFG, trying something along the lines of using a low-end server and set it up according to lowendbox.com fast, dirty,running nginx on cheap hardware.

If I could sort out the performance issues mentioned in the other thread I linked to I could go ahead and move to the new server, set it all up cleanly for ispcfg3 and squeeze.

till 3rd March 2011 01:07

I just answered in your other thread. Your server is fine, no need for a bigger one. Neither memory nor cpu are exhausted. The server runs nearly idle.


All times are GMT +2. The time now is 00:22.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.