HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   My Named service isn't working properly (http://www.howtoforge.com/forums/showthread.php?t=51611)

all 24th February 2011 16:37

My Named service isn't working properly
 
Hi,

I have setup two name servers

ns1.example.com x.x.x.183
ns2.example.com x.x.x.184

cat pri.example.com

$TTL 86400
@ IN SOA ns1.example.com. mail.example.com. (
2011022413 ; serial, todays date + todays serial #
8800 ; refresh, seconds
7200 ; retry, seconds
604800 ; expire, seconds
86400 ) ; minimum, seconds
;

mail A x.x.x.142
ns1 A x.x.x.183
www A x.x.x.142
example.com. A x.x.x.142
example.com. MX 10 mail.xpert-zone.com.
example.com. NS ns1.xpert-zone.com.
example.com. NS ns2.xpert-zone.com.


[root@heavysrv named]# dig localhost

; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_5.3 <<>> localhost
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61992
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;localhost. IN A

;; ANSWER SECTION:
localhost. 10800 IN A 127.0.0.1

;; Query time: 0 msec
;; SERVER: 213.133.98.98#53(213.133.98.98)
;; WHEN: Thu Feb 24 21:05:25 2011
;; MSG SIZE rcvd: 43




[root@heavysrv named]# dig yahoo.com

; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_5.3 <<>> yahoo.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 25941
;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 7, ADDITIONAL: 7

;; QUESTION SECTION:
;yahoo.com. IN A

;; ANSWER SECTION:
yahoo.com. 20950 IN A 72.30.2.43
yahoo.com. 20950 IN A 98.137.149.56
yahoo.com. 20950 IN A 209.191.122.70
yahoo.com. 20950 IN A 67.195.160.76
yahoo.com. 20950 IN A 69.147.125.65

;; AUTHORITY SECTION:
yahoo.com. 172150 IN NS ns2.yahoo.com.
yahoo.com. 172150 IN NS ns1.yahoo.com.
yahoo.com. 172150 IN NS ns5.yahoo.com.
yahoo.com. 172150 IN NS ns4.yahoo.com.
yahoo.com. 172150 IN NS ns3.yahoo.com.
yahoo.com. 172150 IN NS ns6.yahoo.com.
yahoo.com. 172150 IN NS ns8.yahoo.com.

;; ADDITIONAL SECTION:
ns1.yahoo.com. 170304 IN A 68.180.131.16
ns2.yahoo.com. 170304 IN A 68.142.255.16
ns3.yahoo.com. 170304 IN A 121.101.152.99
ns4.yahoo.com. 170303 IN A 68.142.196.63
ns5.yahoo.com. 170304 IN A 119.160.247.124
ns6.yahoo.com. 170334 IN A 202.43.223.170
ns8.yahoo.com. 170354 IN A 202.165.104.22

;; Query time: 0 msec
;; SERVER: 213.133.98.98#53(213.133.98.98)
;; WHEN: Thu Feb 24 21:06:01 2011
;; MSG SIZE rcvd: 345


but dig example.com

[root@heavysrv named]# dig example.com

; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_5.3 <<>> example.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 18306
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;example.com. IN A

;; Query time: 2 msec
;; SERVER: 213.133.98.98#53(213.133.98.98)
;; WHEN: Thu Feb 24 21:06:17 2011
;; MSG SIZE rcvd: 32




where example.com is my domain.

Regards
All

all 24th February 2011 18:33

lame server resolving 'example.com' (in 'example.com'?): x.x.x.183#53
lame server resolving 'example.com' (in 'example.com'?): x.x.x.184#53
lame server resolving 'www.example.com' (in 'example.com'?): x.x.x.183#53
lame server resolving 'www.example.com' (in 'example.com'?): x.x.x.184#53
lame server resolving 'www.example.com' (in 'example.com'?): x.x.x.183#53
lame server resolving 'www.example.com' (in 'example.com'?): x.x.x.184#53
lame server resolving 'www.example.com' (in 'example.com'?): x.x.x.183#53
lame server resolving 'www.example.com' (in 'example.com'?): x.x.x.184#53
lame server resolving 'www.example.com' (in 'example.com'?): x.x.x.183#53
lame server resolving 'www.example.com' (in 'example.com'?): x.x.x.184#53
lame server resolving 'www.example.com' (in 'example.com'?): x.x.x.183#53
lame server resolving 'www.example.com' (in 'example.com'?): x.x.x.184#53
lame server resolving 'www.example.com' (in 'example.com'?): x.x.x.184#53
lame server resolving 'www.example.com' (in 'example.com'?): x.x.x.183#53
lame server resolving 'www.example.com' (in 'example.com'?): x.x.x.183#53
lame server resolving 'www.example.com' (in 'example.com'?): x.x.x.184#53
lame server resolving 'www.example.com' (in 'example.com'?): x.x.x.184#53
lame server resolving 'www.example.com' (in 'example.com'?): x.x.x.183#53
lame server resolving 'example.com' (in 'example.com'?): x.x.x.184#53
lame server resolving 'example.com' (in 'example.com'?): x.x.x.183#53
lame server resolving 'ns1.example.com' (in 'example.com'?): x.x.x.184#53
"/var/named/chroot/var/named/data/named.run" 285L, 23903C


these are logs any help?

all 24th February 2011 19:12

no problem i fixed it multiple issues with ispconfig though


All times are GMT +2. The time now is 01:53.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.